question about "QoS policing"

Unanswered Question
Jan 7th, 2010
User Badges:

hi all,


I wonder why rate limit is not operating as configuring.


configuration

==================================================

access-list 10 permit any


policy-map test1
  class class-default
   police cir 1000000    conform-action transmit     exceed-action drop



interface GigabitEthernet2/5.101
encapsulation dot1Q 101
ip vrf forwarding vrf101
ip address 8.1.101.1 255.255.255.252
no cdp enable
service-policy input test1
service-policy output test1

=================================================


as above configuration

we are using policing to limit the speed of customer.


but gi2/5 is not operated as configuring.

it is sending 1.04Mbps although configruing 1.00Mbps.


PE008#sh int sum

Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL
-------------------------------------------------------------------------

* GigabitEthernet2/5       0     0    0     0 80000000  116279 1040000  1512    0



if i change the speed 1Mbps into 2Mbps, then it sends 2.08Mbps

(1Mbps configure=> it works 1.04Mbps, 2Mbps configure => 2.08Mbps)


who's knows about this?


(show run is attached and you can read it by wordpad)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Fri, 01/08/2010 - 01:00
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sanghee,

depending on the size of packets used in the test the different OSI layers overheads take a role.

The policer may be not taking in account the whole L2 Frame overheads (for example the 4 byte FCS or 802.1Q tag)


Also the policer has a resolution capability that is probably it works on steps of N kbps where N can be 64 kbps and so it tries to go near the rate you have configured.


What size are the frames you are sending to test the policer? How many frames per second are you sending?


Hope to help

Giuseppe

Actions

This Discussion