Patrick Born Fri, 01/08/2010 - 13:50
User Badges:
  • Cisco Employee,

Hi camronjohnson,


The Configuring Cisco SPA500S Attendant Console document describes both the manual and zero-touch configuration steps: https://www.myciscocommunity.com/docs/DOC-11522


The document is targeted at Asterisk as call-control, but the BLF information on pages 8 and 9 are relevant.


Regards,



Patrick

-----------

camronjohnson Fri, 01/08/2010 - 13:53
User Badges:

Is there a way to do this without the use of the SPA500S Attendant Console and Use only the phone itself?

Patrick Born Sun, 01/10/2010 - 06:09
User Badges:
  • Cisco Employee,

Hi camronjohnson,


Sorry, I thought you had a typo and meant to type "On SPA500S", turns out you really meant "No SPA500S"


Yes, unused line keys on SPA5xx IP phones support Broadsoft BLF. This is documented in the SPA5xx Admin Guide:
http://tools.cisco.com/search/display?url=http%3A%2F%2Fwww.cisco.com%2Fen%2FUS%2Fdocs%2Fvoice_ip_comm%2Fcsbpipp%2Fip_phones%2Fadministration%2Fguide%2Fspa500_admin.pdf&pos=1&strqueryid=2&websessionid=ehoQWTwEoaQg5MstdKDgz7A

Take a look at page 23, "Assigning Busy Lamp Field, Call Pickup, and Speed Dial Functions to Unused Lines on a Cisco SPA 500 Series IP Phone"


Phone related documents are linked from the Community phone page: https://www.myciscocommunity.com/docs/DOC-2148


Regards,



Patrick

-----------

camronjohnson Mon, 01/11/2010 - 06:58
User Badges:

Ok, I have attempted to use that configuration, however I just see a flashing orange led for that line. What issues are usually associated with this type of error?

Patrick Born Tue, 02/23/2010 - 06:30
User Badges:
  • Cisco Employee,

Hi camronjohnson,


What call-control and version are you using, Asterisk, Broadsoft, something else?

BLF functionality must be enabled on the server so that it sends SIP NOTIFY to the phone/s monitoring status.


Regards,



Patrick

----------

camronjohnson Tue, 02/23/2010 - 06:54
User Badges:

I believe I am using Broadsoft version 14. The BLF feature is enabled.

camronjohnson Mon, 03/01/2010 - 14:49
User Badges:

This appears to have fixed the issue, after I managed to get the correct sub and user domain combination from the sip log messages. I am still attempting to acquire a SPA500S to get the automatic configuration update.

robray_sc Tue, 12/07/2010 - 08:56
User Badges:

Did you ever get the Automatic configuration for the BLFs to work?

camronjohnson Tue, 12/07/2010 - 09:26
User Badges:

No, it was all still a manual configuration. We never ordered a SPA500S to test with and ultimately we went in a different equipment direction. Since it was all still a manual process any way.

Actions

This Discussion

Related Content