Patch rollup for Cisco Secure ACS 4.2 fails.

Unanswered Question
Jan 8th, 2010

I've got 2 freshly installed ACS 4.2 for Windows servers and I need to apply the latest patch rollup before I build the configurations.  I stopped the ACS services and ran Acs- to install the patches.  The application begins running fine but fails on upgrading the database and then none of the ACS services would start.  I was able to restore the files from the backup that runs with the patch utility and get ACS functioning again.  What am I missing - does the patch rollup require any specific Microsoft Patches to be installed or something like that?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Erick Delgado Fri, 01/08/2010 - 18:28


It is pretty streight forward just execute the exe file and the exe will stop your services and then install the software.

What is the windows version?

Could you please let me know the exact acs version? you can check that by clicking the cisco logo

Also I will suggest to install ACS 4.2.1 that will include all the ACS 4.2 patches and also include new features.


sean_jaehne Mon, 01/11/2010 - 07:50


Thanks for the feedback.  My versions are as follows:

Server OS - Windows Server 2003 R2

Cisco Secure ACS - 4.2.(0) Build 124

I can't really go to 4.2.1 at this time.  I need to figure out how to make what we've got work.


Richard Jaehne

Jatin Katyal Sun, 01/10/2010 - 02:13


This time I would recommend you to copy and paste the Acs- in the ACS install directory and then execute the file. You will see whats going in the backround via cmd window.

Before you start again, please make sure whether the last attempt went fine or not by checking the acs version.




Plz rate helpful posts-

sean_jaehne Mon, 01/11/2010 - 07:45

Thanks for the feedback.  I attempted the patch rollup install again and it failed in the same place - on the database upgrade.  I did think of one thing.  Do I need to have my antivirus/protection services disabled prior to installing the rollup?

Also my versions are as follows:

Server OS - Windows Server 2003 R2

Cisco Secure ACS - 4.2.(0) Build 124


Richard Jaehne

sean_jaehne Thu, 01/14/2010 - 08:31

So I've disabled my antivirus and tried the rollup installation again.  It fails in the same place -with the database update.  Has anyone seen this behavior with updating ACS before?

sean_jaehne Wed, 01/20/2010 - 06:45

I finally got the patch to go through.  I ended up completely removing ACS then reinstalling it.  After that the patch rollup installation went through the first time.

marekbudzisz Thu, 03/29/2012 - 06:24


I have the same problem but on 4.1 ACS ver.

Have you solved this problem, yet?




This Discussion

Related Content