3560 Inter vlan

Unanswered Question
Jan 10th, 2010
User Badges:

Hi friends,


i am saravanan from Bangalore. I have one cisco 3560 switch and some L2 switches also.


i want to create inter vlan routing in the 3560. I already tried to enable ip routing command.

Then i tried to create routing protocol also.


so please give a valuable solution. IOS version is 12.2 (3560)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Sun, 01/10/2010 - 10:33
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

psaravanan wrote:


Hi friends,


i am saravanan from Bangalore. I have one cisco 3560 switch and some L2 switches also.


i want to create inter vlan routing in the 3560. I already tried to enable ip routing command.

Then i tried to create routing protocol also.


so please give a valuable solution. IOS version is 12.2 (3560)


Saravanan


What IOS feature set are you running and which routing protocol are you trying to use ?


To get the feature set run a "sh version" on the switch.


Jon

Leo Laohoo Sun, 01/10/2010 - 13:04
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

pnicolette Sun, 01/10/2010 - 13:14
User Badges:

One way is to create an interface for each vlan (they don't exist automatically), and give each interface an IP on the correct subnet. 


My example: 


VLAN 2 uses 10.1.2.0/24

VLAN 3 uses 10.1.3.0/24


ip routing


interface vlan 2

  no shutdown

  ip address 10.1.2.1 255.255.255.0


interface vlan 3

  no shutdown

  ip address 10.1.3.1 255.255.255.0


Unless I've forgotten something, hosts can now be configured to use the 3560's IP on their subnet/vlan as the default gateway.  They will then be able to reach devices on the other subnet/vlan.


Paul


P.S.  Another way (with a more complex scenario) is described at http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008015f17a.shtml

vvasisth Mon, 01/11/2010 - 02:15
User Badges:
  • Silver, 250 points or more

there are 2 types of IOS images SMI and EMI

on SMI images you can only run intervlan routing and RIp

on the other hand EMI you can all other routing protocals like EGIRP , OSPF etc..


i am not sure what IOS you have but for inter vlan routing you just need to assign IP to diff vlans and enable routing by "ip routing " command.


Hope that helps.


Regards,

Varun

psaravanan Mon, 01/11/2010 - 03:39
User Badges:

Thanks for ur reply,


I am using c3560-ipbase-mz.122-25.SEB4.bin image. I enclose my configuration.


Conf:


version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CentralSwitch
!
enable secret 5 $1$Ir96$diD5JCZAF/uZZAxUnWsSw.
!
no aaa new-model
ip subnet-zero
ip routing
!
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree logging
spanning-tree extend system-id
no spanning-tree vlan 1
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
!

.

.


interface GigabitEthernet0/21
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
ip address 200.0.0.213 255.255.240.0
!
interface Vlan2
ip address 192.168.10.1 255.255.255.0
!
router rip
network 192.168.10.0
network 200.0.0.0
!
ip default-gateway 200.0.0.10
ip classless
ip http server




till routing between vlan1 to vlan 2 is not able to ping.

vvasisth Mon, 01/11/2010 - 03:47
User Badges:
  • Silver, 250 points or more

If you remover RIP config also it should work fine.

Did you check the default garteway on the PC ? it should be the vlan ip of there respective vlans


just to eliminate an pc related issues on the switch try this

ping 192.168.10.1 source vlan1

if it pings this means intervaln routing is working fine


Let me know the results.


regards,

varun

psaravanan Mon, 01/11/2010 - 04:06
User Badges:

Thanks for ur reply,


i already removed rip protocol and put default gateway as vlan 2 ip of my vlan 2 network. Then i can able to ping my default gateway (vlan2), but when i try to ping vlan 1 then request time out came.


Is there any option to put static routing.

Abdullah Net Sat, 03/27/2010 - 23:13
User Badges:

I have the same problem .. InterVlan is not working even though i typed "IP ROUTING" in the global config mode.

Could someone help?

Actions

This Discussion