ESW-540-24P-K9 passing VLAN's to 2950

Unanswered Question
Jan 10th, 2010

Strange issue.  I have a new ESW-540-24P-K9 programmed with the same VLAN's as a 2950.  When I connect the ESW to the 2950 via a combo port using a CAT5 cable it will pass VLAN information between the 2 switches and everything works fine.  When I use the same combo port but connect via an SFP to the 2950's GBIC it will not pass VLAN data.  All ports being used are set up as trunking ports and I have tried several configurations on both the 2950 and ESW.  no matter what I try the ports on the ESW will only pass VLAN traffic if using copper...not the SFP.  Only difference between the 2 set ups is that the combo port on the ESW connects to another copper port on the 2950 not the GBIC port when it works, but the GBIC port and coper port on the 2950 are programmed exactly the same. Any thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alejandro Gallego Sun, 01/10/2010 - 19:19

If you have the GBiC ports configured using the smart port wizzard go ahead and clear that by running the wizard again but chose "other". That will default the port and remove all other parameters. Make sure that you have not removed auto neg on the GBiCs (either side) and configure the port as a trunk. Also do not forget about STP, check to make sure you are running the same mode (either RSTP or STP). This is all assuming your native VLAN is still 1.

Let us know if that helps.

bdaly6969 Tue, 01/12/2010 - 20:46

Tried setting things through smartports as suggested.  Using CNA and web config for 2950 and CCA and web config for ESW just to see if one or the other was causing problems.  It made no difference in how the ESW handled VLAN traffic.  Copper works, SFP to GBIC doesn't.  I even tried experimenting with smartports on both 2950's I have at the site that are connected via fiber.  If I set the GBIC ports to "Switch" in smartports the 2950's stopped passing VLAN traffic.  I even tried to go in and directly set the GBIC ports to pass the specific VLANS then to pass all VLAN traffic, different trunk port settings etc. and nothing worked other than reloading the configs.  Any other ideas I can try?

John Platts Tue, 01/12/2010 - 21:57

Are you using the correct kind of GBICs on your switches? The ESW switches are designed to be used with the Cisco Small Business GBIC's, which also are used on the Linksys and Cisco Small Business managed switches. The Catalyst and Catalyst Express switches are designed to be used with Cisco GBIC's designed for Catalyst and Catalyst Express switches. Be sure that you are using the right kind of GBIC modules for your switch. GBIC's for Catalyst and Catalyst Express Switches have Cisco branding and part numbers starting with GLC.

In addition, I have read over the release notes for firmware version 2.1.16 of the ESW 500 switches. The new firmware allows all of the VLANs on the ESW 500 switches to be trunked, and might actually solve your problem.

Actions

This Discussion