Cisco ACE context login issue

Unanswered Question
Jan 11th, 2010
User Badges:

Hi,


I am new to ACE and I am having a problem with logging into a context with it's management IP address. I get " Invalid login" message when I try to login to the context (ip: 172.16.0.6) (No spelling or typing mistakes I assue you) .I can login to the Admin context without any issues. Following is the config overview:


Admin Context:

Total Vlans: 1 (Vlan 4) used for management connectivity


XYZ_VC (User Context)

Total Vlans: 3 (Vlan 2, Vlan 3, Vlan 4) Vlan 4 used for management connectivity and belongs to same subnet as Vlan 4 of Admin Context.


I have also uploaded the config files for more details.


Please could anyone point me in the right direction?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Mon, 01/11/2010 - 01:06
User Badges:
  • Cisco Employee,

Try to create another username "cisco" with password "cisco123".

See if you can login with that user.

Just to verify if everything fails or just the ones you configured.


Thanks.


G.

Muhammad Khan Mon, 01/11/2010 - 03:27
User Badges:

Thank you for your reply gdufour.


I have already tried by creating a different user account as well as seperate domain. Following is my user contect config:


Also, If I enable int vlan 2 ACE assumes that as management Interface which is bit strange... any ideas?? (Am I missing anything... new to ACE so my knowledge is limited)


XYZ-ACE-01/XYZ_VC# sh run
Generating configuration....

no ft auto-sync startup-config

logging enable
logging timestamp
logging trap 7
logging buffered 5

telnet maxsessions 2

ssh maxsessions 1



access-list ALL line 8 extended permit ip any any
access-list ALL line 9 extended permit icmp any any


probe http Probe_HTTP
  interval 5
  passdetect interval 60
  expect status 200 200
  open 10


rserver host Server1
  ip address 192.168.0.23
  conn-limit max 4000000 min 4000000
  inservice


rserver host Server2
  ip address 192.168.0.2
  conn-limit max 4000000 min 4000000
  inservice


serverfarm host Farm1
  probe Probe_HTTP
  rserver Server1 80
    conn-limit max 4000000 min 4000000
    inservice
  rserver Server2 80
    conn-limit max 4000000 min 4000000
    inservice


sticky http-cookie XYZ_Cookie XYZ_Cookie
  serverfarm Farm1


class-map type management match-any Management
  201 match protocol http any
  202 match protocol https any
  203 match protocol icmp any
  204 match protocol kalap-udp any
  205 match protocol ssh any
  206 match protocol telnet any
  207 match protocol xml-https any


class-map match-all XYZ_VS
  2 match virtual-address 10.0.0.3 tcp eq www


policy-map type management first-match Management
  class Management
    permit


policy-map type loadbalance first-match XYZ_VS-l7slb
  class class-default
    serverfarm Farm1


policy-map multi-match int3
  class XYZ_VS
    loadbalance vip inservice
    loadbalance policy XYZ_VS-l7slb


interface vlan 2
  description Server VLAN
  ip address 192.168.0.6 255.255.255.0


interface vlan 3
  description "Client VLAN"
  ip address 10.0.0.1 255.0.0.0
  service-policy input int3
  no shutdown


interface vlan 4
  description Management VLAN
  ip address 172.16.0.6 255.255.0.0
  access-group input ALL
  service-policy input Management
  no shutdown


domain XYZ_DM
  add-object all


ip route 0.0.0.0 0.0.0.0 172.16.0.5

username XYZadmin password 5 role Admin domain default-domain
username XYZusr password 5 role Network-Monitor domain XYZ_DM

Thanks in advance.

iwearing Fri, 06/11/2010 - 07:22
User Badges:

Hi,


Did you ever get a resolution to this. I have the same problem. I can Login to the Admin Context but no other contexts.


Ian.

iwearing Fri, 06/11/2010 - 07:46
User Badges:

I managed to resolve this. Changed password to clear text option.


Ian.

Muhammad Khan Fri, 06/11/2010 - 07:47
User Badges:

Hi Ian,


Yes i did find the solution. It was a very basic error I made. when creating user I specified password as encrypted while password itself was clear text


username ABC password 0 pass123

Actions

This Discussion