Nortel IP Phone, C3550 and VoiceVLAN

Unanswered Question

Hi!

I have a strange problem.

I have Nortel IP Phones, the 1120E Model, and I have configured DHCP to provide Voice VLAN information, and the switches have this configuration on the ports:

switchport access vlan 11
switchport mode access
switchport voice vlan 450
spanning-tree portfast

This works fine on C2960's, C3560's and even C2950's, but not on my C3550 switches.

I have upgraded the C3550's to the latest firmware, but no.

Are there som tricks to get this working on C3550. I am completely out of ideas right now.

Thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
josh.l.anderson Mon, 01/11/2010 - 07:55

Seems like that should work to me. We have a site with Avaya VoIP phones using a 3750 switch, and a similar configuration works correctly for us. Double check just to make sure that your Voice VLAN exists on your switch (show vlan). Are you seeing mac-addresses from the Nortel phones on the data VLAN?

Hi, thanks for answering.

Yes, I have checked the config. It works perfectly fine on the C2950 standing next to the C3550, both of then set up as VTP Clients to the same VTP domain. Ports on both switches are identical set up.

I have tested it with 2 different C3550's, on 2 different locations, and with 2 different IOS versions. It must have something do with with the initial configuration on C3550 switches.

Thanks.

josh.l.anderson Mon, 01/11/2010 - 14:54

Do you have Layer 3 routing enabled on the 3550? If so, try disabling that unless you need it.

As another test, on your 3550, turn on "term mon" and turn on "debug ip dhcp server packet". Then reboot one of your phones and provide the debug output. That will show what the switch is seeing at least. You may have to add "ip helper-address x.x.x.x" to point your VLAN interfaces to your DHCP server depending on your configuration.

Actions

This Discussion