CUC 7.x - No Ringback When Releasing to Switch...

Answered Question
Jan 11th, 2010
User Badges:

Here is my scenario:


  • The customer would like the Front desk phone to ring for 20 seconds
    • If no answer between the hours of 0800 and 1700 the call should roll to a hunt group for all engineers
      • If no answer there it will forward to the answering service
    • If no answer between the hours of 1700 and 0800 the call should be forwarded to the answering service


The front desk phone is configured to forward to voicemail if there is no answer in 20 seconds.


Once the call hits voicemail it is transferred to a "Engineers" call handler.


The call handler is on a schedule and configured as described above.


Here is the issue:


When the call goes to voicemail and CUC is supposed to release it to the switch all the person on the phone hears is dead air yet the hunt group is ringing.


I know that when you get dead air such as this it usually means that CUC is not releasing the call to the switch properly but I cannot seem to nail it down.


Any assistance would be greatly appreciated!


Thanks!


Dan

Correct Answer by Tommer Catlin about 7 years 6 months ago

Im pretty sure you have an issue at the gateway/CUCM with ringback.    Also, it would on hurt to upgrade your CUCM and CUC when you get a chance.  There are a couple reports of bugs with SIP and transfers.


here is one:


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCso04169&from=summary


If there is one, there are typically others


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCta92144&from=summary


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsm31029&from=summary



You can run a quick test and use an internal IP phone to call CUC Call Handler.  (Create a CTI, forward to unity,)  Hit the default opening greeting, enter in a mailbox to transfer to, Unity should do a transfer back out to CUCM and you will hear ring.


I suspected the call was coming from external.  There have been issues with PIMGs, T1 and H323 connections via CUCM to CUC and no ring backs.



Without some traces, it will be hard.  (its hard enough trying to find this needle)  but i suspect (or possibly) there is a command missing in the SIP gateway to provide ringback.


Here is an H323 no ringback doc also.


http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080094c33.shtml


Hope this helps!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Tommer Catlin Mon, 01/11/2010 - 14:46
User Badges:
  • Green, 3000 points or more

Have you tried to release it to a non-hunt group number to see what happens?  If its consistantly dead air, then you know its a system wide problem with CUC.

dan@restech.net Mon, 01/11/2010 - 18:51
User Badges:

Thank you for the response!


I just tried it to an extension that is not a hunt group and got the same result...no ring back.


Any thoughts?


Dan

Tommer Catlin Mon, 01/11/2010 - 19:52
User Badges:
  • Green, 3000 points or more

Just to confirm, it is in fact ringing the phone on transfer right?

dan@restech.net Mon, 01/11/2010 - 20:00
User Badges:

Affirmative,


The phone that is receiving the transfer is ringing but the calling party is not receiving a ringback tone.


Dan

Tommer Catlin Mon, 01/11/2010 - 20:05
User Badges:
  • Green, 3000 points or more

sorry for the questions....  I should have added some more in.


SCCP voicemail ports between CUCM and CUC?



Version of CUC and CUCM?


How did the call come in?   Does it matter if the call came in through the PSTN or another IP phone?

dan@restech.net Mon, 01/11/2010 - 20:22
User Badges:

No worries!


  1. SCCP - Yes
  2. CUCM - 7.0.1.11000-2 ; CUC - 7.0.1.10000-323
  3. The call comes in through a SIP trunk from our Telco.
  4. I just did a test and if the call originates from the SIP trunk there is no ringback but if it originates from another IP phone on the network ringback is heard.


Dan

Correct Answer
Tommer Catlin Mon, 01/11/2010 - 20:35
User Badges:
  • Green, 3000 points or more

Im pretty sure you have an issue at the gateway/CUCM with ringback.    Also, it would on hurt to upgrade your CUCM and CUC when you get a chance.  There are a couple reports of bugs with SIP and transfers.


here is one:


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCso04169&from=summary


If there is one, there are typically others


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCta92144&from=summary


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsm31029&from=summary



You can run a quick test and use an internal IP phone to call CUC Call Handler.  (Create a CTI, forward to unity,)  Hit the default opening greeting, enter in a mailbox to transfer to, Unity should do a transfer back out to CUCM and you will hear ring.


I suspected the call was coming from external.  There have been issues with PIMGs, T1 and H323 connections via CUCM to CUC and no ring backs.



Without some traces, it will be hard.  (its hard enough trying to find this needle)  but i suspect (or possibly) there is a command missing in the SIP gateway to provide ringback.


Here is an H323 no ringback doc also.


http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080094c33.shtml


Hope this helps!

dan@restech.net Mon, 01/11/2010 - 20:49
User Badges:

Thank you for all of the information!  I will digest all of this when I get to the office in the AM and report back.


I do need to get around to doing an upgrade...


Dan

dan@restech.net Tue, 01/12/2010 - 16:36
User Badges:

Here is what I did to get it working:


Under the Callmanger section of Service Parameters I set the "Send H225 User Info Message" to "Use ANN for Ring Back".


That will keep me going until I can dig into the SIP side.


Thanks for all the help!


Dan

Tommer Catlin Tue, 01/12/2010 - 16:41
User Badges:
  • Green, 3000 points or more

Funny, I had to turn on the same parameter in CUCM for something similar.   I was going CUCM----h323---h323--PBX.   For whatever reason, i was not getting ring back with this.  But if I had CUCM--h323-PBX..  I had ring back and it was fine.  After digging, and IOS upgrades, downgrades, etc...  something simple like that fixed it.


Glad you are good for now!

Actions

This Discussion

Related Content