nss4000 windows share permissions domain joined

Unanswered Question
Jan 12th, 2010

Hello –

I have moved the NSS4000 to another domain, and since then have not been able to access files within a share.  Within windows I can connect to the share and view the folder structure, however I cannot access ANY files within the folders. It gives me a permissions error.  I have blown out AD completely, reconfigured the domain, joined the NSS successfully to the domain and added my user into the read-write box within the nss config.  I still cannot access the files within the folders.  I have just upgraded to 1.16 firmware on the nss, and joined the nss back to the domain.  Still nothing.  I tried inheriting permissions within the security tab within windows – nothing.  I CAN access the files from an administrator account.  But when I add the specific user to the admins group, I still cannot access the files from this user.  I even copied the administrator account within AD and just changed the name to the user.  Still nothing.

Please assist!

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alejandro Gallego Fri, 01/15/2010 - 12:16

You will need to move the files out of the NSS and onto a Windows network share in order to break the permissions that were written from the previous domain. For testing just copy a directory on the NSS to a windows machine, and see if you are then able to access the files. Inheritance does not work on the NSS like you would expect on a NTFS share. Try that and let us know the outcome.

erdos_jonathan Fri, 01/15/2010 - 15:07

Thanks for the reply -

It doesn't seem like I can do a bulk move to another share.  It is also putting a 'read-only' attribute onto the folder that seems to clear when I click apply / ok, but when I access the properties again, the ready-only flag is checked.  Even when I apply it to the subfolders as well as the parent folder.

There has to be an easier way.

Alejandro Gallego Wed, 01/20/2010 - 21:27

Do not move the data from one NSS share to another, just from the NSS to a Windows PC directory. This action will break NTFS permissions (if they are hanging on) but will also allow the user to take control of the directory.

ReadOnlyAttrib.png

Ignore that attribute. If you are still not able to access the share you will need to take ownership of the directory once the data has been moved from the NSS.

Let us know if you are still having problems.

Actions

This Discussion

Related Content