Communications Manager 6.1.3 CCMUSER Page

Unanswered Question
Jan 12th, 2010

I am getting the following error when a user tries to log into the cc    

muser page. I do not have this problem witht the ccmadmin

page.

Any one have a resolution?

Here is the error.

HTTP Status 500 -


type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.IllegalStateException
     org.apache.catalina.connector.ResponseFacade.sendRedirect(ResponseFacade.java:432)
     com.cisco.ccm.user.servlets.CCMUserSecureRequestProcessor.processRoles(CCMUserSecureRequestProcessor.java:122)
     org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:197)
     org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
     org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
     javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
     javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
     sun.reflect.GeneratedMethodAccessor29941.invoke(Unknown Source)
     sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     java.lang.reflect.Method.invoke(Method.java:585)
     org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:243)
     java.security.AccessController.doPrivileged(Native Method)
     javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
     org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:275)
     org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:161)
     java.security.AccessController.doPrivileged(Native Method)
     com.cisco.ccm.common.security.XSSFilter.doFilter(XSSFilter.java:115)
     sun.reflect.GeneratedMethodAccessor29944.invoke(Unknown Source)
     sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     java.lang.reflect.Method.invoke(Method.java:585)
     org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:243)
     java.security.AccessController.doPrivileged(Native Method)
     javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
     org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:275)
     org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:217)
     java.security.AccessController.doPrivileged(Native Method)
     com.cisco.ccm.admin.servlets.FormPostCharacterEncodingFilter.doFilter(FormPostCharacterEncodingFilter.java:482)
     sun.reflect.GeneratedMethodAccessor29946.invoke(Unknown Source)
     sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     java.lang.reflect.Method.invoke(Method.java:585)
     org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:243)
     java.security.AccessController.doPrivileged(Native Method)
     javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
     org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:275)
     org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:217)
     java.security.AccessController.doPrivileged(Native Method)
     com.cisco.ccm.common.security.ChangePasswordFilter.doFilter(ChangePasswordFilter.java:72)
     sun.reflect.GeneratedMethodAccessor29943.invoke(Unknown Source)
     sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     java.lang.reflect.Method.invoke(Method.java:585)
     org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:243)
     java.security.AccessController.doPrivileged(Native Method)
     javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
     org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:275)
     org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:217)
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
htluo Tue, 01/12/2010 - 15:34

This may or may not solve the problem, but could you go into CCMAdmin > User Managment > End User and see if there's a locale configured for the user?

Thanks!

Michael

josefgonzales Wed, 01/13/2010 - 05:47

The locale was set. I removed it and tried again with the same result.

Thanks for the suggestion.

htluo Wed, 01/13/2010 - 06:17

What permission the logon user has?  You might want to check to see if the user has "CCMuser administration role".

Michael

Actions

This Discussion