Intermittant bad requests

Unanswered Question
Jan 13th, 2010
User Badges:

Our UC -520 is apparently rejecting some calls. I suspect they may all be Vonage customers but I can't be sure.(yet). I cleared the sip-ua statistics and had our president call from his vonage line and checked the stats again. I showed badrequests 0/20. Is there any way to narrow that down to what's causing this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Wed, 01/13/2010 - 05:32
User Badges:
  • Blue, 1500 points or more

Please provide a "debug ccsip messages" for a failed call and also the running configuration of the system (remove passwords before posting). Was this working before?


Thanks,


Marcos

dhankins1 Wed, 01/13/2010 - 05:48
User Badges:

how exactly do I export our configuration to a file?

Marcos Hernandez Thu, 01/14/2010 - 05:24
User Badges:
  • Blue, 1500 points or more

You need to Telnet and authenticate to the UC500 and then type the following:


UC500>enable


UC500#debug ccsip messages 

SIP Call messages tracing is enabled


UC500#terminal monitor


Make the call and copy the output to a text file. then, disable the debug collection:



UC500#undebug all


Thanks,


Marcos

dhankins1 Thu, 01/14/2010 - 06:00
User Badges:

Thanks for the very quick response. We have a combined experience of over a century in this shop but I seem to be the one delegated to become our Cisco expert. I have attached the log although some of it seems truncated. It looks like the relevant stuff is there. I can send you a copy of our configuration file if that will help. Thanks again. Our president is breathing fire over this.

Steven Smith Thu, 01/14/2010 - 08:16
User Badges:
  • Gold, 750 points or more

You should upgrade to the 7.1.3 software pack.  It will fix the issue.  The problem is...



CSCsu57129: Comma in Caller ID prevents calls to reach in SIP - SIP  Trunk config
It doesn't like the comma in the from field.  The bug if fixed in 7.1.3 and newer software packs.  You can get those here...
dhankins1 Thu, 01/14/2010 - 12:55
User Badges:

Tried to update our UC 520 but we get this error that a TFTP server is running. We couldn't find one. After hours of effort, I unboxed a brand new XP computer, loaded CCA 2.2 on it and the update package to fix our original error. Same message. This computer is about an hour old and nothing has ever been run on it. Could there be an error in CCA? Is there a process to do this update by CLI?

Steven Smith Thu, 01/14/2010 - 14:13
User Badges:
  • Gold, 750 points or more

You should disable the firewall, antivirus, and only have one NIC connected.  Without seeing the computer, I can't tell you want it doesn't like, but there might be something running on the tftp port.


Close CCA and run a netstat -an

Post the output here.


Also, can you capture a screen shot of the error?  I believe it will give multiple problems that you could be having, one being tftp. 

dhankins1 Fri, 01/15/2010 - 05:16
User Badges:

It has been suggested that we may have a bad sector in our flash drive. Is there a way to test for that? I have included the output of the netstat -an command. I don't see any open ports that would cause this. I have tried 3 different computers now with the same error. Never had this issue before.

Actions

This Discussion

Related Content