Complex GRE tunnel: Help needed.

Unanswered Question
Jan 13th, 2010
User Badges:

Hi All.


Consider the following scenario.



Node A. --->Switch---->C7609--{...Internet..}--C7200--NodeB


Node A has IP 192.168.1.1

Node B has IP 192.168.1.2


So far I have a working gre tunnel between the routers.

How do I get Node A to talk to Node B ?


Any help appreciated.

Thanks,

Ken

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Wed, 01/13/2010 - 13:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Hi Ken,
Is this a trick question or are you going to post the config?

Armando Yesua G... Wed, 01/13/2010 - 13:51
User Badges:
  • Cisco Employee,
Consider the following topology

Router1 [S0](64.45.15.17) ------ Internet -------(65.17.89.11)[S0]Router2---192.168.1.0/24
        |_(10.0.0.1)_____________GRE Tunnel____________________(10.0.0.2)_|

Router1
*******

interface Tunnel0
ip address 10.0.0.1 255.255.255.252
tunnel source 64.45.15.17
tunnel destination 65.17.89.11

ip route 192.168.1.0 255.255.255.0 Tunnel0
ip route 65.17.89.11 255.255.255.255 Serial0

Router2
*******

interface Tunnel0
ip address 10.0.0.2 255.255.255.252
tunnel source 65.17.89.11
tunnel destination 64.45.15.17

ip route 64.45.15.17 255.255.255.255 Serial0

hope this helps.
madhaquer Thu, 01/14/2010 - 01:43
User Badges:

I have the basic tunnel between the cisco routers up but i suspect my whole approach seems wrong.



Node A. --->Switch---->C7609--{...Internet..}--C7200--NodeB


Node A has IP 192.168.1.1

Node B has IP 192.168.1.2


Unfortunatelly the iterfaces are all ethernet and it is the nodes that i need to get to talk.


madhaquer Mon, 02/01/2010 - 08:55
User Badges:

I have decided to go with an EoMPLSoGRE setup.


So far I have:

the gre tunnel up

the mpls l2transport vc up


the setup is:


asr1004====GRE====c7206


the xconnect is on ge interfaces in the 2 boxes and the ce is a pc on one end and a switch on the other.


My challenge is the vc does not seem to pass any traffic. Specifically when I sh mpls forwarding-table I see no bytes switched.

Also on the c7200 the outgoing interface is 'none'


All assistance will be appreciated.

jmurphy2 Tue, 03/30/2010 - 02:44
User Badges:
  • Cisco Employee,

The configuration for this is relatively straightforward, so if the code and platform you're operating support the feature you should be fine.


-Configure a GRE Tunnel between your PEs.

-Enable MPLS over Tunnel

-Establish Routing over Tunnel for LDP endpoints

-Verify LDP adjacency

-Configure Pseudowire Class with 'encapsulation mpls'

-Configure the xconnect on the Attachment Circuit.


Validate the state of your vc with the 'show mpls l2transport vc' command.


hth,


jm

Actions

This Discussion