Unable to access an outside server connected through a VPN tunnel at DMZ interface

Unanswered Question

Hi,




I have to access an outside server connected through a third party VPN tunnel at DMZ Interface on my ASA 5520. At the same time, outside secure server should be able to access two servers on my inside network as well. I have configured the CISCO ASA 5200 and outside server is able to access the inside servers but inside users are not able to access the outside server.



Inside Network--Third Party Firewall-----ASA 5520---Outside Network


                                                              l----DMZ-----Third Party VPN---Outside Server


Please find below the message captured through packet tracer


fx1(config)# packet-tracer input inside tcp 192.168.206.168 135 10.10.1.2 135


Phase: 1

Type: FLOW-LOOKUP
Subtype:
Result: ALLOW
Config:
Additional Information:
Found no matching flow, creating a new flow


Phase: 2

Type: ROUTE-LOOKUP
Subtype: input
Result: ALLOW
Config:
Additional Information:
in   10.0.0.0        255.0.0.0       Inside


Phase: 3

Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:


Phase: 4

Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:


Phase: 5
Type: IDS
Subtype:
Result: ALLOW
Config:
Additional Information:


Phase: 6
Type: NAT
Subtype:
Result: DROP
Config:
nat (Inside) 1 0.0.0.0 0.0.0.0
  match ip Inside any Inside any
    dynamic translation to pool 1 (No matching global)
    translate_hits = 6, untranslate_hits = 0
Additional Information:


Result:
input-interface: Inside
input-status: up
input-line-status: up
output-interface: Inside
output-status: up
output-line-status: up
Action: drop
Drop-reason: (acl-drop) Flow is denied by configured rule


But if allow the NAT exemptions using the following command then, I'm able to access the outside server but outside server will not able to access the servers kept on my inside network.


fx1(config)# access-list NATEX extended permit ip 200.1.1.0 255.255.255.0 192.168.104.0 255.255.255.0

fx1(config)# access-list NATEX extended permit ip 200.1.1.0 255.255.255.0 192.168.206.0 255.255.254.0
fx1(config)# nat (Inside) 0 access-list NATEX



Please find below the message captured through packet tracer


fx1(config)# packet-tracer input dmz tcp 192.168.206.168 1100 192.168.104.150 1100


Phase: 1
Type: FLOW-LOOKUP
Subtype:
Result: ALLOW
Config:
Additional Information:
Found no matching flow, creating a new flow


Phase: 2
Type: UN-NAT
Subtype: static
Result: ALLOW
Config:
static (Inside,DMZ) BOS-SAW-TRANS-IP-priext BOS-SAW-TRANS-IP-priint netmask 255.
255.255.255
  match ip Inside host BOS-SAW-TRANS-IP-priint DMZ any
    static translation to BOS-SAW-TRANS-IP-priext
    translate_hits = 77, untranslate_hits = 13678
Additional Information:
NAT divert to egress interface Inside
Untranslate BOS-SAW-TRANS-IP-priext/0 to BOS-SAW-TRANS-IP-priint/0 using netmask
255.255.255.255


Phase: 3
Type: ACCESS-LIST
Subtype: log
Result: ALLOW
Config:
access-group DMZ-access-in in interface DMZ
access-list DMZ-access-in extended permit tcp host PRI-enSBSAA host BOS-SAW-TRAN
S-IP-priext object-group enSBSStcpPorts
object-group service enSBSStcpPorts tcp
description: enSBSStcpPorts
port-object range 9100 9105
port-object eq 1100
port-object eq 1106
port-object eq echo
Additional Information:


Phase: 4
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:


Phase: 5
Type: IDS
Subtype:
Result: ALLOW
Config:
Additional Information:


Phase: 6
Type: NAT-EXEMPT
Subtype: rpf-check
Result: DROP
Config:
Additional Information:


Result:
input-interface: DMZ
input-status: up
input-line-status: up
output-interface: Inside
output-status: up
output-line-status: up
Action: drop
Drop-reason: (acl-drop) Flow is denied by configured rule




fx1(config)#


Attached, please find the config for ASA 5520.


Apprecaite, if someone can lend a helping hand to resolve the above problem.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Diego Armando C... Wed, 01/13/2010 - 08:45
User Badges:
  • Bronze, 100 points or more

I would try this




fx1(config)# access-list NATEX extended permit ip  192.168.104.0 255.255.255.0 200.1.1.0 255.255.255.0

fx1(config)# access-list NATEX extended permit ip 0 192.168.206.0 255.255.254.0 200.1.1.0 255.255.255.


Let me know.

Hi diegocambronero


Firstly, Thanks for your prompt response. you want me to amend the existing command with the ones you suggested or these are in addition to the existing ones. Moreover, Please look at the current config and let me feedback

Thanks for your great help.




ASA Version 7.2(3)
!
hostname fx1
domain-name xyz.com
names


name 192.168.104.110 SWIFTVPNE02 description SWIFT PRIMARY VPN INSIDE INTERFACE
name 192.168.104.150 BOS-SAW-TRANS-IP-priext description Assumed-BOS-SAW-TRANS-I
P-primary-server
name 192.168.104.151 BOS-SAW-TRANS-IP-secext description Assumed-BOS-SAW-TRANS-I
P-standby-server
name 200.1.1.10 BOS-SAW-TRANS-IP-priint description Actual-BOS-SAW-TRANS-IP-prim
ary-server
name 200.1.1.9 BOS-SAW-TRANS-IP-secint description Actual-BOS-SAW-TRANS-IP-stand
by-server
name 192.168.216.168 DR-enSBSAA description SAA DR SWIFT ENSB SERVER
name 192.168.206.168 PRI-enSBSAA description SAA LIVE SWIFT ENSB SERVER
name 200.1.1.156 BOS-SAW-IPIntprn description SAW Actual IP ADDRESS Printer
name 192.168.104.152 BOS-SAW-IPExtprn description Assumed-SAW Actual IP ADDRESS
Printer
!
interface GigabitEthernet0/0
description External Network
nameif Outside
security-level 0
ip address 213.42.203.242 255.255.255.240
!
interface GigabitEthernet0/1
description Internal Network
nameif Inside
security-level 100
ip address 10.10.1.1 255.0.0.0
!
interface GigabitEthernet0/2
description DMZ Zone
nameif DMZ
security-level 50
ip address 192.168.104.100 255.255.255.0
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name xyz.com
same-security-traffic permit intra-interface
object-group network Inside-Net
description Inside Network
network-object 10.0.0.0 255.0.0.0
object-group network Outside-Net
description Outside Network
network-object 213.42.203.240 255.255.255.240
object-group service enSBSStcpPorts tcp
description enSBSStcpPorts
port-object range 9100 9105
port-object eq 1100
port-object eq 1106
port-object eq echo
object-group service enSBSSudpPorts udp
description enSBSSudpPorts
port-object range 9100 9105
port-object eq isakmp
port-object eq 1100
port-object eq 1105
port-object eq echo
object-group protocol enSBVPNPorts
description enSBVPNPorts
protocol-object esp
protocol-object ah
access-list DMZ-access-in extended permit ip 192.168.104.0 255.255.255.0 200.1.1.0 255.255.255.0
access-list DMZ-access-in extended permit tcp host PRI-enSBSAA host BOS-SAW-TRANS-IP-priext object-group enSBSStcpPorts
access-list DMZ-access-in extended permit udp host PRI-enSBSAA host BOS-SAW-TRANS-IP-priext object-group enSBSSudpPorts
access-list DMZ-access-in extended permit object-group enSBVPNPorts host PRI-enSBSAA host BOS-SAW-TRANS-IP-priext
access-list DMZ-access-in extended permit tcp host PRI-enSBSAA host BOS-SAW-TRANS-IP-secext object-group enSBSStcpPorts
access-list DMZ-access-in extended permit udp host PRI-enSBSAA host BOS-SAW-TRANS-IP-secext object-group enSBSSudpPorts
access-list DMZ-access-in extended permit object-group enSBVPNPorts host PRI-enSBSAA host BOS-SAW-TRANS-IP-secext
access-list DMZ-access-in extended permit tcp host PRI-enSBSAA host BOS-SAW-IPExtprn object-group enSBSStcpPorts
access-list DMZ-access-in extended permit udp host PRI-enSBSAA host BOS-SAW-IPExtprn object-group enSBSSudpPorts
access-list DMZ-access-in extended permit object-group enSBVPNPorts host PRI-enSBSAA host BOS-SAW-IPExtprn
access-list DMZ-access-in extended permit tcp any host BOS-SAW-TRANS-IP-priext object-group enSBSStcpPorts
access-list DMZ-access-in extended permit icmp any any echo
access-list ips extended permit ip any any
access-list ips extended permit ip any object-group Inside-Net
access-list ips extended permit ip object-group Inside-Net any
access-list NATEX extended permit ip 200.1.1.0 255.255.255.0 192.168.104.0 255.2
55.255.0
access-list NATEX extended permit ip 200.1.1.0 255.255.255.0 192.168.206.0 255.2
55.254.0
pager lines 24
logging enable
logging asdm informational
mtu Outside 1500
mtu Inside 1500
mtu DMZ 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
nat (Inside) 0 access-list NATEX
nat (Inside) 1 0.0.0.0 0.0.0.0
static (Inside,DMZ) 10.0.0.0 10.0.0.0 netmask 255.0.0.0
static (Inside,DMZ) BOS-SAW-TRANS-IP-priext BOS-SAW-TRANS-IP-priint netmask 255.255.255.255
static (Inside,DMZ) BOS-SAW-TRANS-IP-secext BOS-SAW-TRANS-IP-secint netmask 255.255.255.255
static (Inside,DMZ) BOS-SAW-IPExtprn BOS-SAW-IPIntprn netmask 255.255.255.255
access-group Outside_access_in in interface Outside
access-group DMZ-access-in in interface DMZ
route Outside 0.0.0.0 0.0.0.0 213.42.203.241 1
route Inside 200.1.1.0 255.255.255.0 10.10.1.2 1
route DMZ 192.168.206.0 255.255.254.0 SWIFTVPNE02 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
!
!
class-map inspection_default
match default-inspection-traffic
class-map ips_class_map
match access-list ips
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
class ips_class_map
  ips inline fail-open
policy-map interface_policy
class ips_class_map
  ips inline fail-open
!
service-policy global_policy global
service-policy interface_policy interface Inside
prompt hostname context
Cryptochecksum:48c0befd17138abca1875f43774a6a80
: end
fx1#

Diego Armando C... Thu, 01/14/2010 - 05:47
User Badges:
  • Bronze, 100 points or more

Hi,


I would try to add the ones that I suggested.


Let me know if it works.

Actions

This Discussion