Voice & Data VLAN Configuration

Unanswered Question
Jan 13th, 2010
User Badges:

Greetings, We had a vendor install all our switches and I've found that the switch configurations for voice & data are a little different. They are configured either as (where vlan 10 = data, vlan 172 =voice):


interface FastEthernet0/2
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode access
switchport voice vlan 172
mls qos trust dscp
spanning-tree portfast



OR....


interface GigabitEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 172
mls qos trust dscp
spanning-tree portfast


I've also see the voice configured as:


switchport access vlan 172


And some ports (that are not connected to 'static' devices such as a router) configured with switchport mode trunk, and also had voice running on it.



I'm trying to get all configurations consistent across the board. Can anyone tell me if there is a best way to approach this? Is one configuration going to give better performance than another?


Thanks,

Chris


P.S. The switches are Catalyst 3650, running 12.2 (35)SE5 IOS.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Wed, 01/13/2010 - 08:27
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi Chris,


For your first solution, Cisco calls this a Multi-Vlan access port, and NOT a trunk port. But we all know if you have more then one vlan on the port then it is trunk.  I would go with your second option:


interface GigabitEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 172
mls qos trust dscp
spanning-tree portfast


https://supportforums.cisco.com/thread/1003209?tstart=30



HTH

Reza

Actions

This Discussion