Two Provider Network [Routing Issue]

Unanswered Question
Jan 13th, 2010
User Badges:

Dear Netpros,

We have a client who have taken a internet connectivity from us. This client already having a another internet connectivity from some another provider. They want to operate on both the connectivity simultaneously. Attached is the network current network connectivity scenario in which we are representing ourselves as PROVER-B.

At present PROVIDER-A wan link is connected on client router Gig0/0 interface (1.1.1.2/29), and we (PROVIDER-B) connected on client router Gig0/1 interface(2.2.2.2/29). TWO default route is configured on client router towards both provider’s network i.e.

ip route 0.0.0.0 0.0.0.0 1.1.1.1 name Provider_A

ip route 0.0.0.0 0.0.0.0 2.2.2.1 name Provider_B

Client router Gig0/1/1 interface (172.16.0.1/24) is connected with LAN L-3 switch from where customer’s LAN HOST are connected (with private natted IPs of 172.16.0.XX pool).

Please find the configs of WAN/LAN interfaces from customer router :-

à

interface GigabitEthernet0/0

description +++ Connected to Provider-A  +++

ip address 1.1.1.2 255.255.255.248

ip nat outside

duplex full

speed 100

à

interface GigabitEthernet0/0

description +++ Connected to Provider-B +++

ip address 2.2.2.2 255.255.255.248

ip nat outside

duplex full

speed 100

à

interface GigabitEthernet0/0/0

description +++ Connected to L3 Switch +++

ip address 172.16.0.1 255.255.255.0

ip nat inside

negotiation auto

à

ip nat inside source static 172.16.0.3     1.1.1.3

ip nat inside source static 172.16.0.8     2.2.2.5

[PC with private IP 172.16.0.3 is binded with Provider-A ip 1.1.1.3 and …….PC with private IP 172.16.0.8 is binded with our(Provider-B) ip 2.2.2.5]

Note- These NATTED PC are having single LAN card.

Problem :- Problem we are facing that at our end router(Provider-B) on which this client internet connectivity is connected. We always getting high “input” traffic i.e. Upload traffic from customer (even when customer is not accessing/browsing on our network) and output traffic on our router interface is almost very small. Like below , which is recently taken from our router respective interface when client is not using /acessing network.

30 second input rate 634000 bits/sec, 310 packets/sec

30 second output rate 2000 bits/sec, 2 packets/sec


Sometime client is not able to browse by using our network. After removing the default route towards our WAN IP from client router and then again adding it , browsing happening. This is the only point of conclusion with is till time. We have checked almost thigs , but suspecting some routing or configuration related issue. Please suggest if the existing configs on client router is proper or if any need to add or remove any command.

*** => Client don't have any plan for future to segragate the LAN (private) IP pool for both the Providers. They want to use with current IP scheme configured.



Txns

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cisco.net Wed, 01/13/2010 - 09:22
User Badges:

Sorry, In previous post there was typo, related to Client router Interfaces. Please find the correct one.

à

interface GigabitEthernet0/0

description +++ Connected to Provider-A  +++

ip address 1.1.1.2 255.255.255.248

ip nat outside

duplex full

speed 100

à

interface GigabitEthernet0/1

description +++ Connected to Provider-B +++

ip address 2.2.2.2 255.255.255.248

ip nat outside

duplex full

speed 100

à

interface GigabitEthernet0/1/1

description +++ Connected to L3 Switch +++

ip address 172.16.0.1 255.255.255.0

ip nat inside

negotiation auto

Marwan ALshawi Wed, 01/13/2010 - 13:27
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi

about the input rate in the provider side i am not sure why


but regarding the client router configuration,  from your description and config i understand that you only have to hosts

and you want first one to go through provider A and the other one use theinternet thorugh provider B

at the same time you have two default routes in that router

i think the problem the hosts face when brows the internet is becuase you have two default route this will load balnce the traffic ( per flow )


i think you could try policy based routing 1.1.1.1

and host 172.16.0.8 to use 2.2.2.1


access-list 100 permit ip host 172.16.0.3 any

access-list 101 permit ip host 172.16.0.8 any


route-map PBR permit 10

match ip address 100

set ip next-hop 1.1.1.1


route-map PBR permit 20

match ip address 101

set ip next-hop 2.2.2.1


then apply it to incoming interface which is the LAN interface

int gigx/x   -- the lan interface

ip policy route-map PBR



if you have other LAN device use the nating they will use the normal routing table in you casee the default route you have


also i recomend you to have a look at the bellow document,  you may find some usfule ways to configure the client router


https://supportforums.cisco.com/docs/DOC-8313




good luck

if helpful Rate

Marwan ALshawi Thu, 01/14/2010 - 02:23
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

i think the issue as flowing


as i mentioned before the two default routes loadbalncing

but nating with two interfaces will use always the first nat address thats why some time your traffic dos not work

and also you see input traffic because traffic coming to the provider router with the wrong source and then no output because the router will not forward the traffic back

to fix the nating issue with the two default routes use the match interface command with a route map with the nating config as described in the link provided above


good luck

if helpful rate

rajatsetia Thu, 01/14/2010 - 01:20
User Badges:
  • Bronze, 100 points or more

As client setup is not well explained so I have made some assumptions about things which could go wrong at client side. a total different perspective of solving the issue (logically yes but not sure if it make sense in pure technical terms)-


1) Upstream traffic is high - possibly its not an issue, as at the client side two default routes so upstream traffic is load balanced


2) Now about the downstream traffic - Now client has two hosts and question for the client side

    

     - if both the hosts have been used for internet browsing (proxy kind of setup), it is possible that only the host which is NATed with Service provider A is the one who is catering to the load right now, so when you delete the default route towards Service provider B, browsing works fine


Capture the netflow traffic which is entering your router, which could help you clarify if any traffic with source address 2.2.2.5 is coming your way.


in nutshell, along with configuration thing, get more clraity on client side setup and then based on client setup & requirement, check for useful ways of configuring the client router (as marwanshawi recommended)


Kind Regards

Actions

This Discussion