SPA400 Constantly re-booting

Unanswered Question
Jan 13th, 2010

I am on my second SPA400 in as many weeks. I thought the first one had a problem because after doing some configuration it would start re-booting itself on approximately 10 ~ 15 second intervals.  I suppose I don't know for sure that they were re-boots, but the SPA400 would lose it's connectivity for a bit, then it would come back for a bit, then lose it for a bit, etc. This was verified by running constant pings to the SPA400.

With both SPA's, they seemed to work fine out of the box with the exception of multiple out-bound calls not working (later fixed by altering the ground-loop start setting). However, following the instructions I upgraded the firmware to and that's when the problems started.

This is apparently random as you may configure any number of things on the SPA400 before the re-boot cycle starts. It doesn't seem to matter what you configure, either. Sometimes you configure option X and it works fine, then later you configure the same option and the cycle starts.

Once it starts, the only way I have found to fix it is to catch it while it is up and do a factory reset on the device (you must work quickly because you only have a few seconds). Then you begin the process all over again.

I also upgraded to the beta firmware of, but this didn't fix the problem.

Again, this behavior has been consistent on both SPA400's. At this point I am reluctant to make any configuration changes for fear of it starting to re-boot itself over and over again, but my configuration is less than optimal (default passwords, DHCP, etc.).

If someone could help, I'd really appreciate it.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
naazish_khatri Thu, 01/14/2010 - 01:17

One possible temporary solution, try to unplug the line cable from SPA400 and put it back again after a few seconds. This might solve your resetting to factory default problem.


Naazish Khatri  

bradwilliams Thu, 01/14/2010 - 05:24

HI Naazish -

Unfortunately, the problem isn't that the unit goes back to factory defaults. The problem is that it suddenly gets into a boot-loop after making configuration changes. The only way I've found to get it out of this mode is to factory reset the unit.

What I need is for the unit to stop going into this mode of continuously re-booting itself after making configuration changes.

Alberto Montilla Thu, 01/14/2010 - 09:30

Hi Brad;

This is definitively not normal. What configuration parameters are you changing? Are you using it with SPA9000? Is it using latest release?


bradwilliams Thu, 01/14/2010 - 10:46

Hi!  Yes, I agree it is not normal, but two SPA400's have done this.  It is being used with an SPA9000 and SPA series phones.  The SPA9000 is running the latest firmware, and the SPA400 is now under a beta firmware release of as started causing my problems. I've seen other users in the forum mention the re-boot issue as well, but nobody seems to have a fix for it.

As for what I configure that causes the problem? Off the top of my head any of the following changes started causing the device to go into this mode, though it's not consistent (i.e. configuring one of these items doesn't always cause the problem):

  • changing the IP to a static IP address
  • changing the IP of the SPA9000 to a static IP address
  • Adding voice mail boxes
  • configuring the Admin password
  • changing the settings for ground-loop detection / start
  • changing the delay timer for dial out after the FXO goes off-hook

pretty much all of your fairly normal configuration changes have cause this behavior to manifest itself.

bradwilliams Mon, 01/25/2010 - 07:25

Hi everyone -

Is there really no answer on this at all? I saw several other threads mention the same problem. Can someone at least tell me if Cisco is investigating this or if I need to find another product? My customer is pretty upset at the moment.

Thank you,

Brad Williams

Alberto Montilla Mon, 01/25/2010 - 08:07

Dear Sir;

Is it there any way you can plug another SPA400 (it may be a defective unit)?

Otherwise, this may be caused by an invalid value you are introducing. As said, this is not common.

If you require urgent assistance, I suggest you contact the Small Business Support Center (details on the community main page).


bradwilliams Mon, 01/25/2010 - 14:31

Hi Alberto!

Thanks for the suggestion. I had already tried a second SPA400. It pretty much behaved in the same fashion (started cycling after a firmware upgrade and upon configuring the unit). The second one also died during a firmware upgrade and never came back to life even with the recovery utility. That one is being RMA'd and I now have a third unit on the way.

As a side note, I am used to working with UC products and I have to say that this is a little dissapointing even though I believe the unit would be good value for the money if I weren't having these issues.

Thank you,


William Paulsen Mon, 03/29/2010 - 12:57

Is there any update on this?  Will there ever be a firmware for the SPA400?

bradwilliams Mon, 03/29/2010 - 13:16

I tried using the beta firmware and it had the same problem. To be frank, I'm surprised that this issue has not been addressed. I saw several other threads on the same issue and none of them have been resolved.

At this point I am running a really old version of firmware because any of the newer firmware's introduce the problem. This makes it difficult because I can clearly tell that the older firmware doesn't handle some of the features nearly as well, but I'm afraid to upgrade it lest the SPA400 start rebooting constantly.

This is not a good situation. You should not have to be concerned about "touching" your equipment and making configuration changes.

Alberto Montilla Tue, 03/30/2010 - 07:43

Dear Sir;

This is not a normal behavior. Unit should not reboot. I suggest (if under warranty) you RMA the product.


bradwilliams Tue, 03/30/2010 - 08:39

I realize that this is not normal behavior, but I it is apparently frequent enough that other user's have the same problem. I have already RMA'd two SPA400's and am on my third one. This is the one I am afraid to touch.

What I'd really like to see is a definitive answer from Cisco saying that the cause is known and this is what fixed it - even if it is due to a bad batch of SPA400's in the manufacturing process. Simply returning them over and over again doesn't do anything but frustrate everyone involved.

William Paulsen Tue, 03/30/2010 - 09:20

I'm on my second SPA400 and within minutes or running with the latest firmware (, it started rebooting and then locked up.  It took a while to get a hard factory reset, but eventually it came up and I loaded an older firmware version, 1.0.4.x, which seems stable.  I doubt these SPA400 units have manufacturing defects - it seems clear it's a firmware problem.

Cisco: Where's the firmware to correct this problem?  Or should we just indefinitely use the older firmware version?

Alberto Montilla Sun, 04/04/2010 - 06:40

Dear Sirs;

I'm escalating this to engineering to see if there is a root cause for this. Please stay tuned.


bradwilliams Mon, 04/05/2010 - 07:09

Alberto -

Thank you very much!  I'd love to see a resolution on this one.

CTRLITINC Sat, 04/17/2010 - 12:24


I experienced this issue last month during a late night installation so hopefully my memory serves me correctly. I had intended to send to Cisco as I had an open case, but got pushed back.

If you can get into the SPA400 you need to change the SPA9000 Address from Static Address (IP Address and Port) to Discover Automatically. Now the Cisco documentation recommends you use a Static Address, however I have only had problems with it and always use the Discover Automatically.

I confirmed that this resolved our issue and also was able to reproduce so hopefully this will resolve your issue.

Please report back, now if this is not the problem I may be able to review some of our case logs and search or the problem


Steve Wofford

Call Ctrl Call Manager for

SPA900 - SPA500 IP Phones

bradwilliams Sun, 04/18/2010 - 10:36

Hi Steve!

Thanks for the response. I'm out of town at the moment and don't want to take a chance on this remotely. I'll be back in a few days and will give this a try.

I'm curious, in your testing were you able to run the latest firmware versions?

William Paulsen Tue, 04/20/2010 - 08:47

Is there any word from Engineering on the SPA400 rebooting issue?  It's now been more than 2 weeks since getting escalated.  If this issue is caused by a static IP in the SPA400, then this should be easily reproduced by engineering and then a firmware update built.

CTRLITINC Tue, 04/20/2010 - 11:32

Did making this change fix the problem or not? Cisco may or may not be able to reproduce. I recommend you attempt the resolution I posted, if it works you have solid information you can provide to them for them to address w/ QA, but I wouldnt be beholden to the firmware fix as you may be waiting a while when you can make the change and move on.

William Paulsen Wed, 04/21/2010 - 15:09

In my setup the SPA400 must have a static IP.  For example, the only way that I can reach the SPA400 voice mail from an AA Dial Plan in the SPA9000, is:  [email protected]:5090  (where .10.201 is the SPA400)  Normally something like "vmm" should work.  I need to do it this way because of yet other bugs in the SPA9000/SPA400 - calls to Cisco support resulted in no answer to this bug, they simply gave kudos to my "800:..." work-around.

CTRLITINC Wed, 04/21/2010 - 15:15

I have serveral installations and I almost always require VM access from the dial plan so users can either check VM remotely or some sort of hunt group when nobody answers. I never use the Static Address setting.

As a test I would use the discovery address and see if this fixes your issues.

William Paulsen Wed, 04/21/2010 - 15:23

OK, I just set the SPA400 to Discover automatically.  I see this setting is not related to the static IP of either the SPA9000 or SPA400.  So we'll wee what happens now.

CTRLITINC Wed, 04/21/2010 - 15:28

I had wondered why you questioned the IP Address becuase you had to hard code the IP into your DP. Makes sense now.

You are correct, it is not the static IP Address of either the SPA9000 or SPA400. I have used the settings interchangable for some time, but the time I had issues w/ the reboot, fixed the problem. In discovery mode the SPA400 finds out about the SPA9000 when the SPA9000 registers to the SPA400. Otherwise setting it statically it know automatically. I am not sure why there is an option.

Make sure you reboot everything after making the changes and cross your fingers.

William Paulsen Wed, 04/21/2010 - 16:59

After only changing the SPA400 to "Discover Automatically" (from specifying a static IP for the SPA9000), after a few minutes the SPA9000 "Failed to Register".  Reboots all around didn't help.  When I changed the SPA400 back to giving a static IP for the SPA9000, things went back to normal.  (Or about as normal as immediately before this change.)

So, the question to Cisco still remains:  Has this issue been investigated yet???

CTRLITINC Wed, 04/21/2010 - 17:20

Did that stop the constant reboots? If so you may want to find out why the REGISTER failed. You may or may not get an answer from Cisco in the time you need, so you may want to see what you can do on your own... or not.

William Paulsen Wed, 04/21/2010 - 17:57

The constant SPA400 reboots occurred with the version of the firmware (the latest).  When I loaded, the reboots stopped.  And these reboots with occurred within minutes of opening the box, plugging it into a network with only an SPA9000, one SPA504g phone, a PC, and the router/switch.  Basically, out of the box, minimal setup, updates to latest firmware all around.  The SPA400 was replaced but the exact same thing happened, and that's when I went back to an older firmware, which was mentioned on another forum.

CTRLITINC Wed, 04/21/2010 - 19:19

I am confused, when made that change from dynamic to static while running the latest firmware, did that stop the reboots?

William Paulsen Thu, 04/22/2010 - 04:40


What stopped the reboots was to load an older version of the SPA400 firmware.  (I suppose I could just be content with this older firmware, but we're having too many other problems that I suspect there are some things fixed in the current firmware, however a reboot every 30 seconds would make the system totally useless.)

As a reminder here are the open issues we have:

One of the lines on some phones will go into a "Share Call Active" state several times a day.  This even happens by itself - when staff goes home at night things the phones looks OK, but when they arrive in the morning the phones are in this state.  Then it mysteriously goes away after a few calls. The only fix is to reboot the SPA9000.

The SPA400 freezes up every few days, for no apparent reason.  This varies from 2 to 4 days.  The only fix is a power cycle.

When calls are answered by lifting up the handset on the SPA504g phones, about 20% of the time the call goes to the speaker and the handset is dead.  The fix is to put down the handset and pick it up again.

Herman_verschooten Thu, 04/22/2010 - 05:31

Hi everyone,

We have been running SPA9000 with SPA400 and 4 SPA942 phones for over a year now without any problems.  That is until last Monday when without any obvious reason the SPA400 starts to reboot after about 45~50 seconds.  There were no configuration changes and it has the latest software version.

This is the phone system for our retail store and as a result our customers can no longer reach us.

Is there a solution available?



PS I have setup syslog on the router and the reboot starts everytime after the same message.

04-22-201016:22:34Local7.Debug192.168.29.60000019362 - TIU: 1st FXO state report sent
04-22-201016:22:23Local7.Debug192.168.29.60000013811 - TIU: All FXO port get a state
04-22-201016:22:23Local7.Debug192.168.29.60000013807 - Global initialization done.
04-22-201016:22:23Local7.Debug192.168.29.60000013806 - ast_main done USB: 0, vms: 0
04-22-201016:22:23Local7.Debug192.168.29.60000013805 - <027>[1;37;40mAsterisk Ready.<010><027>[0;37;40m

bradwilliams Wed, 04/28/2010 - 15:02

Hi everyone -

I finally got a chance to work on the SPA400. I changed the SPA9000 Interface option from static to "Discovery Automatically" and so far so good. I also upgraded the firmware to the v1.1.2.2 and it has been up for over an hour with multiple calls in and out. I'd like to let it run for a bit before I say for sure that this fixed the re-boot issue but so far it's looking great.

Roland_Pope Sun, 05/16/2010 - 19:40

I am running two SPA400's with Asterisk (Not an SPA9000) which have been stable on the firmware for more than a year now.

However, twice in the past few months, the gateways have started rebooting.. Both of them together.

I have tried setting the SPA9000 to 'Auto Discover' as suggested here, but this prevented my Asterisk server from registering to the gateway. What seemed to stablise them initially was factoring defaulting them and putting the settings back on them manually, however, a second occurance of the issue several months later was not sorted in this way. When I put my settings back on again, the reboots started again.

I have stabilised it now by turing off the SIP registrations to the SPA400's in asterisk and I am now just blindly sending my SIP calls to the SPA400 without registring and so far so good.

I suspect there is some sort of bug in the SPA9000 registration code that is causing this problem. Any chance of a fix?



Roland_Pope Tue, 05/18/2010 - 17:31

OK, I tried downgrading the firmware to the previous release, but this failed to improve things so I went back to the latest firmware.

I eventually managed to get the correct group of settings on the SPA400 and Asterisk to allow me to set the SPA9000 Address  to 'Discover Automatically' and this seems to have stabilised things. Seems that in at least one case, I had to do a factory default after upgrading the firmware to get the Asterisk SIP registrations to stop being rejected with a SIP 'Busy Here' response from the SPA400.

Still a rather odd and frustration issue which I hope is able to be fixed.

bradwilliams Wed, 05/19/2010 - 14:54

Thanks for the update. The SPA400 that I changed to "discover" mode seems to have stabilized. Based on all the posts in this thread I'd say that there is definitely something related to this configuration parameter.

Is anyone from Cisco still monitoring the thread? If so, can this be escalated within the product engineering team?

bradwilliams Thu, 05/20/2010 - 07:37

Hi Steve -

I don't mean to be obstinate, but because the community figures out how to work around what appears to be a fairly serious bug does not mean that the problem is solved. All we've done up to this point is identify the problem, as well as isolate what appears to be causing the problem. It's still a problem, and one that needs to be addressed - perhaps in an upcoming firmware release.

Roland_Pope Thu, 05/20/2010 - 13:52

I agree with Brad. This fault has caused me days of grief with one customer. A pair of SPA400's which were going find suddenly started rebooting and replacing the units failed to make any difference.

Given the number of these units around the world, and given that CISCO has added their name to the product, surely if deserves a fix.

I am sure those who have not yet had the issue or who are unable to use the workaround for some reason will be grateful if this is addressed in the firmware. I for one would be happier knowing that whatever caused the reboots to start happening is not going to re-occur in spite of the workaround.


William Paulsen Thu, 05/20/2010 - 21:08

As far as I can tell, Cisco has given up with the SPA9000/SPA400 - this is an End-of-Lifed product.  There's no one left engineering. There are no more firmware updates, there hasn't been firmware updates in almost 2 years.  I have several open customer support tickets that have been "escalated" for 2 months, and the only occasional contacts I get from Cisco is, "What was your problem again? OK, I'll check into it."  But even now it's been more than two weeks since my last contact.  (I'm struggling to keep alive the SPA9000/SPA400 at my wife's business until I can move to FreeSwitch)