Issue connecting 3120 switch with 3750!!!

Unanswered Question
Jan 14th, 2010
User Badges:

Hi Experts,

I have connected a 3120 switch  to a 3750 and the problem is when I set the Configuration to  Speed 100 duplex Full the link goes down, But when it’s set to “auto” the link is up.

I have tried all the possibilities before requesting the solution on netpro:-

1) Tried different kind of cables (crossover/straightover etc..) without success.

2) Tried using the option “mdx auto” on the 3750 no success.

Is there anything else which you guys gonna give it a try?

Thanks in advance.

Regards

Fariha.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Thu, 01/14/2010 - 07:05
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hello Fariha,


Did you try to set speed and duplex on both sides?


The 3120s do support 100 full:

The autonegotiation feature is enabled by default on the switch. At this setting, the switch module ports configure themselves to operate at the speed of attached devices. If the attached device does not support autonegotiation, you can explicitly set the switch module port speed and the duplex parameters. To maximize performance, either allow the ports to autonegotiate both speed and duplex, or set the port speed and duplex parameters on both ends of the connection.


HTH

Reza

fariha zain Thu, 01/14/2010 - 07:13
User Badges:

Hi Raza,

Yes I know that it supports 100 full. But not sure why it's not supporting for my devices.


The link goes down when I manually configure on both the devices. If I make it auto the link comes up without any problem


Regards,

Far

Reza Sharifi Thu, 01/14/2010 - 08:43
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi Far,


When you set the speed to 100 full, did you try adding "no mdx auto" on both switches?


Reza

glen.grant Thu, 01/14/2010 - 08:43
User Badges:
  • Purple, 4500 points or more

  Make sure "no mdix-auto" is on both ports if you want to hardcode.

Actions

This Discussion