Can’t add Controller over VPN in WCS v6.0.132.0

Answered Question
Jan 14th, 2010
User Badges:

Hi

I use WCS v6.0.132.0 to manage my 4402 and 2106 controller both running version 6.0.182.0
When I try to add another 2106 over DM-VPN it fails with the following errors:

”No response from device, check SNMP communities, version or network for issues”

If I move the new 2106 controller to LAN with same config there is no problem.

I found this note in the in “Cisco Wireless Control System Configuration Guide, Release 6.0”

“Note If you are adding a controller into WCS across a GRE link using IPsec or a lower MTU link with multiple fragments, you may need to adjust the MaxVar Binds PerPDU. If it is set too high, the controller may fail to be added into WCS. To adjust the MaxVarBindsPerPDU setting, do the following:
1) Stop WCS.
2) Go to the location of the Open SnmpParameters.properties file on the server that is running WCS.
3) Edit MaxVarBindsPerPDU to 50 or lower.
4) Restart WCS.”

On my system I have the “SnmpParameters.properties” file is located //WCS6.0.132.0\webnms\classes\com\cisco\server\resources

But I don’t have “MaxVarBindsPerPDU” settings in the file.
Beside some # explanations text, the only settings I have in the “SnmpParameters.properties” file is:

DebugEnabled                         false

SerializeRequests                    true

MaxRepetitions                       10

MaxRetryTimeout                      60

WlanTimeoutMsecsPerAP                 50

I have tried to add “MaxVarBindsPerPDU” settings, but it have no effect.

Anyone have an idea what to do?

TIA

Correct Answer by Lucien Avramov about 7 years 6 months ago

Two things:


1. Change the max var per PDU from : Administration -> Settings -> SNMP

2. Make sure snmp is allowed over your vpn link by enabling debug snmp all enable on the WLC. Also you can run manually an snmpwalk from a host on the same network where the WCS is to make sure SNMP does go accross your VPN.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Lucien Avramov Sat, 01/16/2010 - 13:21
User Badges:
  • Red, 2250 points or more

Two things:


1. Change the max var per PDU from : Administration -> Settings -> SNMP

2. Make sure snmp is allowed over your vpn link by enabling debug snmp all enable on the WLC. Also you can run manually an snmpwalk from a host on the same network where the WCS is to make sure SNMP does go accross your VPN.

PeterJacobsen Sun, 01/17/2010 - 23:58
User Badges:

Thank you so much! 

Step 1 solved the issue.
I changed “Maximum VarBinds per Get PDU” from 30 to 20 and “Maximum VarBinds per Set PDU” from 50 to 20.

Thanks

Actions

This Discussion

Related Content

 

 

Trending Topics - Security & Network