WRVS4400N - VPN has NEVER worked properly!

Unanswered Question
Jan 14th, 2010


This will be a rant - so be warned!

How is it that I can purchase a product from a company such as Cisco / Linksys that is directly targeted towards that highend small business / "prosumer" market as a VPN capable solution, yet nobody seems to be able to get it to work?

I am running the latest Firmware (V1.1.13) on the WRVS4400N and the latest QuickVPN client For some reason this software and router ONLY work properly with Windows XP computers? Why is there no proper support for Windows Vista or Windows 7? Heck the latest version of QuickVPN won't even run on a Vista or Windows 7 workstation!

I have been on the phone with technical support regarding this and there is not solution! At least not one that they can provide.

The only way that I have been able to succesfully connect to this router from Windows 7 (or Vista) is by using a second party piece of software (The Greenbow Client!) Why can all of the brains at Cisco / Linksys not create a client of their own that will allow us to use this device as it was intended? After all, the VPN capabilities are why most of us have purchased this router in the first place, so it would be nice if they worked.

Cisco / Linksys -> Please fix this software, no more excuses, make this device work! While you are fixing it make the VPN work with dynamic address (dyndns) resolution as well!

If you can't figure it out, at least port a version of DD-WRT over to it for us, so that we can use the Windows client to connect to it - like my $50.00 Asus router does seamlessly right now!

End of Rant!

Andrew Read

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
qumartin Thu, 01/14/2010 - 09:23

What you need to do inorder to get the quick vpn to work on windows 7. You must right click on the quick vpn icon and go to properties. Once you are in properties you must click on the compatiblity tab. You must change the Compatibility mode to Run using a earlier version of window for this program. Select Windows vista service pack 2 and this will allow quick vpn to connect. Make sure to use the Ip address when connecting and not the DNS Name. This should fix your problem and you would not have to use your Greenbow Client.

readconsult Thu, 01/14/2010 - 13:14

Well Martin,

That certainly does get the QuickVPN client to run (WHY should I have to do this through compatibility mode??????), however, it does NOTHING to help me connect to the VPN. It still fails and hangs at Verifying Network, just as it always has on any OS other than XP.

When is this software and firmware going to grow up and start walking on its own?

I would love it if other WRVS4400N users would post to this thread and share their experiences as to whether or not they have gotten this product to work on any OS other than XP. Let's consolidate all of our complaints in one place, and maybe then Cisco / Linksys will listen to us and finally get this device working.


Andrew Read

Te-Kai Liu Thu, 01/14/2010 - 18:54

May I know the IP subnet your QuickVPN client is in and the LAN IP of the WRVS4400N, to which your QuickVPN client intends to connect to?

We know Vista QuickVPN client works with WRVS4400N. You might want to call the Samll Business Support Center to do some troubleshooting.

readconsult Thu, 01/14/2010 - 21:40

The IPs are on different subnets (192.168.1.x vs. 192.168.10.x) so that is not the issue.

I agree that this software works, on Windows XP, as long as you don't want to use dynamic dns, which many users do. However, I have never seen it work on Windows Vista or Windows 7. Even after calls to your support department.

People want a solution that works out of the box, not one that almost partially works, after hours of tweaking (what does the Quick in QuickVPN mean anyway?)

This is CLEARLY not that solution.

I have had more success with a $80.00 router with DD-WRT installed, using Microsoft's built in VPN connection client. over Dynamic DNS - That took less than half an hour to setup, including flashing a router with DD-WRT, setting up the new firmware AND the VPN.  The client connected instantly!

Also, the Greenbow client works, although I have not tried it with dynamic DNS running yet, so there is no reason why Cisco should not be able to make some software / firmware that works properly.

This has been an outstanding issue for YEARS - and it needs to be solved or the product needs to be pulled off the shelves and recalled - the product does not work as advertised. :(

Te-Kai Liu Thu, 01/14/2010 - 21:47

>The IPs are on different subnets (192.168.1.x vs. 192.168.10.x)

Could you try changing one of the ip subnet to something like 192.168.2.x? There is a known issue that QuickVPN Client will erronously think that its local subnet is conflicting with the remote subnet if the local subnet is 192.168.1.x and the remote subnet is 192.168.10.x.

readconsult Thu, 01/14/2010 - 21:50

Lol.. no I am not going to waste my time changing my subnet again, if this is a known issue FIX it, and provide the fixed software.

I am not changing a subnet's worth of gear and equipment, for a second time, because of this buggy software.

Just fix it, or pull it off the shelves.


Te-Kai Liu Thu, 01/14/2010 - 21:52

I am aware that QuickVPN Client supporting Windows 7 is in the stage of testing currently. Hopefully it will come out soon.

readconsult Fri, 01/15/2010 - 04:50

I for one will not be sitting here holding my breath, waiting for it to work.. I would have been BLUE a long time ago if I was hoping that this ever would work properly.

Other WRBS4400N users - feel free to voice your concern that this device is not working for you, which it now indeed sounds like it does not, maybe it will get fixed.



Alejandro Gallego Fri, 01/15/2010 - 11:13

Andrew I have created a thread to hopefully directly address the problem with QVPN. Here is the Link to the discussion. You are not alone in your frustration with QVPN and i would to say that as a support engineer it has been very difficult to find out as to why to different clients with almost identical configurations QVPN allows one to connect consistently while the other can't. I have found that making changes on the Windows firewall has fixed connection problems while others with out the change are able to connect.

As you can see it makes for a difficult situation. So please take a look at the thread and post your settings and as more and more people respond we may be able to find some common denominators.



readconsult Fri, 01/15/2010 - 14:40


I understand that it may be frustrating from a Technical Support standpoint, all the more reason for people to post the fact that they have an issue with this software. If there are enough angry customers out there (I know there are, they just aren't in one thread!) then maybe Cisco will take note of what a disaster this whole thing is and actually dedicate some time to getting the Firmware (it is crippled!) and Software for this router fixed.

If it is frustrating for you, imagine how frustrating it is for somebody that either purchased one of these for themselves or a client. It is literally money wasted, and if I could find another router that had gigabit ethernet ports that supported DD-WRT, I would literally throw this thing in the garbage. Unfortunately, there is not one that I can find.

Time and time again, I have read posts (for two years!) that say that this software will work, and by the time you get to the end of them, the determination is that it will not work!

People, please post your dissatisfaction with the WRVS4400N and QuickVPN here, and let's motivate Cisco to set this right! Their reputation is at stake.

plawer123 Sat, 07/17/2010 - 02:16

I've had the WRVS4400N for about two years, and I have not managed to make it work either. I have tried several times with various versions of firmware and QVPN client. My first attempts were with two different laptops running XP, and from reading this I wonder if I should even waste time trying on my Vista laptop.

I found this post when I was about to go for yet another attempt. I can see that there is a newer version of QVPN than the one I have. But whenever I try to download it, I get a 305 Proxy Error.

saturninodoctor Mon, 12/17/2012 - 17:59

I just ran into this thread about QuickVPN on Windows 7 not working for WRVS4400N. Well, it is still an issue. I just purchased this WRVS4400N for our small business because it was marketed in the box with VPN capability.

Well, I've spent hours trying to get this work and talked to Cisco Tech Support to get help. First I was told that a router upstream was blocking ports 443. After verifying that, it was not true. Then they said flash the new firmware and that was done. Still this falsely called QuickVPN is anything but quick or working.

I now know why so many customers are mad about this product. If Cisco can't fix this, I want my money back!


This Discussion

Related Content