3750 Switch Stacking and Ether-channel

Unanswered Question
Jan 14th, 2010

Dear All,

I have 2 3750 switches and had stacking between those switches.

Now when I issue the "show switch" command it showing 2 switches but 1 switch has no information like mac add status everything is set to 0

doesn't matter its connected or not.

3750−Stk>show switch
Current
Switch# Role      Mac Address           Priority    State
−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−
1           -----      0000.0000.000         0          Provisioned
2        Master    0016.9d59.db00          5         Ready

I have removed the problematic switch and working with 1 switch only.

2nd problem is - when I connect any edge switch with just 1 link it works fine but if connect the same edge switch with multiple links and create ether-channel port goes down and hungs at core and edge end.

If I remove all the links except 1 and give "no shut"  under the interface. port comes up.

I am not able to get this kind of situation. why port hungs in Port channel.

configuration at the core and edge end-

==============================

int ran gi1/0/23 - 24

sw trunk encap dot1q

sw mo tru

sw trunk allowed vlan 1-2000

channel-group 23 mode on

no shut

exit

int po23

sw trunk encap dot1q

sw mo tru

sw trunk allowed vlan 1-2000

no shut

exit

Please help

Thanks

Nitin

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
prakadeesh Fri, 01/15/2010 - 00:51

Hello Nitin,

IMHO

Problem 1:

     U have provisioned a switch using the provision command. Is the model in this cli the same as the one your connecting? What are the type of 3750s that your trying to stack? Have you tried with another port and another stack cable. IMHO i sense a connectivity problem between the stacks. Logs showing any clues?

Problem 2:

           I think configs are fine. What is the platform that your trying to etherchannel together? Is there any loggs that indicate etherchannel failure reasons?

rgds,

Deesh

nitsg.gupta Fri, 01/15/2010 - 01:41

Thanks Deesh,

we are useing /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";} WS-C3750G-24TS switches for stacking.

I have added both the switches in CLI and I checked each & every port on both switches for stacking.

but still not getting stacking successfull.

once it shows me under show switch then i can make configuration according to my need (master or slave nd other things).

i didn't try with spare stack cable.

2nd Query

========

plateforms are same or u can say mirror of 1st switch.

glen.grant Fri, 01/15/2010 - 04:30

     Something is not right with the way you setup the switch that says provisioned , a glance thru this doc might point you in the right direction as far as adding a switch to the stack.   http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_40_se/configuration/guide/swstack.html#wp1178950

Also, this one shows a situation where one shows provisioned.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/troubleshooting/switch_stacks.html#wp40112

Actions

This Discussion