Does 6509 support shaping or Hierarchical policymap anyhow?

Answered Question
Jan 14th, 2010
User Badges:

Hello All,


I have a ME customer that is directly connected to a 6509 w/ Version 12.2(33)SXH4. By using the following config, I am trying to:


1- Limit overall traffic at 10 mbps

2- Prioritize voip traffic w/ 2 mbps

3- Limit Netapp traffic at 3 mbps

4- Remaining traffic gets 5 mbps


But I get errors when I apply service-policy under a Gi interface. Does 6509 support shaping or Hierarchical policymap anyhow?




access-list 181 remark Define & permit customer traffic to VoIP
access-list 181 permit ip any 192.168.66.0 0.0.0.255

access-list 182 remark Define & permit customer traffic to Netapp
access-list 182 permit ip any 192.168.62.5 0.0.0.0

access-list 183 remark Define & permit customer traffic to Remaining
access-list 183 permit ip any any




class-map match-all VoIP_TRAFFIC
match access-group 181

class-map match-all Netapp_TRAFFIC
match access-group 182

class-map match-all Remaining_TRAFFIC
match access-group 183



policy-map VoIP_CLASSIFICATION
class VoIP_TRAFFIC
  priority 2000
class Netapp_TRAFFIC
  police cir 3000000 bc 375000 be 375000 conform-action transmit exceed-action drop

class Remaining_TRAFFIC
  bandwidth 5000



policy-map EGRESS_QUEUING
class class-default
  shape aver 10000
  service-policy VoIP_CLASSIFICATION

int Gi3/15
service-policy output EGRESS_QUEUING





65_01(config-if)#service-policy output EGRESS_QUEUING                                      
Hierarchical policymap is not supported for this interface. Configuration failed!



65_01(config-if)#service-policy output EGRESS_QUEUING

shape average command is not supported for this interface. Configuration failed!


65_01#sh run interface g3/15
Building configuration...

Current configuration : 250 bytes
!
interface GigabitEthernet3/15
bandwidth 10000
ip vrf forwarding XXX

ip address 10.2.127.209 255.255.255.252
load-interval 30
speed 100
duplex full
end

Correct Answer by Jon Marshall about 7 years 6 months ago

ctaymez wrote:


Hello All,


I have a ME customer that is directly connected to a 6509 w/ Version 12.2(33)SXH4. By using the following config, I am trying to:


1- Limit overall traffic at 10 mbps

2- Prioritize voip traffic w/ 2 mbps

3- Limit Netapp traffic at 3 mbps

4- Remaining traffic gets 5 mbps


But I get errors when I apply service-policy under a Gi interface. Does 6509 support shaping or Hierarchical policymap anyhow?




access-list 181 remark Define & permit customer traffic to VoIP
access-list 181 permit ip any 192.168.66.0 0.0.0.255

access-list 182 remark Define & permit customer traffic to Netapp
access-list 182 permit ip any 192.168.62.5 0.0.0.0

access-list 183 remark Define & permit customer traffic to Remaining
access-list 183 permit ip any any




class-map match-all VoIP_TRAFFIC
match access-group 181

class-map match-all Netapp_TRAFFIC
match access-group 182

class-map match-all Remaining_TRAFFIC
match access-group 183



policy-map VoIP_CLASSIFICATION
class VoIP_TRAFFIC
  priority 2000
class Netapp_TRAFFIC
  police cir 3000000 bc 375000 be 375000 conform-action transmit exceed-action drop

class Remaining_TRAFFIC
  bandwidth 5000



policy-map EGRESS_QUEUING
class class-default
  shape aver 10000
  service-policy VoIP_CLASSIFICATION

int Gi3/15
service-policy output EGRESS_QUEUING





65_01(config-if)#service-policy output EGRESS_QUEUING                                      
Hierarchical policymap is not supported for this interface. Configuration failed!



65_01(config-if)#service-policy output EGRESS_QUEUING

shape average command is not supported for this interface. Configuration failed!


65_01#sh run interface g3/15
Building configuration...

Current configuration : 250 bytes
!
interface GigabitEthernet3/15
bandwidth 10000
ip vrf forwarding XXX

ip address 10.2.127.209 255.255.255.252
load-interval 30
speed 100
duplex full
end


It depends on the module/interface you are using. It is only supported on some WAN interfaces as shaping is not generally available on Catalyst switches -


6500 Q&A


Catalyst switches have a completely different queueing system than routers so most of the MQC type configuration for queueing is not available -


6500 PFC QOS


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jon Marshall Fri, 01/15/2010 - 02:47
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

ctaymez wrote:


Hello All,


I have a ME customer that is directly connected to a 6509 w/ Version 12.2(33)SXH4. By using the following config, I am trying to:


1- Limit overall traffic at 10 mbps

2- Prioritize voip traffic w/ 2 mbps

3- Limit Netapp traffic at 3 mbps

4- Remaining traffic gets 5 mbps


But I get errors when I apply service-policy under a Gi interface. Does 6509 support shaping or Hierarchical policymap anyhow?




access-list 181 remark Define & permit customer traffic to VoIP
access-list 181 permit ip any 192.168.66.0 0.0.0.255

access-list 182 remark Define & permit customer traffic to Netapp
access-list 182 permit ip any 192.168.62.5 0.0.0.0

access-list 183 remark Define & permit customer traffic to Remaining
access-list 183 permit ip any any




class-map match-all VoIP_TRAFFIC
match access-group 181

class-map match-all Netapp_TRAFFIC
match access-group 182

class-map match-all Remaining_TRAFFIC
match access-group 183



policy-map VoIP_CLASSIFICATION
class VoIP_TRAFFIC
  priority 2000
class Netapp_TRAFFIC
  police cir 3000000 bc 375000 be 375000 conform-action transmit exceed-action drop

class Remaining_TRAFFIC
  bandwidth 5000



policy-map EGRESS_QUEUING
class class-default
  shape aver 10000
  service-policy VoIP_CLASSIFICATION

int Gi3/15
service-policy output EGRESS_QUEUING





65_01(config-if)#service-policy output EGRESS_QUEUING                                      
Hierarchical policymap is not supported for this interface. Configuration failed!



65_01(config-if)#service-policy output EGRESS_QUEUING

shape average command is not supported for this interface. Configuration failed!


65_01#sh run interface g3/15
Building configuration...

Current configuration : 250 bytes
!
interface GigabitEthernet3/15
bandwidth 10000
ip vrf forwarding XXX

ip address 10.2.127.209 255.255.255.252
load-interval 30
speed 100
duplex full
end


It depends on the module/interface you are using. It is only supported on some WAN interfaces as shaping is not generally available on Catalyst switches -


6500 Q&A


Catalyst switches have a completely different queueing system than routers so most of the MQC type configuration for queueing is not available -


6500 PFC QOS


Jon

Jerry Ye Mon, 01/18/2010 - 09:42
User Badges:
  • Cisco Employee,

Like Jon said, this type of configuration can only be done on the WAN line cards, like the FlexWAN and the SIP/SPA. None of the LAN line cards (WS-X6xxx) will support HQoS.


HTH,

jerry

Actions

This Discussion