Connectivity of Voip Phone.

Unanswered Question
Jan 15th, 2010

Hi All,

switch---> Voip Phone --> Pc

I have this kind of connectivity that a switch is connected to a voip phone ( cisco ) which in turn is connected to a pc.

Voip Phone acts like a switch. I have heard that switch is in suppose vlan 10. and switch port to voip phone is a trunk. so data traffic from  pc will get mixed with the voip data if they are in same vlan . so what is done is a native vlan like vlan 20 is defined on switch. data from the pc will pass through voip phone to trunk port on switch to native vlan 20 and data from voip phone will pass through trunk to vlan 10 through switch to the rest of the network and data mixing and qos all are prevented..

This is the logic what i have studied in a video for this avove drwan setup.

My question is :

1.) If the above mentioned setup is correct than how can we put a switch like voip phone to a particular vlan like vlan 10?

2.) if the voip also has two ports and is a switch why we cant put the phone port in different vlan and pc port in different vlan.

Can any body explain me this setup in more detail, so that my points can become more clear?

Regards,

Prateek

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcel Verbrugg... Fri, 01/15/2010 - 01:33

Hi Prateek,

The described setup will work, but the preferred setup is as follows:

interface FastEthernet0/x
switchport mode access
switchport voice vlan 10
switchport access vlan 20

This way no trunk is needed from the switch to the IP Phone. The IP phone will be in VLAN 10 (with QoS configured on this VLAN) and the PC behind the Phone will be in VLAN 20.

This should answer your first question.

I am not sure what exactly your second question is, but I think you want to try and configure VLAN ports on the switch inside the IP phone? That is not possible, the switch inside the IP phone is not as fully manageable as the normal catalyst switches are.

jain.prateek16 Fri, 01/15/2010 - 02:34

Hi,

Thank u so much for the nice reply Marcel.

The described setup will work, but the preferred setup is as follows:


interface FastEthernet0/x
switchport mode access
switchport voice vlan 10
switchport access vlan 20


This way no trunk is needed from the switch to the IP Phone. The IP phone will be in VLAN 10 (with QoS configured on this VLAN) and the PC behind the Phone will be in VLAN 20.

This should answer your first question.

But just want to confirm this Fa0/x is on the switch right?

Also please tell me if Fa0/x is on the switch then how would a single port on the switch is being used to support two devices.( IP Phone as well as PC?

And how would you put IP Phone configured to Vlan 10, is there a setting for it. How would PC be put in Vlan 20?

================================================================================

Also my setting is a IP Phone with two ports 10/100 Sw and 10/100 PC .

10/100 sw is going to the switch port and 10/100 pc port on the IP Phone is going to PC.

How is this setup working? Can u please elaborate this.?

Thanks,

Prateek

================================================================================


The described setup will work, but the preferred setup is as follows:


interface FastEthernet0/x
switchport mode access
switchport voice vlan 10
switchport access vlan 20


This way no trunk is needed from the switch to the IP Phone. The IP phone will be in VLAN 10 (with QoS configured on this VLAN) and the PC behind the Phone will be in VLAN 20.

This should answer your first question.


I am not sure what exactly your second question is, but I think you want to try and configure VLAN ports on the switch inside the IP phone? That is not possible, the switch inside the IP phone is not as fully manageable as the normal catalyst switches are.

prakadeesh Fri, 01/15/2010 - 04:10

hi prateek,

         The cli switchport voice vlan will actually create a psuedo trunk link( without actually creating a trunk). If you have a look at the show inter fa0/x switchport command you will be able to see voice vlan and the data vlan. This is a special CLI that we use to daisy chain an IP phone and PC to the same switchport. yes fa0/x is on the switchport as marcel suggested.

Now every IP phone is actually a switch, which will switch packets according to the PVID that it gets. so the IP phone will get the frames for both the PC and itself on the port that connects to the Switch. Now the Ip phone will basically switch the frames for itself to its internal port and the frames for the PC

on to the port connected to the PC. To the PC this is transperant and it just behaves like a normal access port connection.

Now there are different ways to set the Voice vlan on the IP phone.This depends on the IP phone itself.

1. Set the vlan ID to use for voice in the IP phone manually.

2. Set the voice vlan through dhcp. Now in this mode the IP phone should have been configured to a fully dhcp operational mode.

    The IP phone will first boot up in the data vlan ( vlan 10), request an IP address from dhcp on this VLAN. Now the DHCP server has to be configured to include option like say 191 where u can specify the voice vlan that the IP phone will use, on the data vlan IP pool scope. Say for example if its option 191, then the dhcp server will include VLAN-A:20. in its dhcp option config. Now on the reciept of this dhcp offer from the server along with an IP address in the data vlan range, the IP phone reboots it self( keeping the link UP). It will now reboot in the vlan 20 and release the previous Ip address in data vlan.DHCP request for vlan 20 is sent out now. Now option 128 can be used in the voice vlan IP dhcp scope to point the signalling server and stuff.

Hope that helps,

Prakadeesh

peter.mainwaring Fri, 01/15/2010 - 04:27

Hi Prateek,

That's an excellent reply from Prakadeesh.

Another command you may find useful to see what's connected is:-

show mac-address-table interface Fastethernet0/x

What you should see is the mac-address of the PC in the access VLAN and the mac-address of the phone in both the access VLAN and Voice VLAN.

This should confirm that your configuration is working.

Pete

marknejedlo Tue, 01/26/2010 - 09:20

1. Set the vlan ID to use for voice in the IP phone manually.

How do you set the vlan for the phone manually?  I haven't been able to find any documentation references to doing this.

Thanks

Mark

peter.mainwaring Wed, 01/27/2010 - 00:46

Hi Mark,

I have highlighted below the command (from the information that Marcel posted) which sets the phone VLAN manually:-

interface FastEthernet0/x
switchport mode access
switchport voice vlan 10
switchport access vlan 20

Pete

prakadeesh Wed, 01/27/2010 - 02:18

Hi Mark,

          when I said set the vlan for the IP phone manually, i was taking from the phone perspective. Some Ip phone have a setup option were you can manually type in the voice vlan. This is incase the DHCP voice vlan option is not working. To set the voice vlan on the switchport use the switport voice vlan command.

HTH,

prakadeesh

Actions

This Discussion