Etherchannel between 3120 and 6509 (CatOS)

Answered Question
Jan 15th, 2010
User Badges:

I am having an issue with getting a 3120 to create an etherchannel to a 6509 running CatOS (ver 8.6.3).  It is a standard etherchannel configuration.  On the 6509, I have the following configured:


set port channel 5/32-33,6/32-33 mode on


On the 3120 the 4 interfaces are configured as follows:


channel-group 13 mode on


When I bring up the interface on the 3120 it goes into an err-disabled state.  If I take etherchannel off the interfaces come up just fine.  The weird thing is that I have another 3120 that is configured the exact same way on both ends that is working.


The modules on the 6509 are WS-X6148A-GE-TX running PAGP.  I have tried all the different settings for etherchannal (on, desirable, auto) and they all fail.  Actually the 3120 won't let me set the mode to auto. It tells me that in auto mode all ports need to be on the same switch which I don't understand since the 3120 switches are stacked so that they appear as one switch and I am spreading the channel across 4 individual switches for redundancey.  Any insight to this would be appreciated.


Thanks,

Correct Answer by glen.grant about 7 years 6 months ago

  On the 3120 you have the channel forced on so you have to match the other end  or if you prefer to use pagp then it would have to be "channel group X mode desirable-nonsilent "  .Catos would be like "set port channel slot/port mode desirable non-silent  for pagp or set port channel slot/port mode active" . If using LACP then "channel group x mode active" on all interfaces.    Also bring up all interfaces up at the same time using the shut no shut on the port channel SVI .  If the 3120 is setup as a stack them you have to use crosstack etherchannel using LACP  or force all ports on  as  pagp is not supported on crosstack etherchannel.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
glen.grant Fri, 01/15/2010 - 11:14
User Badges:
  • Purple, 4500 points or more

  On the 3120 you have the channel forced on so you have to match the other end  or if you prefer to use pagp then it would have to be "channel group X mode desirable-nonsilent "  .Catos would be like "set port channel slot/port mode desirable non-silent  for pagp or set port channel slot/port mode active" . If using LACP then "channel group x mode active" on all interfaces.    Also bring up all interfaces up at the same time using the shut no shut on the port channel SVI .  If the 3120 is setup as a stack them you have to use crosstack etherchannel using LACP  or force all ports on  as  pagp is not supported on crosstack etherchannel.

g.hammond Fri, 01/15/2010 - 11:42
User Badges:

The module on the 6509 is configured for PAgP.  It doesn't matter what "mode" combination I use, it won't work.  Even bringing up just one interface on the 3120, it goes into error-disable.  If they are configured the same, it shouldn't error-disable.


As I mentioned, I've got another 3120 (stack) channeled to the same 6509 configured the same way that is working.

g.hammond Fri, 01/15/2010 - 12:19
User Badges:

Tried using the port channel SVI to shut and no shut the ports and that did the trick.


Thanks for your suggestion.

Actions

This Discussion

Related Content