Which NTP server to config on switch

Answered Question
Jan 15th, 2010
User Badges:

Hi all,


I have switch 2950 its default gateway is Router Lan interface 192.168.1.1

Also i have configured ntp server on

Router as


ntp server 132.163.4.101


Under switch 2950 which option i should choose to config ntp server


ntp server 132.163.4.101
  or


ntp 192.168.1.1


Please let meknow

thanks

mahesh

Correct Answer by Ganesh Hariharan about 7 years 6 months ago

Hi Mahesh,


As per the logs reach counter shows a value of 0 for the following configured NTP
server IP address(es):
  132.163.4.101
  128.233.3.100
  150.101.254.110
This means that the router did not receive at least the last eight NTP packets it expects to receive. Usually this counter shows a value of "377" which means that device has received at least the last eight NTP packets.


TRY THIS:


1. Make sure that NTP server IP address(es) mentioned above is reachable by pinging
   the server IP address(es).
2. Enable the debug ntp packet command to make sure that NTP packets are received
   from the server(s).
3. Make sure that NTP packets are not blocked by the access-list statement.
Make sure that above mentioned NTP server(s) is reachable by pinging the server
   IP address(es).
4. Issue the command show ntp status on the server(s) to make sure that NTP server
   has synched itself. If it is not synched, verify the server NTP configuration.
   The show ntp status of the server should display a status of 'sync' before
   clients can sync their clock with the server. If the NTP server is not synchronized
   itself try to disable and re-enable the NTP configuration on the server.
5. Verify that the 'stratum' value configured on the server is valid for your setup.
   Configure a high stratum number to ensure that this router does not override
   the clock on another system with a lower stratum number. The lower stratum number
   indicates a more reliable clock.


Hope that helps out your query !!


Regards

Ganesh.H

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Fri, 01/15/2010 - 13:00
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

ntp server 132.163.4.101 if the switch has reachability to it.


You can also use ntp server 192.168.1.1 as the router will be on sync with 132.163.4.101 and can provide time to other devices in your network.



Regards


Edison.

mahesh18 Fri, 01/15/2010 - 15:08
User Badges:

Hi Edison,



if i use 192.168.1.1  and then reload my switch it shows old time not current time.


it does not sync





sh ntp status
Clock is unsynchronized, stratum 16, no reference clock
nominal freq is 250.0000 Hz, actual freq is 249.9937 Hz, precision is 2**18
reference time is 00000000.00000000 (17:00:00.000 MST Wed Dec 31 1899)
clock offset is 0.0000 msec, root delay is 0.00 msec
root dispersion is 0.00 msec, peer dispersion is 0.00 msec
2950T2#sh ntp status
Clock is unsynchronized, stratum 16, no reference clock
nominal freq is 250.0000 Hz, actual freq is 249.9937 Hz, precision is 2**18
reference time is 00000000.00000000 (17:00:00.000 MST Wed Dec 31 1899)
clock offset is 0.0000 msec, root delay is 0.00 msec
root dispersion is 0.00 msec, peer dispersion is 0.00 msec


2950T2#sh clock
*17:03:33.252 MST Sun Feb 28 1993

Edison Ortiz Fri, 01/15/2010 - 15:11
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

What's the status of 192.168.1.1 ?


Let's see show ntp associations from both devices.

mahesh18 Fri, 01/15/2010 - 15:21
User Badges:

Hi Edison


thanks for reply

from switch


2950T2#sh ntp associations

      address         ref clock     st  when  poll reach  delay  offset    disp
~192.168.1.1      0.0.0.0          16     4    64    0     0.0    0.00  16000.
* master (synced), # master (unsynced), + selected, - candidate, ~ configured



Router


2650#sh ntp associations

      address         ref clock     st  when  poll reach  delay  offset    disp
~132.163.4.101    .ACTS.            1  25873    64    0    81.4   -0.20  16000.
~128.233.3.100    0.0.0.0          16     -    64    0     0.0    0.00  16000.
~150.101.254.110  0.0.0.0          16  1805    64    0     0.0    0.00  16000.
* master (synced), # master (unsynced), + selected, - candidate, ~ configured

Edison Ortiz Fri, 01/15/2010 - 19:08
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Your router is not on sync with the NTP servers.

A "*" next to the NTP server would indicate if this router is on sync.

Until then, this router can't provide time to other devices.

mahesh18 Sat, 01/16/2010 - 22:01
User Badges:

hi Edison,


thanks for reply i was able to fix the NTP issue now


many thanks

mahesh

Correct Answer
Ganesh Hariharan Sat, 01/16/2010 - 03:57
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi Mahesh,


As per the logs reach counter shows a value of 0 for the following configured NTP
server IP address(es):
  132.163.4.101
  128.233.3.100
  150.101.254.110
This means that the router did not receive at least the last eight NTP packets it expects to receive. Usually this counter shows a value of "377" which means that device has received at least the last eight NTP packets.


TRY THIS:


1. Make sure that NTP server IP address(es) mentioned above is reachable by pinging
   the server IP address(es).
2. Enable the debug ntp packet command to make sure that NTP packets are received
   from the server(s).
3. Make sure that NTP packets are not blocked by the access-list statement.
Make sure that above mentioned NTP server(s) is reachable by pinging the server
   IP address(es).
4. Issue the command show ntp status on the server(s) to make sure that NTP server
   has synched itself. If it is not synched, verify the server NTP configuration.
   The show ntp status of the server should display a status of 'sync' before
   clients can sync their clock with the server. If the NTP server is not synchronized
   itself try to disable and re-enable the NTP configuration on the server.
5. Verify that the 'stratum' value configured on the server is valid for your setup.
   Configure a high stratum number to ensure that this router does not override
   the clock on another system with a lower stratum number. The lower stratum number
   indicates a more reliable clock.


Hope that helps out your query !!


Regards

Ganesh.H

mahesh18 Sat, 01/16/2010 - 22:00
User Badges:

Hi Ganesh,


thanks for great reply.It was good note from you.


Mahesh

Actions

This Discussion