CFA not working to Off-net destinations

Unanswered Question

CFA not working to external numbers, but do work to internal DN's.

99.5% sure it's not a CSS issue.  When making calls to DID w/ CFA set, I get an error message from carrier.  We have a SIP trunk to CUBE router, then SIP trunk to CUCMBE (7.1.3).  Ran debug ccsip message on CUBE router, and call fails going to CUCMBE.  Get a error 404.  I'm attaching debug to discussion. 

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
CHRIS CHARLEBOIS Wed, 01/20/2010 - 09:28

Looks like you are getting a Q.850 cause code of 1, which is unassigned/unallocated number.  Can you call this number directly?  If you can, can you pull the debug from a sucessful call for comparison?

jaschulz Wed, 01/20/2010 - 10:52

Hello Ryan,

Has stated this indicates 

the clear code is unallocated/unassigned number, this suggests the status of the
dial peer is down.

Or it is possible that there is no route for 6108542201.

Could you attach

show dial-peer voice summary

And we can go from there.


DR-voice#sh dial-peer voice summary

dial-peer hunt 0

             AD                                    PRE PASS                OUT


100    voip  up   up             61040729..         0  syst ipv4:

101    voip  up   up             61085422..         0  syst ipv4:

110    voip  up   up             6106409485         0  syst ipv4:

111    voip  up   up             6106409836         0  syst ipv4:

120    voip  up   up             484913020[56]      0  syst ipv4:

200    voip  up   up             81[2-9][0-8].[2--  0  syst sip-server


201    pots  up   up             81[2-9][0-8].[2--  1                      down trunkgroup POTS


300    voip  up   up             8011T              0  syst sip-server

301    pots  up   up             8011T              1                      down trunkgroup POTS

900    voip  up   up             8[2-9]11           0  syst sip-server

901    pots  up   up             8[2-9]11           1                      down trunkgroup POTS

CHRIS CHARLEBOIS Wed, 01/20/2010 - 11:55

Actually, looking at it again, Q.850:1 is what the gateway is sending to the CUCM server.  The gateway is getting a Q.850:27 from the remote end of the SIP trunk, which is "Destination Out of Order".  It looks like the Dial-peer is getting matched correctly, but the remote end is refusing the connection.  I don't think the CFA component has anything to do with it.  I think the problem is on the remote gateway.

jaschulz Wed, 01/20/2010 - 12:06

So I guess I'm not getting the call flow here.

You said this was for CFWD to external numbers.

I assume the is CUCMBE, and we see from the debug 610854220 coming back in from sip:[email protected]

This debug looks like an inbound call to CUCMBE not a outbound call to PSTN.


Amitdivekar Wed, 01/20/2010 - 13:24

Hi Ryan,

            I hope you are doing well, so from what i have understood your topology looks like the following.

Ip Phone-->CallManager--Sip Trunk-->Cube--Sip Trunk-->CUCMBE-->Ip Phone

Please let me know if i have understood this correctly, moving ahead

we have received a "404 not found" error, which occurs because of the following:-

1. This response indicates that the server has definite information that the user does not exist in the specified domain.

2. The SIP gateway generates this response if it is unable to locate the callee.

3. Upon receiving this response, the gateway initiates a graceful call disconnect and clears the call.

Can you please attach the "Debug Ccsip All" for the complete call, as i am not able to see the disconnect message.

Could you do a "Show Dialplan number(the called number) & check which dial-peer is being hit.

Also could you please attach a show runn of your cube router.

Please let me know if this helps.




This Discussion