EIGRP filter routes being advertised

Answered Question
Jan 15th, 2010

I would like to filter the routes advertised out an interface by EIGRP based on a route tag. I am migrating from OSPF to EIGRP in a fairly large network. I have redistributed OSPF routes into EIGRP, and EIGRP into OSPF.

My problem is with one remote site R495 that is connected by two Gig fiber links and a backup wireless link. Most of the routes on router R495 at this remote site seem to be learned through the wireless link from router R421. The routes are distributed out the two fiber links, causing the other routers to not advertise these routes (better routes) toward R495 (split horizon). The result is that for these routes, the EIGRP topology table has only one entry, pointing to the wireless link. Only external routes (learned through redistribution from OSPF) exhibit this behavior. Much of the traffic from R495 flows through the wireless link rather than the Gig fiber links.

If I could filter the routes advertised toward R495 across the wireless link using 'match tag' , traffic would flow to the Gig fiber. Hopefully this problem would go away when I finish migration off of OSPF. (Although I am curious to know why this is happening).

Documentation on use of 'distribute-list out' or 'distribute-list in' is inconsistant on whether you can use route-map/match tag or you must use an access-list (which does not support matching tags).

I would like to do

R421osbr1

route-map ext-filter deny 10

match tag 11

route-map ext-filter permit 20

router eigrp 42

distribute-list route-map ext-filter out

or

R495prtg1

route-map ext-filter deny 10

match tag 11

route-map ext-filter permit 20

router eigrp 42

distribute-list route-map ext-filter in

but I don't know if this syntax is allowed.

The attached diagram:

Rectangles are routers.  Green run EIGRP only.  Others run Eigrp and OSPF.  The one in red is the re-distribution point between EIGRP and OSPF.  The wireless link in question is the lightning bolt up the middle of the page from R421osbr1 to R495prtg1.

Any help would be appreciated.

Regards,

Randall

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 6 years 10 months ago

Yes, route-map on distribute-list is supported.

I recommend filtering inbound on R495prtg1 and add the interface on the distribute-list in command.

Regards,

Edison.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Edison Ortiz Fri, 01/15/2010 - 12:34

Yes, route-map on distribute-list is supported.

I recommend filtering inbound on R495prtg1 and add the interface on the distribute-list in command.

Regards,

Edison.

rwiebe Fri, 01/15/2010 - 13:19

Thank you Edison.

It occured to me that I could also summarize the routes outbound on the wireless link at R421osbr1.  This way, R495prtg1 would have summarized routes from the wireless and be able to learn the more specific routes via the fiber links and these would be the prefered routes.  What do you think of this approach?

Randall

Edison Ortiz Fri, 01/15/2010 - 13:47

You could do that as well.

Summarizing will offer some kind of redundancy in case the primary route fails.

Distribute-list will block the route and can never be used as a secondary connection.

It depends on the requirements on how you want to proceed.

Regards

Edison

Please remember to rate helpful posts.

rwiebe Fri, 01/15/2010 - 13:50

Thanks for your help.  I will think about the options over the weekend and give it a try on Monday.

Regards,

Randall

rwiebe Tue, 01/19/2010 - 06:53

I set up a few different methods in a lab.  The following all had the desired effect on the routing table.

====================

! this example filters external routes from being advertised out interface vlan93

! specificaly ones redistributed from ospf and given tag 11

! uses a route-map to identify the routes that match tag 11

route-map ext-tag11 deny 10

match tag 11

route-map ext-tag11 permit 20

Router eigrp 4

distribute-list route-map ext-tag11 out vlan93

====================

! this example filters all external routes from being advertised out interface vlan93

! uses a route-map that identifies route-type external

route-map ext-all deny 10

match route-type external

route-map ext-all permit 20

Router eigrp 4

distribute-list route-map ext-all out vlan93

********************************

! this example filters a specific ip subnet route from being advertised out interface vlan93

! uses a distribute list to identify the route

ip prefix-list bad-route permit 172.17.205.0/27

!

route-map vlan91-route deny 10

match ip address prefix-list bad-route

route-map vlan91-route permit 20

!

Router eigrp 4

distribute-list route-map vlan91-route out vlan93

!

********************************

Note that applying the distribute list to Router EIGRP shuts down the EIGRP adjacency on the interface to which it is applied.  The adjacency rebuilds, and then the routing table at the other end no longer has the unwanted routes.

I will give a try in production filtering all external routes, since these are the ones being advertised up the slow link that I would like to remove.

Randall

rwiebe Tue, 01/19/2010 - 08:45

I gave it a try, and have the desired result, sort of.  Almost all of the traffic now takes the fiber link (mostly because of the default route).  But, the external routes are now not present at all on r495prtg1.  I would have expected them to be learned via the adjacent router on the fiber.  R70 is the redistributing router at the core.  I want routes to go to r151prnc1, then to r495prtg1.

I looked at a specific example, 192.168.56.64/27. On R70 which is the router that redistributes from OSPF to EIGRP (and EIGRP to OSPF) I see

R70#sho ip route 192.168.56.64

Routing entry for 192.168.56.64/27

Known via "ospf 1", distance 110, metric 11, type intra area

Redistributing via eigrp 42

Advertised by eigrp 42 metric 10000 100 255 20 1500 route-map ospf-to-eigrp

Last update from 192.168.253.92 on GigabitEthernet1/1, 1d00h ago

Routing Descriptor Blocks:

* 192.168.253.92, from 192.168.255.33, 1d00h ago, via GigabitEthernet1/1

Route metric is 11, traffic share count is 1

R70#sho ip eigrp topo 192.168.56.64 255.255.255.224

IP-EIGRP (AS 42): Topology entry for 192.168.56.64/27

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600

Routing Descriptor Blocks:

192.168.253.92, from Redistributed, Send flag is 0x0

Composite metric is (281600/0), Route is External

Vector metric:

Minimum bandwidth is 10000 Kbit

Total delay is 1000 microseconds

Reliability is 255/255

Load is 20/255

Minimum MTU is 1500

Hop count is 0

External data:

Originating router is 192.168.255.37 (this system)

AS number of route is 1

External protocol is OSPF, external metric is 11

Administrator tag is 11 (0x0000000B)

192.168.253.92 (GigabitEthernet1/1), from 192.168.253.92, Send flag is 0x0

Composite metric is (3072/2816), Route is External

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 20 microseconds

Reliability is 255/255

Load is 242/255

Minimum MTU is 1500

Hop count is 1

External data:

Originating router is 192.168.255.33

AS number of route is 0

External protocol is Connected, external metric is 0

Administrator tag is 0 (0x00000000)

Going to the next hop r151prnc1 I see

R151prnc1#sho ip route 192.168.56.64

Routing entry for 192.168.56.64/27

Known via "ospf 1", distance 110, metric 12, type intra area

Last update from 172.31.0.169 on GigabitEthernet2/0/1, 01:17:21 ago

Routing Descriptor Blocks:

* 172.31.0.169, from 192.168.255.33, 01:17:21 ago, via GigabitEthernet2/0/1

Route metric is 12, traffic share count is 1

R151prnc1#sho ip eigrp topo 192.168.56.64 255.255.255.224

% EIGRP-IPv4:(42): Route not in topology table TID(0)

then on r495prtg1

R495prtg1#sho ip route 192.168.56.64
% Network not in table


R495prtg1#sho ip eigrp topo 192.168.56.64 255.255.255.224
% EIGRP-IPv4:(42): Route not in topology table TID(0)

So here, r151prnc1 is still running OSPF while I am migrating to EIGRP. It is learning the route through OSPF, and not EIGRP. The result is that the route is not advertised to the next router r495prtg1 (EIGRP only) over the fiber. Now r495prtg1 does not learn the route through the wireless because I filtered it, and does not learn it through EIGRP over the fiber. Should router r251prnc1 (OSPF and EIGRP) learn the route through both protocols from R70?

Actions

This Discussion

Related Content