CME 7.0 call forward issues

Answered Question
Jan 16th, 2010

Hi all,

I am preparing my CCIE lab and I am trying to get hands on CME. I am having troubles with the call-forward feature on my CME lab environment.

1/

Considering css configured for a phone line that gives the rigth to forward all your calls on a CUCM.

When using phones registered with a CUCM, you press the CFwdAll softkey button once which open the primary line, then enter the number to which you want to forward all your calls. The line close and that is all. It is a one time button touch. If you want to disable your call forward, you simply press the CFwdAll button again.

On my CME phone, I need to press the CFwdAll softkey button (which open the line), enter a phone number (internal) and then press a second time the CFwdAll softkey button. It is only after pressing the CFwdAll softkey that it is taken into consideration.

I wonder if this is a normal behavior for a CME as I expected a behavior like with the CUCM.

2/

From notes and CME administration guide, I understand that call-forward pattern "number/wildcard" is the way to restrict call forward all from a global point of view instead of configuring it under each ephone-dn with the call-forward max-length command.

Here is my config and I cannot make the restriction work.

telephony-service

call-forward pattern 1...

ephone-dn 1 dual-line

number 1001

ephone-dn 2 dual-line

number 1002

ephone-dn 3 dual-line

number 1003

ephone-dn 4 dual-line

number 2000

ephone 1

button 1:1

ephone 2

button 1:2

ephone 3

button 1:3

ephone 4

button 1:4

From any of the ephone, I still can make a forward all to 333333.

Can you please help me and let me know if this something you already saw?

Thank you,

Julien

Correct Answer by Rob Huffman about 7 years 1 month ago

Hi Julien,

**1 The behaviour of CFWDALL in CME is not exactly the same
as in CUCM, so this is expected

Forward All Calls

To forward all incoming calls to another number:

1.Press the CFwdALL soft key. You hear a confirmation beep.

2.Dial the number to which you want to forward all your calls. Dial the number exactly as if you were placing a call to that number. Remember to include locally required prefix numbers.
The phone display is updated to show that calls will be forwarded.

3.Press the pound key (#) or the EndCall soft key.

NoteTo forward calls to voice mail, manually enter the voice mail number, or use the CFwdALL soft key plus the Messages button, followed by the EndCall soft key.

When call forward all is set, the display will show Call Forward Icon.
To forward calls to a speed-dial number, use the CFwdALL soft key plus a speed-dial button, followed by the EndCall soft key.

**2 The Call Forward pattern command is only applied
on h323 and Sip calls I believe. Don't forget the max-length
command configuration can be used at the ephone template level
so each phone would not need individual configuration

Check out this great info for your studies of CME from Tony Huynh @ Cisco;


https://www.myciscocommunity.com/docs/DOC-1523;jsessionid=DCD5CB23EF376C8C8A141B9C15662E35

Cheers!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Rob Huffman Sun, 01/17/2010 - 06:59

Hi Julien,

**1 The behaviour of CFWDALL in CME is not exactly the same
as in CUCM, so this is expected

Forward All Calls

To forward all incoming calls to another number:

1.Press the CFwdALL soft key. You hear a confirmation beep.

2.Dial the number to which you want to forward all your calls. Dial the number exactly as if you were placing a call to that number. Remember to include locally required prefix numbers.
The phone display is updated to show that calls will be forwarded.

3.Press the pound key (#) or the EndCall soft key.

NoteTo forward calls to voice mail, manually enter the voice mail number, or use the CFwdALL soft key plus the Messages button, followed by the EndCall soft key.

When call forward all is set, the display will show Call Forward Icon.
To forward calls to a speed-dial number, use the CFwdALL soft key plus a speed-dial button, followed by the EndCall soft key.

**2 The Call Forward pattern command is only applied
on h323 and Sip calls I believe. Don't forget the max-length
command configuration can be used at the ephone template level
so each phone would not need individual configuration

Check out this great info for your studies of CME from Tony Huynh @ Cisco;


https://www.myciscocommunity.com/docs/DOC-1523;jsessionid=DCD5CB23EF376C8C8A141B9C15662E35

Cheers!

Rob

lusandi Tue, 01/19/2010 - 05:14

Hello,

I hope you are doing great,

I just want to let you know that I did recreate your problem on my lab, whit the same result, even whit the call forward pattern set to “....” I was not able to make the transfer the call whit out pressing the soft key the second time, I will be researching on this in order to see if there is anything else I can do.

I hope I will be testing this today, and letting you know.

I have some coworkers here on the MS TAC team who told me that the behavior it is totally normal, and is working as designed.

Have a very good day.

julien.krieger@... Tue, 01/19/2010 - 05:26

Hi Luis Sandi,

The way button sequence to call forward a phone isas designed.

My wonder and what i cannot make work is the "call-forward pattern 1..." under telephony-service that is supposed to restrict the ability to call-forward only to 1... ephone-dns.

Thank you,

Julien

lusandi Tue, 01/19/2010 - 07:38

Hello,

I hope you are doing great,

Based on the H.450.2, when you are setting up the call forward, you will be providing a E.164 number, and in order to provide a local number, you will need to inform that to the gateway, in order to confirm the setup process of the protocol.

Keeping this in mind, you will need to press the soft key in order to provide the final setup step of the protocol.

I hope this information can help you.

Thanks,

http://www.itu.int/rec/T-REC-H.Imp323-200011-S/en

Actions

This Discussion