UC520

Answered Question
Jan 18th, 2010
User Badges:

Hello,

Is there a way on the uc520 to change the phone display language? I've a phone system in Mexico set up and in production. The vm language is Spanish and I have a dual language script running really well for call handling. However, users see the softkeys in English. I'd like to be able to change them to either English or Spanish. The phones are 7961. I've checked all the documentation but haven't found any relevant material.

Appreciate any help on this.

Thanks.

Vincent

Correct Answer by Marcos Hernandez about 7 years 4 months ago

Check this document:


https://supportforums.cisco.com/docs/DOC-9692


I am pretty sure you do not want to start from scratch though. CLI might be required, in which case this document will help:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmelocal.html


Thanks,


Marcos

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (2 ratings)
Loading.
vpersaud001 Mon, 01/18/2010 - 11:47
User Badges:

That's extremely helpful. I'll post an update upon completion. Thanks.

vpersaud001 Mon, 01/18/2010 - 12:36
User Badges:

Marco,

If the default user locale is already set to Spanish, shouldn't the display on the phones be in Spanish? Thanks.


sh telephony-service

....

user-locale[0] ES    (This is the default user locale for this box)

vpersaud001 Wed, 01/20/2010 - 09:45
User Badges:

Steven... I've attached the debug output.

Below uutput shows the localization file is installed and the locale configured on the template and in telephony-service. Am I missing anything else in the config? Thanks for your help.


cnf-file location: flash:
cnf-file option: PER-PHONE-TYPE
network-locale[0] ES   (This is the default network locale for this box)
network-locale[1] US
network-locale[2] US
network-locale[3] US
network-locale[4] US
user-locale[0] ES    (This is the default user locale for this box)
user-locale[1] US
user-locale[2] US
user-locale[3] US
user-locale[4] US


NiMexico_UC520#sh telephony-service ephone-template
ephone-template 15
softkey idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkey seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkey connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
conference drop-mode never
conference add-mode all
conference admin: No
max-calls-per-button 8
busy-trigger-per-button 0
privacy default
MLPP max precedence level -1
MLPP indication Enabled
MLPP preemption Enabled
Always send media packets to this router: No
Preferred codec: g711ulaw
keepalive 30 auxiliary 30
User Locale: ES
Network Locale: ES

NiMexico_UC520#sh run | be ephone  5

ephone  5
device-security-mode none
video
mac-address 0021.A02C.D163
ephone-template 15
username "snrsalesrep1" password vho677603
type 7961
button  1:12

Attachment: 
vpersaud001 Wed, 01/20/2010 - 10:18
User Badges:

Hello... I went through the process again with a Japanese locale file - downloaded the file to flash:/its, then completed the steps below ending in an unknown error per below. So it seems like I have to get this particular file to have a .cfg extension. But this may be completely different problem from getting the ES locale to work. Thanks very much for any help. 

NiMexico_UC520#config t
Enter configuration commands, one per line.  End with CNTL/Z.
NiMexico_UC520(config)#telephony-service
NiMexico_UC520(config-telephony)#$ CME-locale-jp_JP-Japanese-7.0.1.1.tar
Updating CNF files

LOCALE INSTALLER MESSAGE:Loading Locale Package...
LOCALE ERROR: Failure renaming flash:/its/CME-locale-jp_JP-Japanese-7.0.1.1.tar.cfg to flash:/its/japan_CME-locale-jp_JP-Japanese-7.0.1.1.tar.cfg ERROR#Unknown error 2573
%Error deleting flash:/its/CME-locale-jp_JP-Japanese-7.0.1.1.tar.cfg (File not found)
NiMexico_UC520(config-telephony)#

klemens.karwacki Thu, 02/25/2010 - 08:14
User Badges:

Hi,


had the same problem with the german tar file:

22 Oct 2008 -                            www.cisco.com/cgi-bin/Software/Tablebuild/doftp.pl?ftpfile=/cisco/voice/...


router(config-telephony)#user-locale 1 DE load CME-locale-de_DE-7.0.1.1.tar
LOCALE INSTALLER MESSAGE: Old Locale removed
Updating CNF files


LOCALE INSTALLER MESSAGE:Loading Locale Package...
LOCALE ERROR: Failure renaming flash:/its/CME-locale-de_DE-7.0.1.1.tar.cfg to flash:/its/germany_CME-locale-de_DE-7.0.1.1.tar.cfg ERROR#Unknown error 2573
%Error deleting flash:/its/CME-locale-de_DE-7.0.1.1.tar.cfg (File not found)
LOCALE INSTALLER MESSAGE: old files removed, re-enter the command if you want to configure locale DE with package CME-locale-de_DE-German-7.0.1.1.tar
router(config-telephony)#


downloaded a new version:

10 Dec 2008 -                            www.cisco.com/cgi-bin/Software/Tablebuild/doftp.pl?ftpfile=/cisco/voice/...


and it worked:

router(config-telephony)#user-locale 1 DE load CME-locale-de_DE-German-7.0.1.1.tar
Updating CNF files


LOCALE INSTALLER MESSAGE:Loading Locale Package...
LOCALE INSTALLER MESSAGE: VER:1
LOCALE INSTALLER MESSAGE: Langcode:de_DE
LOCALE INSTALLER MESSAGE: Language:German
LOCALE INSTALLER MESSAGE: Filename: 7921-dictionary.xml
LOCALE INSTALLER MESSAGE: Filename: 7921-font.dat
LOCALE INSTALLER MESSAGE: Filename: 7921-kate.utf-8.xml
LOCALE INSTALLER MESSAGE: Filename: 7921-kate.xml
LOCALE INSTALLER MESSAGE: Filename: be-sccp.jar
LOCALE INSTALLER MESSAGE: Filename: g3-tones.xml
LOCALE INSTALLER MESSAGE: Filename: gp-sccp.jar
LOCALE INSTALLER MESSAGE: Filename: ipc-sccp.jar
LOCALE INSTALLER MESSAGE: Filename: mk-sccp.jar
LOCALE INSTALLER MESSAGE: Filename: tc-sccp.jar
LOCALE INSTALLER MESSAGE: Filename: td-sccp.jar
LOCALE INSTALLER MESSAGE: New Locale configured


maybe there is a general problem with some files from 22.Oct 2008?

vpersaud001 Thu, 03/04/2010 - 06:21
User Badges:

Hi Klemens.... Thank you. I'll try to implement that this weekend and update after.

Hasrat Raja Fri, 03/26/2010 - 09:38
User Badges:

Hi Marcos,


My 7942 is not registering, here is the output from debugs:



UC520#sh ephone 7942

No ephone in specified type/condition.

UC520#
UC520#
UC520#
UC520#sh ephone 0026.CB3D.DE4F


ephone-11[10] Mac:0026.CB3D.DE4F TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0
IP:10.1.1.11 29287 Unknown 0  keepalive 0 max_line 0 available_line 0
Preferred Codec: g711ulaw

UC520#



UC520#
Mar 26 11:25:40: TFTP: Server request for port 50743, socket_id 0x86F0B024 for process 132
Mar 26 11:25:40: TFTP: read request from host 97.83.188.207(50743) via Vlan1
Mar 26 11:25:40: TFTP: Looking for SEP0026CB3DDE4F.cnf.xml
Mar 26 11:25:40: TFTP: Opened system:/its/XMLDefault7942.cnf.xml, fd 10, size 1316 for process 132
Mar 26 11:25:40: TFTP: Sending block 1 (retry 0), socket_id 0x86F0B024
Mar 26 11:25:40: TFTP: Received ACK for block 1, socket_id 0x86F0B024
Mar 26 11:25:40: TFTP: Sending block 2 (retry 0), socket_id 0x86F0B024
Mar 26 11:25:40: TFTP: Received ACK for block 2, socket_id 0x86F0B024
Mar 26 11:25:40: TFTP: Sending block 3 (retry 0), socket_id 0x86F0B024
Mar 26 11:25:43: TFTP: Sending block 3 (retry 1), socket_id 0x86F0B024
Mar 26 11:25:47: TFTP: Sending block 3 (retry 2), socket_id 0x86F0B024
Mar 26 11:25:52: TFTP: Sending block 3 (retry 3), socket_id 0x86F0B024
Mar 26 11:25:58: TFTP: Sending block 3 (retry 4), socket_id 0x86F0B024
Mar 26 11:26:05: TFTP: Finished system:/its/XMLDefault7942.cnf.xml, time 00:00:25 for process 132
UC520#



Thanks


hasrat

Marcos Hernandez Mon, 03/29/2010 - 09:16
User Badges:
  • Blue, 1500 points or more

Can you please post your config? Remember to remove the passwords.


Marcos

Actions

This Discussion

Related Content