dot1x authentication on 3750 switch

Unanswered Question
Jan 19th, 2010


I have 3750 switch (WS-C3750G-24TS-S1U) with IP Services version

Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 28    WS-C3750G-24TS-1U  12.2(46)SE            C3750-IPSERVICESK9-M

on the switch,

I have configured

aaa new-model
aaa authentication dot1x default group radius

dot1x system-auth-control

but i am not able to implement the command under interface

Switch(config)#int gigabitEthernet 1/0/20

dot1x commands are not available under the interface config. Is the IOS version is compatible with dot1x? what i am missing over there?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
mrbzumrbzu Thu, 01/21/2010 - 03:58


I have tried the lattest version of IOS but the dot1x commands not available under the interface.

Ihave other cisco 3750 switches, using the same IOS i can see the dot1x commands under the interface.

Is cisco WS-C3750G-24TS-1U supports dot1x or no?

i have tried various ipbase and ipservices images from latest to old but dot1x commands not availble.

your help will be highly appriciated.

peter.mainwaring Thu, 01/21/2010 - 08:46

I can't be sure now as I no longer have access to the switches I configured, but I think I had to configure the port with SWITCHPORT MODE ACCESS before the dot1x commands became available.

I may be wrong, but give it a try.


Charles St Clair Tue, 05/14/2013 - 13:25


     Thank you for taking the time to post an accurate answer to the user's question. We were having the same issue here and by applying "switchport mode access" to all the interfaces that were missing the "authentication" and "dot1x" commands we are now able to configure those interfaces.

Patrick McHenry Fri, 09/02/2011 - 17:21


I was having the same problem. The syntax for the new ipbase seems to be different. See below. I was a little worried as I was updating all of switches with this image and was intending on implementing dot1x but, I think we are alright.

ACB21(config-if)#authentication port-control ?

  auto                PortState set to automatic

  force-authorized    PortState set to AUTHORIZED

  force-unauthorized  PortState set to UnAuthorized


This Discussion