IPCC Express script is not working

Answered Question
Jan 19th, 2010

Hello,

i am ahving one script that is configured with script editor fine but when i play with cucm then call for on duty time going to off duty time extneison number.

why is it happening.

it is not shwoing any error in the debugg also.

I have this problem too.
0 votes
Correct Answer by dmotloch about 6 years 10 months ago

I loaded your script on my server and tested it -- worked well.... it is about 10:30 AM here and it rang the "helpdeskadmin" phone.... not the "off duty" phone.... but I made a few changes before running it.

I removed the unused "connection 2, 3, 4" from the time of day.

Did you try the reactive debug?  That is very handy for finding what goes wrong.

Let me know if you need more help.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
dmotloch Tue, 01/19/2010 - 07:27

I loaded your script on my server and tested it -- worked well.... it is about 10:30 AM here and it rang the "helpdeskadmin" phone.... not the "off duty" phone.... but I made a few changes before running it.

I removed the unused "connection 2, 3, 4" from the time of day.

Did you try the reactive debug?  That is very handy for finding what goes wrong.

Let me know if you need more help.

cisco.amit Tue, 01/19/2010 - 20:38

Hello Dear,

Thanks for reply on mythis part of question.

I need some more help from your end.

Actually, my main requirement is to floe call as iwant for my office:

my office timings are from 9.30am to 6.00pm.

at this time, call should go to 1111 extension number that is helpdesk admin number.

this is valid for monday to saturday, but i have first and third saturday full 9.20 to 6.00 and second and fourth saturday close.

And after 6.00pm to 9.30 am call should go to off duty number that is 1112, or any mobile number that i will change and upload.

When i try to call accordingly to dfay, it is working but when i add time in it then it goes to off duty enfineer number in onn duty time.

Please tell me what is the issue coming due to this is nto working.

please tell me what is the reactive debug and how to use it for test the script?

cisco.amit Tue, 01/19/2010 - 21:00

Hello Dear,

Please check again and send me the tested and working script.

I am sending the script in which i follow your points and found the sme error adn call is also going to off suty engineer extension that is 1112.

Please correct and send methe correct file that is working.

cisco.amit Tue, 01/19/2010 - 21:03

Hello Sir,

Please tell mehow is it going to helpdesk admin extension at 10.30am?

I loaded your script on my server and tested it -- worked well.... it is about 10:30 AM here and it rang the "helpdeskadmin" phone?

what is it mention onthe script at 10.30/

please clear me so that correct me and see it is working fine.

cisco.amit Thu, 01/21/2010 - 02:13

Hi sir,

please tell me how did you see that time is showing 10.30 and how the call is going to helpdesk admin?

I am trying to call flow to admin but call is not going to helpdesk admin and it is forwarding to off time user.


When u changed t in the configuration then please send me your change script so that seethat file.

ryan_bell Tue, 01/19/2010 - 09:34

Yeah looks good, verify your time on the server. Also as mentioned before, I'd remove those unused connections in the time of day, though this really shouldn't affect anything.

cisco.amit Tue, 01/19/2010 - 20:39

Hello Dear,

Thanks for reply on my points with your all possible views.

But the time is correct on server and CUCM server also.

The problem is coming to flow the call to onduty extension.

Please tell how to flow call with on and off duty time part?

dmotloch Wed, 01/20/2010 - 07:45

The reactive DEBUG can be found in the script editor under debug... select the script by name and enter a value like 10 seconds or so -- then click ok/start... or whatever it says.

Then call the trigger -- your script will pop up and you can step through it with the tool bar options (one step at a time, etc.) -- this will allow you to see exactly what step the script goes wrong at.

If you'd like help scripting email me at [email protected] -- I'd be happy to help.

Thanks.

Derek.

cisco.amit Wed, 01/20/2010 - 21:38

Hi Sir,

I have forwarded my script to your emaila ddress so that check adn correct it so that apply in our network without any problemthat still facing on it.

Please do it and send me back and if need any further information, please call me on +91-9911372100.

Actions

This Discussion

Related Content