FTP from Cisco IOS device failure

Unanswered Question
Jan 19th, 2010

Hi all,

I have FTP case, i suspected that what caused it

In my lab, Two Cisco 2811 connected together with back-to-back interface with clock rate 256Kbps

I tried to FTP file from flash memory of router to server but it not completed such as I would like to get file 1.5 MB from router but i received only 1.4 MB!!!

I tried to change the files size to smaller/ larger and change speed as well but i getted the same result. I did not sure this cause come from Router or IOS. Could anyone advice me about this case?

PS. I getted the code from FTP application, 221 Services closing control connection

      I transfer file between PC through these router, succeed

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sergei Vasilenko Wed, 01/27/2010 - 02:55

Hello Decho,


Which IOS version are you using this router?

From the description it could be anIOS bug,

for example:


CSCsx46421 File Transfer aborts with the Active FTP

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsx46421


You migth try to test the described Workaround:

Use Passive FTP ("ip ftp passive" on problematic router) for the FTP

file to be properly transferred.


and consider an upgrade to one of the release with the fix.


Thanks,

Sergey

Actions

This Discussion