LMS 3.2 - UserTracking (UT) data not up to date

Unanswered Question
Jan 19th, 2010

Hello,

I use LMS 3.2 with three servers where CS and CM are running on the first server, RME is running on the second one and IPM is running on the third.

The most switches are 3560-24PS-S or 3560-48PS-S with IOS 12.2(46)SE.

Since some weeks I have the problem, that the usertracking data is not up to date.


1. problem:
end hosts are not discovered by CM. all switches are available for CM and data collection works fine.
data collection is running one hour before the user tracking major collection. I scheduled three major runs a day and minor acquisition every 60 minutes.


2. problem:
there are 56000 entries in the UT database, but only 29000 end hosts have a valid "last seen date". the other 27000 hosts have a date of july 2009. the delete intervall is 60 days after every major update. I don't know why they are in the database. some of them have the state "active".
How I can clean the UT database safely so I don't have any old entries in it when I start a new discovery?


One fundamental question: Is it better to use the UT dicovery cycles or to send MAC-notification traps to the CM server?
I think to send traps could be the better way because on a NAC it works fine, too.


Thanks for any advise.

Sven

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sven Hruza Thu, 01/21/2010 - 00:52

Hello,

I deleted all end hosts over the web gui now.

I set the delete interval to one day and thought, that I will have only the last found hosts in database after that.

But after I activated the "delete now" button all hosts were deleted. A little bit strange I think....

After that I started a data collection for all 6340 devices. The collection was successful.


But after that the user tracking job was not so successful. Only 17000 end hosts were found.

What can I do to see where the failure is?

Thanks a lot!

Sven

Sven Hruza Fri, 01/22/2010 - 02:33

I think I have a bigger database problem....

Since yesterday a lot of UT discoveries were running with everytime the same result: there where found not more than 18000 end hosts.

Now I restarted the LMS processes and after that there where over 62000 entries in the database.

That is good, at the first view

But on the second view I saw that all "last seen date" is between may and july 2009.

Does anybody know something about such a failure?

Thanks!

Sven Hruza Mon, 01/25/2010 - 04:21

Thanks for the answer.

I attached the ani.log.

Data Collection began at 10:13 and ended at 11:31 for 6372 devices.

Attachment: 
Joe Clarke Mon, 01/25/2010 - 20:08

I'm not seeing the error I would expect.  Post the ut.log after running a major acquisition?  What version of Campus do you have?

Joe Clarke Tue, 01/26/2010 - 15:59

There are no fatal errors here.  Given you are running CM 5.2, you are not seeing the bug I mentioned.  I suggest you open a TAC service request so more debugging, and possibly live analysis can be done.

Sven Hruza Thu, 01/28/2010 - 03:13

I completely forgot that cisco gave a limit to 5000 devices on campus manager.

Could that be a problem for usertracking because I have 6400 devices in it with something about 1500 standalone accesspoints.

Is the limit only for performance or is there a bigger issue?

Thanks!

Joe Clarke Fri, 01/29/2010 - 19:06

If you have a 5000 device license, then Campus will only manage 5500 devices.  No more will be managed after that.  That said, Campus has a recommended limit of 5000 devices total.  If you have a 10K license loaded, Campus will attempt to manage more than that, but such a configuration is not supported.  you would need to reduce the managed device count to 5000 before contacting TAC.  See http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_lan_management_solution/3.2/install/guide1/prereq.html#wp1101012 for details.

Sven Hruza Tue, 02/02/2010 - 05:32

I excluded all accesspoints out of CM and now I have 4940 devices in it.

UT worked fine now and all entries older than 30 days were deleted. There were 29000 end hosts in the database.

Now I had to restart the services and after that I have 62000 devices in the database and all have an old date of may till juli 2009.

Is there any possibility to delete the database in depth because I think there are a lot of end host corpes in it

Thanks a lot!

Sven Hruza Wed, 02/03/2010 - 06:35

I used the reinitdb.pl script for deleting the ani database.

Now I have 4929 devices and 27480 end hosts in the database. Looks fine at the moment.

One question to the limitation of 5000 devices for campus manager.

Is there a hardcoded limit in the application and why this limit exists?

Because we have a license for 10.000 devices so it is very annoying that we can use only the half of the devices in CM.

Is there a solution for more than 5000 devices?

Thanks!

Joe Clarke Wed, 02/03/2010 - 15:24

There is no hardcoded limit, but you can still manage 10K with Campus.  You just need to use two Campus servers.  That is,

half of the devices will be managed by one Campus instance, and half by the other.  The two servers can share the same DCR (with all 10K devices),

however.

Sven Hruza Wed, 02/03/2010 - 23:13

Okay, but with two Campus Managers the daily business getting a little bit complex because all collegues have to know on which CM they will find a device they are surching for.And the UserTracking Utility will not work because I can't configure two servers, right?

That is not realy what I want.

Joe Clarke Thu, 02/04/2010 - 16:45

Everything you have said is correct.  It would be difficult for help desk operators to know from what server a user should be seen.  That is one of the challenges being worked on for LMS 4.0.

Actions

This Discussion

Related Content