CUPC - Presence Failed to connect (general setup issues)

Unanswered Question
Jan 19th, 2010
User Badges:

Freshly installed CUP 6.0 and I am to the point that CUPC will log in but the Server Health shows the following:

Logon Server- Connected

Phone Configuration (TFTP)- Download Failed

Presence- Failed to Connect- No Servers Configured

Desk Phone- Not Active

Softphone- Not Active

Voicemail- Not Connected-No Servers Configured

Web Conferencing- Not Available- No Servers Configured

LDAP- Failed - No Servers Configured


The CUP troubleshooter shows this warning:

The port for the SIP Publish Trunk on Cisco Unified Communications Manager does not match any configured ports for the Cisco Presence Engine Listeners on the Cisco Unified Presence server.

The SIP trunk has been set up, though I dont know how to confirm its working correctly.


I have read all the documentation and threads I can find to get past this but I am missing something. Most likely something simple.


Any epiphanys or nudges in the right direction would be greatly appreciated.


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
scott.hammond Tue, 01/19/2010 - 11:01
User Badges:

are you trying to sell me the answer?

Okay, thanks for that. I think I will wait and see if anyone has any free suggestions first.


Like any debugging or logging I could do, or even a high level description of the data flow from client-CUP-UCM. Since the end user data is synced I assume CUP and UCM are on speaking terms, and I know UPC is talking to CUP. The thing that I dont understand is why UPC says there is no presence server configured when that is what I am logging into.


So did I miss populating some field, or is this all a symptom of a SIP trunk failure?

htluo Tue, 01/19/2010 - 11:10
User Badges:
  • Red, 2250 points or more

It'll be a long answer to all your configuration questions.  And all those questions were answered in documentations.


Prsence won't work without SIP authentication (digest authentication).  In case you didn't know, there are three different ways to configure/bypass digest authentication:

1) from CUCM

2) From CUPS access list

3) From CUPS service parameters.


UPC won't work until you configure TFTP and UPC device.  And if it's not confused enough, CUPC != UPC device.  And CUP licensing != CUPC licensing.


Neither soft phone nor desk phone will work unless you have primary extension configured.


Desk phone won't work if you're using LDAP authentication and the LDAP server sent back a LDAP referral.


And you haven't configured LDAP profile, voicemail profile, web conference profile yet.


Again, all the answers are in documents.


Michael

scott.hammond Tue, 01/19/2010 - 11:25
User Badges:

alright dude, no need to be a jerk about it.


Forums like this are infinitely useful, but infinitely less useful when people respond with snide "read the documentation" comments. Links are helpful, but not really when its something for sale.


However, thankyou for being slightly less of a jerk and giving me something useful. I will look at the authentication piece, and I honestly appreciate it.


You will not be getting a christmas card from me though.

scott.hammond Tue, 01/19/2010 - 11:52
User Badges:

Oh and the SIP problem wasnt authentication, it was the port. I assumed 5060 was to be on both sides, but found in another thread that the UCM side has to be 5070.


So I am one step closer.


Of course it still doesnt work, it hits UCM (TFTP) looking for some config file that isnt there, so it fails. UPC never registers with UCM so I do not have the ability to set it up. (another assumption on my part is that UPC is pretty much like IPC in that regard)


I noticed IP Phone messenger doesnt work either from CUP, so there is something other than SIP missing.

htluo Tue, 01/19/2010 - 11:58
User Badges:
  • Red, 2250 points or more

There are two kinds of prensece here: phone presence and IM presence.


For phone presence, you'll have to set up a SIP trunk between CUCM and CUPS.  For CUPS 6.x, the port number is 5070.  For CUPS 7.x, the port number is 5060.


For IM presence, CUPC has to authenticate with CUPS on SIP level, which requires Digest Authentication on CUCM End User configuration.  Or you'll have to configure incoming ACL on CUPS to bypass it.


For TFTP, you'll have to configure UPC device on CUCM > Device > Cisco Unified Personal Communicator.  The device name should be UPCJDOE (where JDOE is the user ID).  All upper case.


Michael

scott.hammond Tue, 01/19/2010 - 12:05
User Badges:

Good to know.


I will look at the the CUPC to CUPS ACL's.


yes, that is the format of the file its looking for. Problem there is CUMCM>Device> I have no UPC option


So I am missing something on UCM to make UPC happen. I will look into it....


Seriously, Thanks!


Im beating my head on the desk here as I volley from document to document trying to put the pieces together. (the media server is a loaner so I only have a short time to get this going, present to the user populous and then try to get funding for mass deployment- hence my hurry and panic)


Cheers!

scott.hammond Tue, 01/19/2010 - 12:28
User Badges:

You have to manually set up the UPC's before they register!


I didnt expect that, thought it would be treated like IPC. Oh well, they are registered and I have call functionality.


You were right htluo, it was a host of things and not just one little check box.

Actions

This Discussion