CME External Directory

Unanswered Question
Jan 19th, 2010
User Badges:

Our customer has a Unified CM cluster and a few Call Manager Express and he needs that ip phones registered in the CME could consult the Call Manager corporate directory. I´ve configured all steps described in the chapter "Configuring Directory Services" in the "Cisco Unified Communications Manager Express System Administrator Guide"  but when I press the Directory button, there isn´t any option to search coportate directory. I´ve configured the same url in telephony-service as in the Call Manager and I've add the ip phones in the Call Manager. I´m missing something?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jimander Tue, 03/02/2010 - 13:26
User Badges:

Did you ever get an answer on this? I'm running into the same problem but what I have figured out is that if your CME phones have registered to CUCM at least once EVER then the directory will work. There is some sort of switch that gets flipped in the phone once it has registered to CUCM and the directory will always work after that, regardless of CUCM/CME/whatever.


This is the URL I am using in CME- pointing to the CUCM Directory URL from Enterprise Manager.


url directories http://XXX.XXX.XXX.XXX:8080/ccmcip/xmldirectory.jsp


I've been running through various scenarios and it seems like the behavior change happens after xmldefault.cnf.xml is loaded from the CUCM.


I'd appreciate the input from any Cisco IP Phone SME's out there. I have the xmldefault.cnf.xml from CME and CUCM and while they are different I can't find any obvious reason for the behavior.

jimander Tue, 03/02/2010 - 13:49
User Badges:

I found the answer to my own question with further trolling through NetPro at https://supportforums.cisco.com/message/1217097#1217097


It's not the xmldefault.cnf.xml, it's the fact that after that file is read CUCM has created an AutoReg config entry for the device.


CUCM will only serve the Directory to phones that are in the Device Database, ensuring that more DLU's are purchased.

analavric Mon, 03/22/2010 - 12:12
User Badges:

Hi! sorry, I saw your posted just now.


I registered the IP phones in our Call Manager, and yes, as you say, after that I could see the directory en the same phones but now registered in the CUCME. But when I reset the CUCME, I have the same problem with the directory.

Did you try reload the CUCME and then try to access to the directory?

Actions

This Discussion