SPA525G - But where do I set the string serv=tftp://192.168.2.2/;d0=English-US;x0=spa525_EN_7_2_5.xml;d1=German;x1=spa525_DE_7_2_5.xml

Unanswered Question
Jan 8th, 2010
User Badges:

Hi Patrick,


i´m still trying to localize my 525G, too.

But my Web-GUI of the 525G is in r/o-mode

and i can´t set any command like


serv=tftp://192.168.2.2/;d0=English-US;x0=spa525_EN_7_2_5.xml;d1=German;x1=spa525_DE_7_2_5.xml


(I´m a newbie on UC500 and have no further idea)


By the way, i want to localize several 521, too

but i can´t find the mentioned file CP_521_524_Dictionary.tar

from other topics. (cco-account is at hand)


Any idea?



Kind regards,

DetNit



Hi, now i´ve found the "WEB-Server writable"-button !!!

(Firmware 7.4.3)


But where do I set the string

serv=tftp://192.168.2.2/;d0=English-US;x0=spa525_EN_7_2_5.xml;d1=German;x1=spa525_DE_7_2_5.xml ???


Kind regards,

DetNit

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
DetNit1101 Tue, 01/19/2010 - 00:17
User Badges:

Hi @ all,


the first way was a dead-end for me and I got another hint:


For language "german" I puth both files


     spa525_DE_7_2_5.xml

     spa525_EN_7_2_5.xml


in the following directory


     flash:/phones/525/


and put following strings to the config of the UC520


     tftp-server flash:/phones/525/spa525_DE_7_2_5.xml alias German_Germany/525G-dictionary.xml
     tftp-server flash:/phones/525/spa525_EN_7_2_5.xml alias English_United_States/525G-dictionary.xml



and it works!


additional info: Firmware 7.4.3 can work with dictionary 7_2_5


Thanx to RaLe !!!


Greetings & happy Copy&Paste,


  DetNit

ROBERTO TACCON Tue, 02/02/2010 - 05:41
User Badges:

Hi,


I'm trying to localize in Italian the PHONE 525G with firmware version 7.4.3.


My TFTP server IP is 192.168.1.55
My IP PHONE 525G IP is 192.168.1.4


I've put the spa525_EN_7_2_5.xml and the spa525_IT_7_2_5.xml files on the TFTP server.



Using the web browser on the PHONE 525G (192.168.1.4) I've configured the following string on the following menu (using admin login and advanced option):

Voice
Regional
Language


serv=tftp://192.168.1.55/;d0=English-US;x0=spa525_EN_7_2_5.xml;d1=Italian;x1=spa525_IT_7_2_5.xml;


BUT THE PHONE LOAD THE ENGLISH version.

I can see on the phone on the menu the option to use the italian language but the PHONE doesn't change it (still remain in english).


Can someone help me ?


Regards


Roberto Taccon

DetNit1101 Tue, 02/02/2010 - 06:09
User Badges:

Hi Roberto,



forget the way with serv:= and try this way


Put these additional strings into your UC-Config. Make sure to use the right names for the directories.

(I´ve changed language/country from German_Germany to Italian_Italy ?but I don´t know your according directories on the UC

in which the files are located)


     tftp-server flash:/phones/525/spa525_IT_7_2_5.xml alias Italian_Italy/525G-dictionary.xml
      tftp-server flash:/phones/525/spa525_EN_7_2_5.xml alias English_United_States/525G-dictionary.xml


If the phone now is requesting the localisation "Italian_Italy/525G-dictionary.xml" then the UC provides the file

"flash:/phones/525/spa525_IT_7_2_5.xml" means


It works - in my case ...  :-)



Please check for the right name-settings for Italy



Greetings, DetNit

ROBERTO TACCON Tue, 02/02/2010 - 06:32
User Badges:

Hi,


I haven't the UC . I use "only" SIP IP phones (generally prefer SNOM phones) because I'm using an external internet SIP provider.


Regards,


Roberto Taccon

Joachim Kern Fri, 02/05/2010 - 02:53
User Badges:
  • Cisco Employee,

serv=tftp://192.168.16.100/;d0=English-US;x0=spa525_EN_7_2_5.xml;d1=Italian;x1=spa525_IT_7_2_5.xml;


I used the string above. Worked for me with firmware 7.4.3.


The phone loads the xml files from the tftp server when you actually select the Italian language for the first time on the phone display.

Check your tftp server when you actually select Italian on the display and press the SAVE softkey.

Attachment: 

Actions

This Discussion