Catalyst 3524-XL Error LED's

Unanswered Question
Jan 20th, 2010
User Badges:

Hi all!


So im looking at doing my CCNA, so i got a second hand 3524XL off ebay with a bunch of routers, anyway, ive worked with some 3524's before, but ive never seen this.....


When i power it on, i get the following

The RPS light is amber

The following link lights are amber: 3, 7, 11, 15, 19 and 23


There are no ethernet cables connected at all.


When i plug into the console, i get garbage currupt charecters, nothing that makes any moderatly decipherable sense. Its things like the copyright symbol etc


I tried all the speeds (that was a fun hour or so )


No other LEDs are on at all, after leaving it on for an hour or so, NOTHING changes.


I tried holding in the mode button while its on, no response at all


Tried holding down the mode button and powering it on, the only change is that LED's 3 and 23 dont turn on, leaving LED's 7, 11, 15, 19 on


Powered it all off overnight, rinse repeat, no change


After googling for a bit i found nothing except if you remove 15 you get prime numbers!


So does anyone know what this means and is it fixable?


I opened it up, there are a few bulging capacitors on the main board, the PSU is fine....... Ill replace them at some point, but could it be the issue?


Im connecting just with the Std IEC lead, not the RPS, dont have one of those :'(


So yeah, anyone able to shead some light on this for me?


Thanks guys!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
s.marino Wed, 01/20/2010 - 05:13
User Badges:

Alek,


This sounds like a switch that might have been hit by a power surge.

Things may look ok but are really not.

Can you take a snap shoot of the switch from when you power it you until it completes the boot process.



Sal

Leo Laohoo Wed, 01/20/2010 - 13:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I've seen this behaviour and it's very common to the 2900/3500XL and the 2940/2950.  During the bootup process the switch undergoes a POST and if the port lights go amber it could be that the loopback test failure on the following ports mentioned.

pattya94191 Thu, 01/21/2010 - 02:05
User Badges:

Hey guys,


Thanks for the responses, much appreciated!


I have attached a photo for reference, we are looking at the middle switch, the others work fine and dandy!


In regards to a loopback fault, if that is the fault, should i still be able to get into the console of the switch?


Thanks guys, really appreciate the help!!!!

Attachment: 
pattya94191 Fri, 01/22/2010 - 18:32
User Badges:

Fixed it!


I opened the thing up and realised that one of the caps was majory dead, whole top had shot off.....


I replaced the caps with some brand new ones.... fired it up and away we go!


One fixed switch!


Thanks for all the help guys!!!


If uploaded some before and after pics so you can see the blown caps.....


Hope this helps someone else in the future!


My electronics store didnt have the exact capacitors (1000*funny u*F (micro Farad) 10 v) so i replaced mine with 16v 1000microfarad.....


Dont change the farads, you have a bit of give and take with the voltage but.... if you arent sure... hunt down exactly the same!!!!

Attachment: 
constantin.oprea Sat, 02/13/2010 - 12:01
User Badges:

Hi,

I have a problem like this.

My 3524-XL-EN starts with RPS and random ports amber. I replaced all caps, but nothing happened.


Do you have any ideeas?


pattya94191 Sat, 02/13/2010 - 14:05
User Badges:

Are you able to get into the console?


It looks like a similiar issue.


What caps did you replace on the board?


Do you have pics of what they looked like before they were replaced?

Leo Laohoo Sat, 02/13/2010 - 14:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Try the command "sh post".  If  you get something like "loopback failure" then you'll need to get the appliance RMA-ed.

glen.grant Sat, 02/13/2010 - 15:12
User Badges:
  • Purple, 4500 points or more

Unfortunetly you can't RMA a 3524 that was long long ago

end of life .  If its dead time to buy a new switch...

Leo Laohoo Sat, 02/13/2010 - 15:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Back in 2008 I was able to RMA a Catalyst 1924-C.  It will depend entirely if you have a valid Service Contract.

pattya94191 Sat, 02/13/2010 - 17:10
User Badges:

True, but it could be a good way to spend a saturday, and a good way to save $60 odd bucks.....


If it was as simple as what i did anyway....


So can you get into the console of the switch?


And when you replaced the Caps, you didnt accidently put any in backwards, i did that the first time with my switch (whoops!!!!)


The other thing is, did you manage to replace em with the same voltage / farads? or did you have to use something else?

constantin.oprea Thu, 03/04/2010 - 10:29
User Badges:


I can't see any caracter on console.


I replaced all 1000uF caps and i'm sure i put them right.


The caps was the same, but higher voltage. The voltage don't count, only need to be the same or upper.


One of my friend told me that probably controllers had problems.

Leo Laohoo Thu, 03/04/2010 - 12:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

What is the result you get with the command "sh post"?

pattya94191 Thu, 03/04/2010 - 12:29
User Badges:

Damn.


If you cant get anything at the console, that could be a big issue. Its possible that its died because its been exposed to the wrong voltage for too long.



Regardless, If you can upload some good pics of what its doing (front panel LED's and the inside of the board) as well as some close ups of the caps, might still be worth a look.


Just to make sure, the console cable is definatly connected right? When mine did it, i just got garbage on the console (i was using PuTTY) but i was unable to run any commands.....


Also, i dont think he will be able to do a sh post if he cant get to the console!

Actions

This Discussion