Translate MGCP command to H323

Answered Question

Hi All,

I'm helping one of my clients get School Messenger working. I'm not 100% sure how it works, I'm coming in after the fact, but something with DTMF isn't being passed correctly. The way I understand it, School Messenger initiats a call to a Teacher of Principle at home and prompts them to hit a key to record a message. When they hit the key, School Messenger doesn't recognize it. However, this does work internally.

The School Messenger support gave me this following line to insert into my config:

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} mgcp dtmf-relay voip codec all mode nte-ca


They stated that this has resolved this issue for other schools in the past. My issues is that our Gateway is H323 and I don't want to migrate it to MGCP. Does anyone know if that command has a relative in the H323 world? I tried to following command, which didn't work:

voice service voip

dtmf-interworking rtp-nte

Thanks for any help!

I have this problem too.
0 votes
Correct Answer by Ovais Iqbal about 6 years 11 months ago

I would suggest the same MTP checkbox on your SIP trunk in CUCM and that is why I asked you to confirm if the app is integrated with CUCM via a SIP trunk, make sure that MTP resources is running and registered with CUCM, its device pool - region settings etc, you can simply use the software MTP on CUCM. Let me know if you need help in setting this up.

Thanks

Ovais.

Correct Answer by steigja about 6 years 11 months ago

I believe you issue may be with the DTMF protocol being used between the SIP application and the CUCM.  On your SIP trunk configuration in CUCM do you have media termination point required checked?  you may have to have that check, see below.

You can configure Cisco Unified Communications Manager SIP trunks to always use an MTP. Check this check box to provide media channel information in the outgoing INVITE request. When this check box is checked, all media channels must terminate and reoriginate on the MTP device. If you uncheck the check box, the Cisco Unified Communications Manager can decide whether calls are to go through the MTP device or be connected directly between the endpoints.

Note : If check box remains unchecked (default case), Cisco Unified Communications Manager will attempt to dynamically allocate an MTP if the DTMF methods for the call legs are not compatible.

For example, existing phones that run SCCP support only out-of-band DTMF, and existing phones that run SIP support RFC2833. Because the DTMF methods are not identical, the Cisco Unified Communications Manager dynamically allocates an MTP. If, however, a new phone that runs SCCP, which supports RFC2833 and out-of-band, calls an existing phone that runs SIP, Cisco Unified Communications Manager does not allocate an MTP because both phones support RFC2833. So, by having the same type of DTMF method supported on each phone, no need exists for MTP.

Also what do you have set for your DTMF signaling method in the trunk configuration?  I have OOB and RFC 2833 set and DTMF works fine in my voice setup, I'am using a SIP trunk for outside calls.  When it is OOB and RF 2833 it sends out both type of DTMF.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
steigja Tue, 01/26/2010 - 13:34

Do you have the DTMF-relay command on you H323 VOIP dialpeers pointing back to your call manager/s?

such as this

dial-peer voice 2000 voip
preference 1
destination-pattern [1-7]...
session target ipv4:192.168.100.1
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

Ovais Iqbal Tue, 01/26/2010 - 14:12

Hi,

If you share your H.323 router config then I can easily assist you in fixing this but I agree with the last reply that most probably you are sending in-band DTMF which is cuasing this.

Thanks

Ovais.

Here are my voip dial peers:

dial-peer voice 1000 voip
preference 1
destination-pattern 2485......
modem passthrough nse codec g711ulaw
voice-class codec 1
voice-class h323 1
session target ipv4:x.x.x.x
incoming called-number .
dtmf-relay h245-alphanumeric h245-signal cisco-rtp rtp-nte
fax-relay ecm disable
fax rate disable
no vad
dial-peer voice 1001 voip
preference 2
destination-pattern 2485......
modem passthrough nse codec g711ulaw
voice-class codec 1
voice-class h323 1
session target ipv4:x.x.x.x
incoming called-number .
dtmf-relay h245-alphanumeric h245-signal cisco-rtp rtp-nte
fax-relay ecm disable
fax rate disable
no vad

I had just dtmf-relay h245-alphanumeric, but I added the other commands and still no luck.

Thanks for the help!

Ovais Iqbal Wed, 01/27/2010 - 08:10

Ok, I just re-read your initial post again, this is actually an outbound call from the CUCM and gateway perspective, could you please try this call again and run this on your router "show voice call status" I wanted to know exactly which voip dial-peer the call is landing on the voice gateway, if it is not your dial-peers 1000 or 1001 then you may have missed that DTMF command under that dialp-peer.

By the way this school system uses SIP to integrate with CUCM?

Thanks

Ovais.

Correct Answer
steigja Wed, 01/27/2010 - 11:27

I believe you issue may be with the DTMF protocol being used between the SIP application and the CUCM.  On your SIP trunk configuration in CUCM do you have media termination point required checked?  you may have to have that check, see below.

You can configure Cisco Unified Communications Manager SIP trunks to always use an MTP. Check this check box to provide media channel information in the outgoing INVITE request. When this check box is checked, all media channels must terminate and reoriginate on the MTP device. If you uncheck the check box, the Cisco Unified Communications Manager can decide whether calls are to go through the MTP device or be connected directly between the endpoints.

Note : If check box remains unchecked (default case), Cisco Unified Communications Manager will attempt to dynamically allocate an MTP if the DTMF methods for the call legs are not compatible.

For example, existing phones that run SCCP support only out-of-band DTMF, and existing phones that run SIP support RFC2833. Because the DTMF methods are not identical, the Cisco Unified Communications Manager dynamically allocates an MTP. If, however, a new phone that runs SCCP, which supports RFC2833 and out-of-band, calls an existing phone that runs SIP, Cisco Unified Communications Manager does not allocate an MTP because both phones support RFC2833. So, by having the same type of DTMF method supported on each phone, no need exists for MTP.

Also what do you have set for your DTMF signaling method in the trunk configuration?  I have OOB and RFC 2833 set and DTMF works fine in my voice setup, I'am using a SIP trunk for outside calls.  When it is OOB and RF 2833 it sends out both type of DTMF.

Correct Answer
Ovais Iqbal Wed, 01/27/2010 - 11:42

I would suggest the same MTP checkbox on your SIP trunk in CUCM and that is why I asked you to confirm if the app is integrated with CUCM via a SIP trunk, make sure that MTP resources is running and registered with CUCM, its device pool - region settings etc, you can simply use the software MTP on CUCM. Let me know if you need help in setting this up.

Thanks

Ovais.

Actions

This Discussion