How to create a custom time zone or DST policy in CME?

Unanswered Question
Jan 20th, 2010

Hi, my strange country currently doesn't match any predefined time-zone in telephony-service. I'm in GMT -180. How is it solved?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dlob Wed, 01/20/2010 - 18:07

I´m in Argentina, it´s GMT -180 minutes (GMT -3 hours). No Daylight Saving Time, altough it´s actually summer.

dlob Fri, 01/22/2010 - 11:52

Nop. Zone 17 is GMT -2 hours right now.

No zone is GMT -3 at this date

dlob Fri, 01/22/2010 - 11:57

Stevie, Buenos Aires is the zone actually using, but it's currently GMT -2 because it's applying DST.

The problem is, this time we don't use DST in Argentina, so we keep using GMT -3. Is there anyway to force GMT -3 or disable DST?

dlob Fri, 01/22/2010 - 12:14

I've tried all of them!

Zone 18 is also GMT -2

dlob Fri, 01/22/2010 - 12:31

I have no clock summer-time in the configuration.

For your reference, a "show clock" command in the CLI shows me the correct local time (if configured clock timezone arg -3 in global config)

But I understand the time zone under telephony-service is independent for the time zone of the IOS.

Marcos Hernandez Fri, 01/22/2010 - 12:54

From our case database:

Workaround/Solution Cisco CallManager Express is an IOS based application. Thus, the Daylight Saving Time Configuration parameters for a system running IOS can be easily changed with a single configuration command. This command can be run at any time and on any device to alter the current default settings of the given device. clock summer-time zone recurring [week day month hh:mm week day month hh:mm [offset]] For example, to configure the new settings for DST in calendar year 2007, one can enter the following command: clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00 This will configure the IOS to adjust the time on the 2nd Sunday of March and then again on the 1st Sunday in November.  This will disable the time change at the normal time 3 weeks later. Please let me know if you have any questions.  Here is the link to the field-notice for CME gateways if you have any questions: http://cisco.com/en/US/products/sw/voicesw/ps4625/products_field_notice09186 a00807e9632.shtml


dlob Fri, 01/22/2010 - 12:59

Could you please send me that link again? It seems broken.

Thanks

dlob Fri, 01/22/2010 - 13:02

Anyway, which zone name should I configure using clock summer-time command?

For IOS global config you can name the zones in any way you want. For the zones of the CME they are predefined numbers.

Steven Smith Fri, 01/22/2010 - 11:52

In CCA...

Configure -> Device Properties -> System Time

Click modify on the time...

Timezone GMT -03:00 Buenos Aires

I believe that would work for you.

Actions

This Discussion