3560 QOS - no hits in classes when doing sh policy-map interface

Unanswered Question
Jan 20th, 2010

On my 3560 when I applied a inbound Marking policy-map on a port I do not see any hits in the classes.  What am I misssing?

interface GigabitEthernet0/3
description "NetApp -usplbx001-standby"
switchport access vlan 3
switchport mode access
no mdix auto
spanning-tree portfast
service-policy input MARKING

PLBCR-A-001#sh policy-map interface
GigabitEthernet0/3

  Service-policy input: MARKING

    Class-map: INTERACTIVE (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 110
        0 packets, 0 bytes
         rate 0 bps

    Class-map: LOW_PRIO (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 120
        0 packets, 0 bytes
         rate 0 bps

    Class-map: Standard (match-all)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: ip dscp default (0)

    Class-map: VOICE (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 150
        0 packets, 0 bytes
         rate 0 bps

    Class-map: class-default (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
         rate 0 bps

======================

mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos

class-map match-any LOW_PRIO
  match access-group 120
class-map match-all Standard
  match ip dscp default
class-map match-any INTERACTIVE
  match access-group 110
class-map match-any VOICE
  match access-group 150
!
!
policy-map MARKING
  class INTERACTIVE
   set dscp af21
  class LOW_PRIO
   set dscp cs1
  class Standard
   set dscp default
  class VOICE
   set dscp ef
!

access-list 110 remark ACL to identify Citrix traffic by server
access-list 110 permit ip any host 148.138.14.17
access-list 110 permit ip any host 148.138.14.138
access-list 110 permit ip any host 148.138.13.118
access-list 110 permit ip any host 148.138.13.211
access-list 110 permit ip any host 148.138.14.6
access-list 110 permit ip any host 148.138.14.7
access-list 110 permit ip any host 148.138.14.135
access-list 110 permit ip host 148.138.14.134 any
access-list 110 permit ip host 148.138.14.17 any
access-list 110 permit ip host 148.138.14.138 any
access-list 110 permit ip host 148.138.13.118 any
access-list 110 permit ip host 148.138.13.211 any
access-list 110 permit ip host 148.138.14.6 any
access-list 110 permit ip host 148.138.14.7 any
access-list 110 permit ip host 148.138.14.135 any
access-list 110 permit tcp any any eq 1494
access-list 110 permit tcp any eq 1494 any
access-list 110 permit tcp any any eq 2598
access-list 110 permit tcp any eq 2598 any
access-list 110 permit tcp any any eq telnet
access-list 110 permit tcp any eq telnet any
access-list 120 remark ACL to identify LOW_PRIO traffic by server
access-list 120 permit ip any host 157.171.68.41
access-list 120 permit ip any host 157.171.68.42
access-list 120 permit ip any host 157.171.53.95
access-list 120 permit ip any host 204.156.68.126
access-list 120 permit ip any host 157.171.85.11
access-list 120 permit ip any host 204.156.68.34
access-list 120 permit ip any host 170.102.26.170
access-list 120 permit ip any host 170.102.247.33
access-list 120 permit ip any host 157.171.43.137
access-list 120 permit tcp any any eq 8888
access-list 150 permit udp any any range 16384 32767
access-list 150 permit tcp any any eq 2000

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Wed, 01/20/2010 - 12:59

Your'e not missing anything, it is a well known limitation with the 3560 and 3750 switches. Because the packets are switched in hardware the 3560 switch does not keep acl or QOS policy map counters.

The best you can do on these switches is "sh mls qos interface statistics" which gives some general info on what is happening with QOS on the switch.

Jon

Actions

This Discussion