Stable Code for LLDP Support with Avaya 4610 IPT

Unanswered Question
Jan 20th, 2010
User Badges:

Have a c3750 running c3750-ipservicesk9-mz.122-52.SE.bin.  Is this the best version of code to support lldp-med message exchanges between switch and 4610 ipt?  Trying to get the ipt to learn voice vlan using lldp.  I have followed the config doc for the code that I am running in the switch for lldp config and created a network policy and have applied to int that phone is connected on. IPT seems to work and get on the correct voice vlan but when I reset or clear the ipt using the ipt keypad and enter 'clear' or 'reset' the ipt does not come up on the voice vlan but instead on the data vlan subnet that a pc behind the ipt is connected on. The only way to get the ipt back on the voice vlan is to remove the network policy on the ipt switch port int a few times and it works....but that does not sound correct.  Has anyone seen the same issue?  Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Wed, 01/20/2010 - 17:52
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi John,


I checked with feature navigator and your image does support LLDP.  The latest version on CCO is 12.2(53), so your image is not very old at all.

Can you provide the exact switch model?


Also, I found below bug on 12.2(52), but not sure this is your issue.

BTW, It does mention 3560 but who knows




CSCtc67421 Bug Details Bug #1 of 6 | < Previous | CSCtb45900&from=summary" rel="nofollow">Next >
LLDP TLV power assignment doesn't work when 24 IP Phones are booted
Symptoms
On a Cisco 3560 running IOS version 12.2(52)SE, using LLDP for power negotiation
fails.

Conditions
This is seen when 24 phones are booted at the same time.

Workaround
Boot up the phones separately. However, this won't be always possible, for
example, after a power outage.


HTH

Reza

emartens Thu, 08/05/2010 - 08:14
User Badges:

Hello John,


I have the same issue on both 3560 and 3750 series.

We down-graded to 12.2.44 and all is working fine.

12.2.46 also works but has a ssh client problem.


The 9600 does work correctly with the latest IOS, tested with 12.2.53SE2.


Hope this helps a little...


Regards,


Ed

akomyakov Wed, 09/15/2010 - 08:14
User Badges:

Just checked with 4610SW and WS-C3750-48PS running 12.2(44) and it works as expected.
Tested with version 52, 53 and 55 of IOS and it does not work.

I have a ticket open with cisco regarding this one.


Also just tested out 12.2(44) with 4602SW running 2.3 software and LLDP did not work.

JOHN APONTE Wed, 09/15/2010 - 15:31
User Badges:

Thanks for the info. Never got LLDP   to work right so went with DHCP opt 176 settings.

emartens Thu, 09/16/2010 - 00:58
User Badges:

Hi All,


I have the 46xx and 96xx working on a 3750 with all type of IOS versions. Even with the 12.2(52)


There is a patch for the 46xx phones, it is a patch for the 2.9.1 software version named: IPT46_R9.033b.zip

LLDP works only with 2.6 and above for sure till IOS 12.2(44). With the patch also above 12.2.(44).


The 96xx version works best with software 3.11 icw all versions of IOS.

To receive the patch you have to contact Avaya and explain your LLDP problem and mention the patch filename.


Hopes it helps you


Regards,


Ed Martens

akomyakov Thu, 09/16/2010 - 05:40
User Badges:

So 4602SW phones are out of luck than? The latest software for those is 2.3 (comes in the same batch with 2.9 for 4610SW and above)

Unfortunately, DHCP option is not good enough for me. I need to have different voice vlans, but retain same access vlan.

emartens Thu, 09/16/2010 - 07:43
User Badges:

DHCP is always an option..


in your access vlan:

option 176:L2Q=1,L2QVLAN=10  (where VLAN 10 is your voice vlan)


in your voice vlan f.e.:

option 176:MCIPADD=10.1.1.1,MCPORT=1719,TFTPSRVR=10.1.1.2


Good luck

akomyakov Thu, 09/16/2010 - 07:51
User Badges:

Yup, I know about that one. My problems is that I need 100 phones to boot into an access vlan 25, but only 50 of them go into voice vlan 100 and the other 50 go into voice vlan 200. So they have to share an access vlan, but not voice vlan. This puts using DHCP out of the question.


Again, thanks much for your help.


PS: I can't find the above mentioned patch, and I don't have service agreement with avaya, so I can't call them.

emartens Fri, 09/17/2010 - 00:36
User Badges:

HI Andrey,


Strange to have your voice in two seperate VLAN's while data is in one vlan, but you probably will have your reason for it..


I've attached the file, so goodluck with it.


Regards,


Ed

akomyakov Mon, 09/20/2010 - 06:59
User Badges:

I tried your firmware and it worked on 12.2(50), so I deployed it in one of my small buildings (about

50 phones). I'll see if I discover any issues with it. I've heard that 2.9 has broken speaker phone, but I was not able to replicated it on 2.9.1 and did not have a change to test it on this one either. We'll see.


Thank you, very much for your help on this, you saved the day (or the week for that matter).


PS. The PBX, though does not recognized the software. It displays it as 0.   0. Strange. Other than that, everything seems to be working.

Actions

This Discussion