LWAPP Upgrade to v6 issue

Unanswered Question
Jan 21st, 2010

Hello,

I recently upgrade one of our WLC's from V4.2.207 to V6.0.188 which seemed to have gone well without problems, however, when my test AP connects to that wlc, it receives the new image fine from the controller, but when it reboots, it connects to another controller which has v4.2.207 and downgrades it's image. Once it reboots again, it connects to the test controller and the cycle continues. It has a SSC which I have allowed and there does not seem to be any clear reason why this is happening!! 

I have forced the primary controller on the AP to the test controller management address but the AP still manages to try connect to a different controller.

Any ideas on why this is happening??

In the log, I am getting quite a few "Received LWAPP packet with invalid sequence number", and the following messages:-

*Jan 21 18:47:41.037: %RRM-3-RRM_LOGMSG: rrmChanUtils.c:292 RRM LOG: Airewave Director: Could not find valid channel lists for 802.11bg

*Jan 21 18:47:40.864: %LWAPP-3-PAYLOAD_MISSING: spam_lrad.c:5754  Join request does not contain BOARD_DATA payload

I also noticed that when I uploaded the emergency boot image, v5.2.157, it uploads fine but  does not appear in the 'show sysinfo' but instead 'N/A'
Cheers,
- Trevor
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
George Stefanick Fri, 01/22/2010 - 23:25

funny im having the same issue in my lab ... i will try and work on it this weekend and share what i find ... Im on the same code revs as you in the lab as well ..

Leo Laohoo Sat, 01/23/2010 - 03:59

What is the MAC address of the AP involved?  Does it start with "00" or not?

Leo Laohoo Sun, 01/24/2010 - 21:27

There's a bug in the 6.0.188.0 LAPs with MAC address that DO NOT start with "00".  These LAPs refuse to join the WLC/WiSM.  

tajennings Mon, 01/25/2010 - 06:13

I have tried 2 AP's and they both have the same problem!  They also start with "00" for the MAC address. I tried downgrading to V6.0.182 but same problem!!  Cisco support seem to be stumped on this issue too.

tajennings Mon, 01/25/2010 - 13:53

Solved!!!!!!!   Turns out that I never added the CAPWAP UDP ports (5246,5247) in the access rules which prevented the test AP to join the upgraded controller.

Lesson learned, always read the documentation about new features

- Trevor

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode