MWI not working

Unanswered Question
Jan 21st, 2010
User Badges:

Hello-


I have searched this site and tried/checked multiple suggested solutions that I found but I can not get our MWI light to show on any of our phones.


I have checked for the three dots behind the MWI extensions (we have 3 digit extensions).

I have checked the gateway on the service module and changed it from 10.1.10.2 to 10.1.1.1 but no change

Refreshed MWI a lot

Changed ON to OFF on MWI extension properties and then back again, refreshing each time but no change


Any other suggestions?


Thanks,


Derek

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Trad Thu, 01/21/2010 - 21:36
User Badges:
  • Gold, 750 points or more
  • Cisco Designated VIP,

    2013 Small Business

Hi Derek,


These might be stupid questions but I have to ask them.


1. Are these extension registered for Voice Mail? You can deposit voice mail to an extension but if it is not registered the red light wont come up on the handset until the phone is a registered VM user.


2. Do you have the appropriate DN's registered on the system? Your config should have something simular to this:


ephone-dn  87
number A801... no-reg primary
mwi off
!
!
ephone-dn  88
number A800... no-reg primary
mwi on


Log into your Web GUI and see it from there, it should also be there.


3. Does your CUE have the MWI configuration? It should look something like this:


ccn application ciscomwiapplication aa
description "ciscomwiapplication"
enabled
maxsessions 6
script "setmwi.aef"
parameter "CallControlGroupID" "0"
parameter "strMWI_OFF_DN" "A801"
parameter "strMWI_ON_DN" "A800"
end application



ccn trigger http urlname mwiapp
application "ciscomwiapplication"
enabled
maxsessions 1
end trigger


The best way to find out if you have a sound configuration is to use a program like Putty, copy the config over to a TXT file and go over it bit by bit, if you have another working config to compare too, then compare it, this is how i do basic troubleshooting, doesn't allways work, but hey it can help.


Let us know how you go with it, please update us.





Cheers,



David.

Marcos Hernandez Fri, 01/22/2010 - 08:25
User Badges:
  • Blue, 1500 points or more

Add this and let us know:



!

dial-peer voice 9999 voip

incoming called-number A80[0,1]...

codec g711ulaw

no vad

!




Derek Thom Fri, 01/22/2010 - 08:54
User Badges:

Marcos-


Input what gave me and it didn't seem to have an effect. I did a refresh again of the MWi indicators but still no dice. Is there something else I should be looking for?


Thanks,


Derek

Marcos Hernandez Fri, 01/22/2010 - 09:30
User Badges:
  • Blue, 1500 points or more

Please provide a "debug ccsip message" for when a message is left. Also post your configuration, removing password and any sensitive information.


Thanks,


Marcos

Marcos Hernandez Fri, 01/22/2010 - 13:05
User Badges:
  • Blue, 1500 points or more

Config looks fine, but I do not see the outcall from CUE. Can you change the sip gateway in CUE to 10.1.10.2 and try? ACL 104 is probably blocking traffic.


Marcos

Derek Thom Fri, 01/22/2010 - 13:25
User Badges:

I changed the gateway in Call Manager Express from 10.1.1.1 to 10.1.10.2 before running the debug, and it is still set that way.


From the CUE CLI:


ccn subsystem sip
gateway address "10.1.10.2"
mwi envelope-info
dtmf-relay sip-notify
mwi sip outcall sub-notify
end subsystem

Marcos Hernandez Tue, 01/26/2010 - 08:50
User Badges:
  • Blue, 1500 points or more

Please do not use "sub-notify". This is how I have it working:


Screen shot 2010-01-26 at 10.31.53 AM.png



Derek Thom Mon, 02/01/2010 - 08:47
User Badges:

Sorry for the delayed response, I have been out of town for a week.


Made that change and refreshed the MWI and reset the phone, but still no change.

Derek Thom Fri, 01/22/2010 - 08:53
User Badges:

Thanks for the response!


1. I am pretty sure they are registered, but how would I verify that?


2. The DN's are registered just like you have them.


ephone-dn  55
number A801... no-reg primary
mwi off
!
!
ephone-dn  56
number A800... no-reg primary
mwi on


3. The CUE also has the correct configuration as you show.



ccn application ciscomwiapplication aa
description "ciscomwiapplication"
enabled
maxsessions 6
script "setmwi.aef"
parameter "CallControlGroupID" "0"
parameter "strMWI_OFF_DN" "A801"
parameter "strMWI_ON_DN" "A800"
end application


ccn trigger http urlname msgnotifytrg
application "msgnotification"
enabled
maxsessions 2
end trigger

ccn trigger http urlname mwiapp
application "ciscomwiapplication"
enabled
maxsessions 1
end trigger


Thanks for the help so far!


Derek

Derek Thom Thu, 02/11/2010 - 10:38
User Badges:

Still having issues with this. Does anyone have any other suggestions?


Thanks,


Derek

Derek Thom Wed, 03/03/2010 - 15:43
User Badges:

I thought I would update this. One of the fixes must have worked, but did not take effect until I rebooted. After going through the fixes mentioned above and rebooting, it all works. Thanks to all contributors!

Marcos Hernandez Sun, 03/07/2010 - 07:42
User Badges:
  • Blue, 1500 points or more

Hmmm. Maybe a MWI refresh would have done the trick too. In any case, I am happy this has been resolved.


Marcos

Actions

This Discussion