WakeOnLan (WOL ) through Cisco 870 not working

Unanswered Question
Jan 21st, 2010
User Badges:

Hi,


I need to allow WOL packets through a Cisco 870W router to powerup pcs at a remote location. The device is running IOS version 12.4(9)T


The WOL magic packet will be coming from VLAN1 (192.168.2.0/24)  and going to FastEthernet4 (192.168.6.0/24).


The WOL application sends UDP packets on port 9


Here are the relevant running-config sections


interface Vlan1

ip address 192.168.2.30 255.255.255.0
no ip redirects
no ip unreachables
ip directed-broadcast
no ip proxy-arp
ip route-cache flow
ip tcp adjust-mss 1452


interface FastEthernet4

ip address 192.168.6.1 255.255.255.0
** ip helper-address 192.168.2.1
** ip helper-address 192.168.2.10
no ip redirects
no ip unreachables
ip directed-broadcast
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
no cdp enable



** the iphelper addresses are the domain dhcp servers.



I've also found documents recommending I add


ip forward-protocol udp 9


which I've added and still nothing. Can anyone tell me why this is not working?


Thank you.


Vic.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Fri, 01/22/2010 - 20:40
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try setting a static ARP entry for the PC, on the router

vic.orgos Sun, 01/24/2010 - 15:49
User Badges:

It is not just one PC. I need to be able to wake up any workstation in the subnet on the other side of this router. Adding static arp entries is unmanageable.

Jon Marshall Sun, 01/24/2010 - 16:56
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

vic.orgos wrote:


Hi,


I need to allow WOL packets through a Cisco 870W router to powerup pcs at a remote location. The device is running IOS version 12.4(9)T


The WOL magic packet will be coming from VLAN1 (192.168.2.0/24)  and going to FastEthernet4 (192.168.6.0/24).


The WOL application sends UDP packets on port 9


Here are the relevant running-config sections


interface Vlan1

ip address 192.168.2.30 255.255.255.0
no ip redirects
no ip unreachables
ip directed-broadcast
no ip proxy-arp
ip route-cache flow
ip tcp adjust-mss 1452


interface FastEthernet4

ip address 192.168.6.1 255.255.255.0
** ip helper-address 192.168.2.1
** ip helper-address 192.168.2.10
no ip redirects
no ip unreachables
ip directed-broadcast
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
no cdp enable



** the iphelper addresses are the domain dhcp servers.



I've also found documents recommending I add


ip forward-protocol udp 9


which I've added and still nothing. Can anyone tell me why this is not working?


Thank you.


Vic.


Vic


Add this to your config under the vlan 1 interface -


interface vlan 1

ip helper-address 192.168.6.255


Jon

vic.orgos Wed, 01/27/2010 - 15:36
User Badges:

Solved it myself. I found that the PC that sends the magic packet,  which in our case is running RHEL (linux), needs a static route to the network in question. I then added


ip directed-broadcast


under FastEthernet 4, which is the interface for the network where the pcs are in.


Once I got that working, I locked it down a bit by creating an ACL


access-list 101 permit udp host 192.168.2.70 192.168.6.0 0.0.0.255 eq discard


and changed the first command to use the ACL like this


ip directed-broadcast 101


That is it. Thanks to all took the time to reply.


Regards,

Vic.

Actions

This Discussion