Need help to Vlan configuration between cisco 1841, catalyst 2960g and linksys swithces

Unanswered Question
Jan 21st, 2010

Hello,

I would like you to please help me undestand what am I doing wrong with the following scenario.

I created a 3 VLAN network with a Cisco Router 1841, a Catalyst 2960G with PoE and linksys 48 port PoE switches, because the data traffic was dropping connection from the voice IP phones to the IP PBX.

Vlan 1 as native data network with 192.168.123.0 /24

Vlan 2 for notebooks, wireless AP, mobiles and desktop computers with no restrinction Internet access, 192.168.124.0 /24

Vlan 5 for IP phones only and the IP PBX giving and handling DHCP IP addresses to the phones, 192.168.127.0 /24.

The router has all three subinterfaces created, DHCP server for the Vlan 2 and access to Internet with a ADSL Pots WIC card for Vlan 2 users. The Catalyst is the Core Switch and it has trunk ports for connecting the Linksys switches and a Catalyst 2950. The linksys switches are connected to the SFP ports and their SFP ports has trunk configuration.

Now, every computer, wireless or mobile has an static IP from the Vlan 1 network and they access to internet not yet through the ADLS WIC or the FA 0/1 port, they ADLS routers are connected to Vlan 1 with static IP and they are the outbound gateways for internet. This is what I need to change right away.

Everything works fine at Vlan 1 and Vlan5, no problems there, at the cisco or linksys switches, but when I try to start using the Vlan2 at any linksys switch port, I can't access to it, I tried all port configurations available, accesss, general or trunk, and neither gives me access to Vlan2 network and without this, I can't enable the internet access through the ADLS WIC.

At the catalyst, if I configure the switchport as access vlan2, It sends me right away to the Vlan2, but if I configure it as a trunk port, I need to change my NIC configuration to vlan2, in order to be able to connect, and of course I can't do that, because not all the computers has the option to move their NICs to a certain Vlan.

Attached you'll find my router and catalyst configuration.

Please help me to undestand what's wrong so I can serve right my customer.

Thanks,

Guillermo Manzo

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion