Cisco 837 & BT 21 century upgrades

Unanswered Question
Jan 22nd, 2010

I have been advised by our ISP that problems with loss of CD are the result of BT having upgraded their exchange to the 21st Century IP network. We recognise that the 837 does not support ADSL2/2+. However does the fact that the router does not support ADSL2+ mean that it will not be compatible with the basic ADSL level services with the new exchanges? If so is there a fix to this? I have seen that there are firmware upgrades to other integrated services routers such as the 836 and 877, is there one we can obtain for the 837?

Many thanks any pointers on this.

Regards,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sat, 01/23/2010 - 13:10

Hello Alan,

per standards ADSL2+ is backward compatible with ADSL1, ADSL2 is not.

So ask them if their line is ADSL2+ or ADSL2.

UK scenario looks like different there have been several threads about problems also with ADSL2+ implementations (different flavours)  on the router side with exchange of informations about DSL firmware to use.

for example

https://supportforums.cisco.com/message/833420#833420

Hope to help

Giuseppe

Actions

This Discussion