Router fe Interface vs Switch fe Inteface status ??

Unanswered Question


I am a bit of a newby to this and I have just ran into a somewhat of a curious question and a bit odd.  I do apologize if this is  very simple question and I am just not as sharp as I should be.

So on a switch, on a enabled fast Ethernet interface if I do a status, sh interface command, if the cable is unplugged, it shows down/down, as expected. plug it back in and I have up/up.

On the router, same thing fast ethernet interface, enabled, cabled plugged in shows up/up, cable unplugged it shows up/down, not down/down as I expected to see.

To throw the monkey wrench in the picture, I do the same thing on the serial port on the router, if I unplug the cable it goes down/down, up/down or up/up when plugged in.

Is this the right behavior or no?  Am I missing something?  Why different statuses on the same situation plugged/unplugged between it being a router vs a switch?

I get the same behavior on a 3700 and a 2600 router, switches are a 2950, I believe the IOSs are 12.3



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Fri, 01/22/2010 - 14:32

Hello Haris,

what you see is normal.

There has been a recent thread about keepalive frames where the different behaviour of routers and switches on LAN interfaces when unplugged has been examined.

in old times in a router to fool it was enough to do the following:

int fas0/0

ip address

no shut

no keepalive

and even if unplugged it is possible to ping !!!

on a LAN switch this trick doesn't work.

I used this trick many years ago to perform some connectivity tests before realizing I could configure multiple logical loopback interfaces

Hope to help


Thanks Giuseppe.  Glad I wasn't loosing my mind on the two differences.  After trying this on few more routers I get the same result, and that's ok with me now, not a suprise any more, I now just know that is the state they end up after a cable is unplugged.

Can anybody give me a technical explanation why the difference between the two devices and their behavior when the cable is removed?  Can the router port be forced to go to a down/down state using any type of configuration commands once the cable is removed?  What is keeping the port in the up state for the first part of the status, up/down state?




This Discussion