Nexus 5010 - not allowing more than 1 fex interface into a port-channel

Unanswered Question
Jan 23rd, 2010

Hi - I am trying to create a port-channel that contains 2 fex interfaces to provide SLB to a UNiX server, each time I try to add more that 1 interface into the Channel-group I get the following message:-"port channel cannot have more than 1 members".  I have configured the fex interfaces up as trunk interfaces and have set the lacp to active mode.

interface port-channel62
  switchport mode trunk

interface Ethernet107/1/37
  description NAS DATAMOVER L cge2
  switchport mode trunk
  channel-group 62 mode active

NEXUS-2-5010-B(config-if)# int e107/1/38
NEXUS-2-5010-B(config-if)# channel-group 62 mode act
port channel cannot have more than 1 members

Please note that I am trying to configure multiple interfaces on the FEX not on the 5010...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.2 (9 ratings)
dave.chadwick Sun, 01/24/2010 - 01:49

I'm not concerned about the vPC connections, I already have my vPC's configured from the 2148T FEX to the 5010's..  I'm talking about setting up an etherchannel connection to a server, which when configuring up the GEC the Nexus says "no more that 1 connection within the port-channel" .

slandeira Wed, 12/22/2010 - 08:14

I have the same problem. Finally, how you solved it?


steve_mils Thu, 01/28/2010 - 03:00

Hi David,

I see exactly the same problem - did you manage to find an answer?

Thanks, Steve

rawlinsm Mon, 02/01/2010 - 11:21

Same problem here.

I have 4 ports on a server divided evenly between 2 2048's

I would like all 4 ports to be seen to the server as an aggregated 4Gig  connection that will use LACP.

If I run 1 connection from each 2048 and put them in the same VPC, No  Problem.

When I try to add the second port on a 2048 to the same port-channel I get  the same error.

Something more like this:

andy.steere Mon, 02/01/2010 - 12:36

What happens when you create a new port-channel (different channel#) and add it to the same vPC?   Like this:

N5k-1(config-if)# int ethernet 100/1/1

N5k-1(config-if)# channel-group 10

N5k-1(config-if)# int po10

N5k-1(config-if)# vpc 10

N5k-1(config-if)# int ethernet 100/1/2

N5k-1(config-if)# channel-group 11

N5k-1(config-if)# int po11

N5k-1(config-if)# vpc 10

rawlinsm Mon, 02/01/2010 - 13:33

So, , , How do you bind multiple ports together to a server in the nexus environment?

Peter Koltl Wed, 07/30/2014 - 11:39

This topology requires Enhanced vPC.


"Cisco NX-OS supports Enhanced vPC on the Cisco Nexus 5548P, Cisco Nexus 5548UP, and
Cisco Nexus 5596UP devices. The Cisco Nexus 5010 and Cisco Nexus 5020 devices cannot support
Enhanced vPC. Enhanced vPC is implemented on the Cisco Nexus 5500 Series device and has no
specific requirements from a FEX. As a result, different types of FEXs can be deployed in an Enhanced
vPC topology."

rawlinsm Mon, 02/01/2010 - 13:11

a VPC can only belong to a single Port-Channel

You get an error:

LVC-5020-1(config)# int po 50
LVC-5020-1(config-if)# vpc 50
LVC-5020-1(config-if)# int po 51
LVC-5020-1(config-if)# vpc 50
ERROR: Operation failed: [vPC already exists]

alytle111 Mon, 02/01/2010 - 13:58

Reported problem to TAC.  They stated the current Nexus-OS does not support more than one interface per port-channel attached to a single 2k...if you want more than 2 ports per port-channel then use 5k ports.

Lucien Avramov Wed, 02/03/2010 - 22:25

TAC should have also tell you that the product N2248T is the one that will support this feature.

I guess this post can be marked as resolved

DAVIDE RENDINIELLO Tue, 02/22/2011 - 02:20

Where I can find cisco's official documentation on this problem?

Is possible that NX-OS 5 has fixed it?



tiwang Tue, 02/22/2011 - 02:34

I had the same problem - the only fix is to buy 2248 instead of 2148 - is some broken design in the asic's as far as I know

best regards /ti

vdsudame Tue, 02/22/2011 - 08:10

There is nothing broken or any kind of design flaw here. This is a hardware limitation with the Nexus 2148 platform. This was our first FEX and at the time there was no support in n2k hardware to support more than one link in a portchannel from the fex to the host. Since this is a hardware limitation there wont be any software fix for it.

The current documentation is here:

Table 9 - Layer 2 Features

PortChannel on server ports on Cisco Nexus 2200  platforms

Note: The platform says Nexus 2200. It does not account Nexus 2148.

Manas Dutta Thu, 03/14/2013 - 10:01

Hello Lucein,

I am facing the same issue but while trying to connect my 2248 ports to NetApp FAS3200 Dual Controller.

The 10Gig connection works fine with vpc 13 and vpc 14 as follows (member ports are 5548 ports):

interface port-channel13

  description 10G connection to NetApp_Controller1

  switchport mode trunk

  switchport trunk allowed vlan 161

  spanning-tree port type edge trunk

  speed 10000

  duplex full

  vpc 13

interface port-channel14

  description 10G connection to NetApp_Controller2

  switchport mode trunk

  switchport trunk allowed vlan 161

  spanning-tree port type edge trunk

  speed 10000

  vpc 14

But when I use for 2248 ports which are connected a dual-homed (EvPC) to both 5Ks, I get the error '

operation failed vpc already exists' when I try to use vpc 17 for e102/1/17 & e103/1/17 and vpc 18 for e102/1/18 & e103/1/18.


Group Port-       Type     Protocol  Member Ports



17    Po17(SU)    Eth      LACP      Eth102/1/17(P)  Eth103/1/17(P)

18    Po18(SU)    Eth      LACP      Eth102/1/18(P)  Eth103/1/18(P)

However, they are up in PO right now but I can't add them to vpc. No matter what vpc number I use. It gives the same error.

Please help.

Andrew Sparkes Mon, 06/30/2014 - 04:47


I had the same problem, but with slightly different models.

My setup used a Nexus 5548 and 2248 FEX.

The fix to the problem, shut down the uplink ports on the 5548 and disassociate the physical ports with the port channel and delete the port channel.

Next, reassign the two uplink ports to the FEX and recreate the port channel. This allowed me to apply the necessary configuration without error messages. I have provided an example below of the steps carried out.


show FEX - confirmation FEX is online and ports associated.

FEX: 104 Description: FEX104-Po104   state: Online
  FEX version: 7.0(2)N1(1) [Switch version: 7.0(2)N1(1)]
  FEX Interim version: 7.0(2)N1(1)
  Switch Interim version: 7.0(2)N1(1)
  Fabric interface state:
    Po104 - Interface Up. State: Active
    Eth1/18 - Interface Up. State: Active
    Eth1/26 - Interface Up. State: Active
  Fex Port        State  Fabric Port


show port-channel - confirmation port-channel has been built, but only one port assigned

104   Po104(SD)   Eth      NONE      Eth1/18(D)  


initial configuration applied and error message when trying to add second port to PO.

interface Ethernet1/18
  description fex 104 port 1
  switchport mode fex-fabric
  fex associate 104
  channel-group 104


interface Ethernet1/26
  description fex 104 port 2
  switchport mode fex-fabric
  fex associate 104

conf t

int e1/26

channel-group 104

command failed: port not compatible [port dynamic logical-interface scale disable]

interface port-channel104
  description fex 104
  switchport mode fex-fabric
  fex associate 104

The above shows the configuration applied and the error message recieved when trying to add second port to PO.


The next set of commands resolved the issue.

conf t

int e1/18
switchport mode access
int e1/26
switchport mode access

no int po 104

Reapply configuration, but using port range command.


int e1/18 , e1/26
switchport mode fex-fabric
fex associate 104
channel-group 104


show commands confirm FEX returned to service and both ports in PO

sh fex

104   FEX104-Po104                Online   N2K-C2248TP-E-1GE   FOX1744G5TC

show port-channel summary
104   Po104(SU)   Eth      NONE      Eth1/18(P)   Eth1/26(P)


Hopefully the above will assist and is easy to follow.








This Discussion

Related Content