Failing RV016 or ISP?

Unanswered Question
Jan 23rd, 2010

I have a rv016 that's been in 24x7 operation since I bought it a few years back.  It is out of warranty.  It is connected to three cable modems on WANs 1-3.  Behind it are a bunch of PCs getting IPs via DHCP.  There is a gateway to gateway vpn tunnel setup on wan3 to a rv082 at another site.  There is a forwarding entry for http to an internal http server.  Everything else is pretty much default.

The router is primarily used to aggregate bandwidth for uploading large numbers of photos.  The systems behind the router initiate the uploads and the router automatically load balances the outgoing bandwidth.

This was all working fine until just recently.  The ISP is Knology who is upgrading each of the 8m/768k cable modems to 25m/5m.  They are also moving from DOCSIS 1 to DOCSIS 3.  They are currently in the middle of this upgrade and have upgraded the modems to DOCSIS 3 as well as the speeds to 12m/2m.  The problem is that the rv016 Network Service Detection, which is set to "Default Gateway" indicates that the modems fail randomly.  Usually only one will be failed, but up to two will fail the Network Service Detection simultaneously.

Knology insists that there is nothing wrong with their modems.  I have removed a modem from the rv016 when Network Service Detection indicates it is in a failed state and connected it directly to a computer.  It will work, but it has a different IP address and default gateway.  As soon as I connect it back to the rv016, it works there too, but on the original IP address and gateway.  I've only tried this test this twice so far, so it is a bit inconclusive.

Speed tests behind the rv016 are the same as directly connected to one of the cable modems.  The router works normally as it has for years.  Nothing else is acting funny.

So my question is, is the rv016 failing or is the ISP having problems?  What other tests can be done to help isolate what is truly going on?  Any assistance appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jasbryan Sun, 01/24/2010 - 04:48

I would make sure that the firmware is up to date from the start, so you can rule out that. Since the only thing that's changing is that the cable company is upgrading there system, there modem could be going down a certain times without them knowing about it. I would make sure that you do have the latest firmware for the RV018, remember after firmware upgrade it's best practice to factory default the router and rebuild your config. You need a way to test the modem individually, You could plug a pc directly into the modem and run a multiple pings(continuous), to see though out the day if you get gateway not responding. This would tie up one modem though out the day for this test! You also could set up SNMP on the RV016, this is a network managment protocol, set up snmp software on a local pc, to capture the traps. This would just give you more information, it wouldnt tell you why it's going down.

Jason

Samir Darji Sun, 01/24/2010 - 08:56

Thank you for the reply.  I'm a little wary of a firmware update.  I don't want to end up making things worse, which firmware updates can do.  And to be frank, with all the firmware bugs I've discovered while setting up my VPN, I really don't have much faith in the firmware.

I've thought about connecting a PC and doing the exact same ping test you've mentioned.  But I don't think it would prove anything because I believe that this may be a routing issue on the ISP's side, and an individual PC gets a completely different IP and subnet.  There's a chance that it would work fine and then when reconnected to the router, the same issues would emerge.

What additional information would SNMP reveal?  Also, is there a open source/free snmp client?  I've never played with SNMP, but have always wanted to.

Any other suggestions to just test the base operation of the router without firmware updates?  I've thought about bringing my rv082 to this location and testing the modems that way, but I'd run into the same problem of different IP address/subnet.

jasbryan Sun, 01/24/2010 - 11:23

If you look under the system management, and click the more tab, and you will see that there is a active running firmware and a backup firmware. So if you update your firmware and it makes it worse you can just role to the backup firmware. Now it depends on the snmp software that you have, it will give you ports speeds, mac address, few other things. You just need to look into a certain software and see what it may give you to benefit you. You also could run the rv082 and that would give you a good result , weather it your isp or router.

Jason

Samir Darji Sun, 01/24/2010 - 16:21

Thank you again for the reply.  I didn't realize there was a backup firmware capability.  The current version I have is 2.0.6.  What's the curent version?  Are there release notes with the new firmware?  Will I be able to use the import/export settings feature?  And if not, what is the format of the stored settings file?  Is it text that can be read to figure out what the settings were or is it something cryptic?

I don't have any SNMP management software.  Where can I get a package?

One thing I forgot is that the cable modems have a built-in status screen at 192.168.100.1.  I'll need to check this the next time I connect a failed modem to a computer to see if there's something else I can find.

If my diagnosis points to the rv016, what are my repair options?

Samir Darji Wed, 01/27/2010 - 23:06

Today, the rv016 has had serious problems.  So serious that I've actually had to connect one of the modems directly to a system on the network in order to have Internet access.

Really late at night two days ago, Knology had a nationwide outage where they must have upgraded a bunch of internal infrastructure .  The rv016 hasn't been the same since this upgrade.  But it is important to note that today is first time I've been at this location and been able to run tests.  The VPN still works perfectly to the rv082, and some testing reveals that routing works fine, just not DNS.

Rebooting the rv016 results in sporadic acquiring of an IP address from the cable modem, even if it had the address prior to reboot.  Also, DNS lookups only work for a very short time period before they stop working completely.  This is even with a ping from the diagnostic page in the setup.

Once I manually and electronically back up all my settings, I'll be attempting a firmware update.  If the firmware update doesn't resolve the problem, what are my repair options?

William Childs Thu, 01/28/2010 - 03:53

Samir,

The repair options you have are limited to purchasing a new router. Your router is out of the 1 year phone/hardware support that came with the device. It looks like you may need a new router.

Bill

Samir Darji Thu, 01/28/2010 - 09:24

So there is no repair option?  Isn't the rv016 a current product?  Would it be of any use to attempt the firmware update as recommended above?

I've been able to restore full functionality by manually assigning DNS entries to the systems on the LAN, but this doesn't seem like a permanent fix.

jasbryan Thu, 01/28/2010 - 12:48

There is no repair option for the routers, but if you haven't done a firmware upgrade i would recommend upgrading.

Samir Darji Fri, 02/05/2010 - 10:46

This update introduced a problem where the router would randomly reboot when multiple WAN connections were being utilized simultaneously.

Seems like this router works fine when it only has to route a single WAN connection.  I think it will be retired to that capacity.

Samir Darji Fri, 02/12/2010 - 15:55

Looks like I had some luck on my side after all.  I was able to acquire a rv016 brand new, still in the original packaging, and still shrinkwrapped from someone that bought it for a network project that never went through.  It was sitting in a closet from the time it was purchased and was never even opened.  This was approximately 6 months.

So my question is, what do I need to do to properly register this for warranty since I don't have a sales receipt?

Samir Darji Sat, 02/13/2010 - 05:57

And how is the date determined in the system?  I'll attempt to get a copy of the original sales receipt.

William Childs Thu, 02/18/2010 - 01:12

Samir,

The answer to this question is simple and quite static (process cannot be changed). It goes something like this:

The customer will provide the serial number of the unit/product to be repaired at the opening of the Service Request. An engineer may NOT work on a customer's device without creating a case, therefore a serial number is mandatory. The engineer will check the provided serial number in the serial number lookup tool to prove entitlement to support prior to opening the case.

If the serial number database shows that the device is no longer under it's specific warranty, the engineer has two avenues he/she can take. The preferred avenue is to have the customer fax a copy of the sales receipt to the attention of the engineer at the number provided by the engineer. If the receipt shows that the product has been purchased within the device's warranty range, then free support may be provided and a case can be opened. The other avenue is to charge the customer a one-time non-refundable per incident support charge of $74.99. This charge is to cover the time the engineer spends troubleshooting the device and DOES NOT guarantee a fix. If at the end of the support call, the engineer determines the hardware is defective, NO RMA WILL BE PROVIDED since the device is no longer under warranty. The case will be closed at that point and no further support for that device will be provided under that case number.

The "legalese" of what was just briefly outlined can be found in the PDF I attached to the post.

HTH,

Bill

Samir Darji Mon, 04/01/2013 - 11:12

So, I somehow neglected to update this thread with what really happened.

The new rv016 which runs v2 hardware and firmware 3.0.0.19 would reboot almost constantly when all 3 cable modems of 25/5 where connected.  The same would be for my existing rv016 with 3.0.0.19.  Nothing was wrong with my original rv016.

The issue was caused by over 100 packets/sec being sent from Knology to "check the cable modem status" (according to them).  These packets cause the rv016 to think it's under attack.  The only solution that worked was to put a router in front of the rv016 for each of the wan connections, thereby filtering the 100 packets/sec.  Even then, the rv016 would need to be rebooted every 8hrs or the DNS resolution stopped working.

Actions

This Discussion