CDP support on WiSM?? / Switchport trace

Unanswered Question
Jan 23rd, 2010

I am running WCS with 2 WiSM and 4 4404 WLC.

I just turn on CDP on all switches and router for switchport trace features on WCS.

When I tried to turn on CDP on access points I get message to turn on Global CDP features.   Problem seem to occur when I tried to turn on cdp on access points that are connect to WiSM.   I have no problem with 4404 controllers.

I am running  on

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
George Stefanick Sun, 01/24/2010 - 20:12

This is interesting. I think this means the WiSM wont respond to CDP !? Dont have a WiSM in front of me to test. I do know that i have WiSMs that DO show CDP neighbor information of the access points attached to the swicthes. In fact, this gets filtered to WCS. I just hit the duplex mode issue, so i know AP CDP neighboring does work on the WiSMs running code

zhenningx Mon, 01/25/2010 - 07:35

Yes I think this means wism, not APs. You cannot see wism as the CDP neighbour in 6500 switches, but you can see 440x WLCs as the CDP neighbour in switches.

At controller tab> CDP>, CDP is not enabled there. If you try to enable it, you will get an error message "CDP is not enabled on this controller".

under the Wireless tab> AP configuration>, CDP is enabled here and that is the CDP setting for APs.

We always using WCS to change AP names. We haven't see any issues.


kentislander Mon, 01/25/2010 - 06:17

Let me explain the problem that I have on CDP issue -

When I update access point to change ap name on Wireless Control System and click save,  I get error message which is "Failed to enable Cisco Discovery Protocol, Global CDP on controller is disabled."    I have to turn off Cisco Discovery Protocol features on this ap in order to make change.

To turn on CDP, I need to get on Wireless Lan Controller (WiSM) and check CDP features on access point page.  WLC did not submit error report.

Work around to change ap name, I have to do the change on WLC home page and run audit to refresh WCS from controller. I can not even use WCS controller templates to make changes on all ap unless I turn off CDP features.


On switchport trace -

I am getting error message related to WiSM and CDP.   I will post error message as soon as I see one.  (I have not been able catch rogue ap on our network using this method - It is possible that no one is plugging in rogue ap and am seeing lot of AP outside of our network.

Bernhard Kohl Fri, 02/26/2010 - 05:01

When trying to change the location of an AP from the WCS I got the same error on a combination WCS: / WiSM: whereas another system WCS: / WiSM: did fine.

jlhainy Tue, 10/26/2010 - 09:46

Interesting.  I am having the same problem on WiSM 7.0.98.

It looks like to me that this is something specific with the WiSM blades in various versions of code.  It appears to have been resolved in 6.0.x but re-introduced in 7.0.

It is a minor annoyance, but an annoyance none the less.

Norberto Salgado Fri, 04/08/2011 - 06:57


we are having the same issue. Do you guys know if there is a definitive fix for this? Or at least a bug ID?

Thank you.

Best regards,


jlhainy Mon, 04/11/2011 - 06:55

Well, for me, when I started introducing 3500i's into the environment, the behavior seemed to go away.  Since it was a minor annoyance, I really haven't pursued it much.  But, finding out if there is a bug ID would be a good idea.  That would tell us that Cisco at least knows the issue exists.


This Discussion

Related Content