Dual ISP, set ip next-hop issue

Unanswered Question
Jan 24th, 2010


I have a 2821 router with a T1 to ISP A, and a new ethernet connection to a cable provider.

We are using public IPs from the T1 provider, and want to route some of this traffic to the cable provider.  Since the cable provider cannot route ISP A's IPs, I have enabled NAT for the cable interface, and a route-map to send certain source IPs through the cable interface.

Traffic is getting caught up in the router and not getting out the cable interface, and need assistance in figuring out how to fix:

interface GigabitEthernet0/0.2
description Inside_Lan
encapsulation dot1Q 20
ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip policy route-map cable_provider
no cdp enable

interface GigabitEthernet0/1
description Cable_Provider
ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
zone-member security in-zone
ip route-cache flow
duplex auto
speed auto
no mop enabled

route-map cable_provider permit 10
match ip address 105
set ip next-hop

access-list 105 permit ip 0 any



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
huangedmc Sun, 01/24/2010 - 21:36

What's the subnet of your inside LAN?

Your Gi0/0.2 interface is configured as, but your ACL is matching

Could you also post the rest of your NAT configuration?

I only see ip nat inside & ip nat outside on your interfaces.

dbauman_wan Sun, 01/24/2010 - 21:44

Sorry, its

ip nat inside source list 10 interface GigabitEthernet0/1 overload

access-list 10 permit

When I do a show ip nat trans

I do see a bunch of translations with the inside global being gig 0/1 (cable provider) and inside local being the end-user IP


This Discussion